summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-05 18:17:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-05 18:17:32 +0000
commitb0dc2feab3271dbcb42df6e6d8a37138a90c44a1 (patch)
treeae02f159c125f183b2adae47fdf0e64357bf76a8 /doc/meson.build
parentReleasing debian version 1.1-2. (diff)
downloadlibnvme-b0dc2feab3271dbcb42df6e6d8a37138a90c44a1.tar.xz
libnvme-b0dc2feab3271dbcb42df6e6d8a37138a90c44a1.zip
Merging upstream version 1.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/doc/meson.build b/doc/meson.build
index d716c8b..60a92ed 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -85,7 +85,10 @@ if want_docs != 'false'
endforeach
else
if want_docs == 'all' or want_docs == 'man'
- install_subdir('man', install_dir: mandir)
+ list_pre_compiled = find_program('list-pre-compiled.sh')
+ m = run_command(list_pre_compiled, check: true)
+ man_pages = m.stdout().strip().split('\n')
+ install_data(man_pages, install_dir: mandir)
endif
endif
endif