summaryrefslogtreecommitdiffstats
path: root/libnvme
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-24 07:51:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-24 07:51:48 +0000
commit8d843cc9cc0e989d3929f204f77223cd08730c7a (patch)
tree1fcba17d10325d9d7ccb68b2eb48cd9bbba6a534 /libnvme
parentReleasing debian version 1.5-3. (diff)
downloadlibnvme-8d843cc9cc0e989d3929f204f77223cd08730c7a.tar.xz
libnvme-8d843cc9cc0e989d3929f204f77223cd08730c7a.zip
Merging upstream version 1.7.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libnvme')
-rw-r--r--libnvme/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/libnvme/meson.build b/libnvme/meson.build
index 12a601e..b5b99fc 100644
--- a/libnvme/meson.build
+++ b/libnvme/meson.build
@@ -67,16 +67,16 @@ if build_python_bindings
test_env.append('PYTHONMALLOC', 'malloc')
# Test section
- test('[Python] import libnvme', python3, args: ['-c', 'from libnvme import nvme'], env: test_env, depends: pynvme_clib)
+ test('python-import-libnvme', python3, args: ['-c', 'from libnvme import nvme'], env: test_env, depends: pynvme_clib)
py_tests = [
- [ 'create ctrl object', [ files('tests/create-ctrl-obj.py'), ] ],
- [ 'SIGSEGV during gc', [ files('tests/gc.py'), ] ],
- [ 'Read NBFT file', [ files('tests/test-nbft.py'), '--filename', join_paths(meson.current_source_dir(), 'tests', 'NBFT') ] ],
+ [ 'create-ctrl-object', [ files('tests/create-ctrl-obj.py'), ] ],
+ [ 'sigsegv-during-gc', [ files('tests/gc.py'), ] ],
+ [ 'read-nbft-file', [ files('tests/test-nbft.py'), '--filename', join_paths(meson.current_source_dir(), 'tests', 'NBFT') ] ],
]
foreach test: py_tests
description = test[0]
args = test[1]
- test('[Python] ' + description, python3, args: args, env: test_env, depends: pynvme_clib)
+ test('python-' + description, python3, args: args, env: test_env, depends: pynvme_clib)
endforeach
endif