summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-30 22:36:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-30 22:36:10 +0000
commit61d0a8bdffbbb7229776d2f4f2e79ed22d21551f (patch)
tree2e249969fedce45eb37ae6314ad167595900fe38 /meson.build
parentReleasing debian version 1.4-4. (diff)
downloadlibnvme-61d0a8bdffbbb7229776d2f4f2e79ed22d21551f.tar.xz
libnvme-61d0a8bdffbbb7229776d2f4f2e79ed22d21551f.zip
Merging upstream version 1.5.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build23
1 files changed, 16 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 007ffdc..77415eb 100644
--- a/meson.build
+++ b/meson.build
@@ -8,7 +8,7 @@
project(
'libnvme', ['c'],
meson_version: '>= 0.50.0',
- version: '1.4',
+ version: '1.5',
license: 'LGPL-2.1-or-later',
default_options: [
'c_std=gnu99',
@@ -16,6 +16,7 @@ project(
'buildtype=debug',
'prefix=/usr/local',
'sysconfdir=etc',
+ 'wrap_mode=nofallback'
]
)
@@ -41,7 +42,7 @@ version_tag = get_option('version-tag')
if version_tag != ''
conf.set('GIT_VERSION', '"@0@"'.format(version_tag))
else
- r = run_command('meson-vcs-tag.sh',
+ r = run_command('scripts/meson-vcs-tag.sh',
meson.current_source_dir(),
meson.project_version(),
check: true)
@@ -56,7 +57,7 @@ if get_option('json-c').disabled()
else
json_c_dep = dependency('json-c',
version: '>=0.13',
- required: true,
+ required: get_option('json-c'),
fallback : ['json-c', 'json_c_dep'])
endif
conf.set('CONFIG_JSONC', json_c_dep.found(), description: 'Is json-c required?')
@@ -215,7 +216,7 @@ conf.set10(
)
conf.set(
- 'HAVE_LIBNSS',
+ 'HAVE_NETDB',
cc.links(
'''#include <sys/types.h>
#include <sys/socket.h>
@@ -225,7 +226,7 @@ conf.set(
return getaddrinfo(argv[1], argv[2], &hints, &result);
}
''',
- name: 'libnss',
+ name: 'netdb',
),
description: 'Is network address and service translation available'
)
@@ -269,7 +270,7 @@ subdir('doc')
################################################################################
if meson.version().version_compare('>=0.53.0')
- summary_dict = {
+ path_dict = {
'prefixdir': prefixdir,
'sysconfdir': sysconfdir,
'bindir': bindir,
@@ -279,5 +280,13 @@ if meson.version().version_compare('>=0.53.0')
'libdir': libdir,
'build location': meson.current_build_dir(),
}
- summary(summary_dict)
+ summary(path_dict, section: 'Paths')
+ dep_dict = {
+ 'json-c': json_c_dep.found(),
+ 'OpenSSL': openssl_dep.found(),
+ 'keyutitls': keyutils_dep.found(),
+ 'libdbus': libdbus_dep.found(),
+ 'Python 3': py3_dep.found(),
+ }
+ summary(dep_dict, section: 'Dependencies')
endif