summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-04-03 07:38:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-04-03 07:38:52 +0000
commit90cf2208656c513b78a587e3e0f1f64144c0f209 (patch)
tree003a07f93ade469ca1e876018c1a0b133b478f3b /src/meson.build
parentReleasing debian version 1.3-1. (diff)
downloadlibnvme-90cf2208656c513b78a587e3e0f1f64144c0f209.tar.xz
libnvme-90cf2208656c513b78a587e3e0f1f64144c0f209.zip
Merging upstream version 1.4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 1186e81..3732f8c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -23,13 +23,16 @@ mi_sources = [
'nvme/mi-mctp.c',
]
-if conf.get('CONFIG_JSONC')
+if json_c_dep.found()
sources += 'nvme/json.c'
+else
+ sources += 'nvme/no-json.c'
endif
deps = [
json_c_dep,
openssl_dep,
+ keyutils_dep,
]
mi_deps = [