summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-30 22:36:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-30 22:36:10 +0000
commit61d0a8bdffbbb7229776d2f4f2e79ed22d21551f (patch)
tree2e249969fedce45eb37ae6314ad167595900fe38 /test/meson.build
parentReleasing debian version 1.4-4. (diff)
downloadlibnvme-61d0a8bdffbbb7229776d2f4f2e79ed22d21551f.tar.xz
libnvme-61d0a8bdffbbb7229776d2f4f2e79ed22d21551f.zip
Merging upstream version 1.5.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index d90f835..49cd1ac 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -65,3 +65,23 @@ uuid = executable(
)
test('uuid', uuid)
+
+if conf.get('HAVE_NETDB')
+ tree = executable(
+ 'tree',
+ ['tree.c'],
+ dependencies: libnvme_dep,
+ include_directories: [incdir, internal_incdir]
+ )
+
+ test('tree', tree)
+
+ test_util = executable(
+ 'test-util',
+ ['test-util.c'],
+ include_directories: [incdir, internal_incdir]
+ )
+ test('Test util.c', test_util)
+endif
+
+subdir('nbft')