summaryrefslogtreecommitdiffstats
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
new file mode 100644
index 0000000..f1f8ee5
--- /dev/null
+++ b/examples/meson.build
@@ -0,0 +1,34 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+#
+# This file is part of libnvme.
+# Copyright (c) 2021 Dell Inc.
+#
+# Authors: Martin Belanger <Martin.Belanger@dell.com>
+#
+executable(
+ 'telemetry-listen',
+ ['telemetry-listen.c'],
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)
+
+executable(
+ 'display-columnar',
+ ['display-columnar.c'],
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)
+
+executable(
+ 'display-tree',
+ ['display-tree.c'],
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)
+
+executable(
+ 'discover-loop',
+ ['discover-loop.c'],
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)