summaryrefslogtreecommitdiffstats
path: root/libnvme.spec.in
diff options
context:
space:
mode:
Diffstat (limited to 'libnvme.spec.in')
-rw-r--r--libnvme.spec.in57
1 files changed, 57 insertions, 0 deletions
diff --git a/libnvme.spec.in b/libnvme.spec.in
new file mode 100644
index 0000000..8a2e4e5
--- /dev/null
+++ b/libnvme.spec.in
@@ -0,0 +1,57 @@
+Name: @NAME@
+Version: @VERSION@
+Release: 0
+Summary: Linux-native nvme device management library
+
+License: @LICENSE@
+Source: %{name}-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-root
+URL: http://github.com/linux-nvme/libnvme
+
+BuildRequires: libuuid-devel
+BuildRequires: meson
+BuildRequires: gcc
+
+%description
+Provides library functions for accessing and managing nvme devices on a Linux
+system.
+
+%package devel
+Summary: Development files for Linux-native nvme
+Requires: libnvme
+Provides: libnvme.so.1
+
+%description devel
+This package provides header files to include and libraries to link with
+for Linux-native nvme device maangement.
+
+%prep
+%autosetup -c
+
+%build
+%meson
+%meson_build
+
+%install
+%meson_install
+
+%check
+%meson_test
+
+%files
+%defattr(-,root,root)
+%attr(0755,root,root) %{_libdir}/libnvme.so.*
+%doc COPYING
+
+%files devel
+%defattr(-,root,root)
+%attr(-,root,root) %{_includedir}/nvme/
+%attr(0644,root,root) %{_includedir}/libnvme.h
+%attr(0755,root,root) %{_libdir}/libnvme.so
+%attr(0644,root,root) %{_libdir}/libnvme.a
+%attr(0644,root,root) %{_libdir}/pkgconfig/*
+%attr(0644,root,root) %{_mandir}/man2/*
+
+%changelog
+* Thu Dec 12 2019 Keith Busch <kbusch@kernel.org> - 0.1
+- Initial version