summaryrefslogtreecommitdiffstats
path: root/libnvme/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libnvme/meson.build')
-rw-r--r--libnvme/meson.build17
1 files changed, 9 insertions, 8 deletions
diff --git a/libnvme/meson.build b/libnvme/meson.build
index e9589fc..4138df3 100644
--- a/libnvme/meson.build
+++ b/libnvme/meson.build
@@ -6,17 +6,17 @@
# Authors: Martin Belanger <Martin.Belanger@dell.com>
#
want_python = get_option('python')
-if want_python != 'false'
- python3 = import('python').find_installation('python3')
- py3_dep = python3.dependency(required: want_python == 'true')
- swig = find_program('swig', required: want_python == 'true')
- header_found = cc.has_header('Python.h', dependencies: py3_dep)
- have_python_support = py3_dep.found() and swig.found() and header_found
+if want_python.disabled()
+ build_python_bindings = false
else
- have_python_support = false
+ python3 = import('python').find_installation('python3')
+ py3_dep = python3.dependency(required: want_python)
+ swig = find_program('swig', required: want_python)
+ header_found = cc.has_header('Python.h', dependencies: py3_dep, required: want_python)
+ build_python_bindings = py3_dep.found() and swig.found() and header_found
endif
-if have_python_support
+if build_python_bindings
pymod_swig = custom_target(
'nvme.py',
input: ['nvme.i'],
@@ -62,6 +62,7 @@ if have_python_support
py_tests = [
[ 'create ctrl object', files('tests/create-ctrl-obj.py') ],
+ [ 'SIGSEGV during gc', files('tests/gc.py') ],
]
foreach test: py_tests
description = test[0]