summaryrefslogtreecommitdiffstats
path: root/libnvme/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libnvme/meson.build')
-rw-r--r--libnvme/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/libnvme/meson.build b/libnvme/meson.build
index c95444e..e9589fc 100644
--- a/libnvme/meson.build
+++ b/libnvme/meson.build
@@ -29,9 +29,9 @@ if have_python_support
pynvme_clib = python3.extension_module(
'_nvme',
pymod_swig[1],
- dependencies : py3_dep,
+ dependencies : [libnvme_dep, py3_dep],
include_directories: [incdir, internal_incdir],
- link_with: [libnvme, libccan],
+ link_with: [libccan],
install: true,
subdir: 'libnvme',
)
@@ -46,7 +46,7 @@ if have_python_support
configure_file(
input: '__init__.py',
output: '__init__.py',
- copy: true,
+ configuration: conf,
install_dir: python3.get_install_dir(pure: false, subdir: 'libnvme'),
)