summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 00c9ceb..d90f835 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -12,7 +12,7 @@
main = executable(
'main-test',
['test.c'],
- dependencies: [libnvme_dep, libuuid_dep],
+ dependencies: [libnvme_dep],
include_directories: [incdir, internal_incdir]
)
@@ -56,3 +56,12 @@ mi_mctp = executable(
)
test('mi-mctp', mi_mctp)
+
+uuid = executable(
+ 'test-uuid',
+ ['uuid.c'],
+ dependencies: libnvme_dep,
+ include_directories: [incdir, internal_incdir]
+)
+
+test('uuid', uuid)