summaryrefslogtreecommitdiffstats
path: root/.travis.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-08-14 16:58:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 10:11:48 +0000
commit4edd467b28c895483cd5468d51d1c6824a21715a (patch)
tree04a4f32d617905acfc23653025b6e8d3899f51c6 /.travis.yml
parentInitial commit. (diff)
downloadlitecli-4edd467b28c895483cd5468d51d1c6824a21715a.tar.xz
litecli-4edd467b28c895483cd5468d51d1c6824a21715a.zip
Adding upstream version 1.5.0.upstream/1.5.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml29
1 files changed, 29 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..896e7f7
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,29 @@
+language: python
+python:
+ - "3.6"
+
+matrix:
+ include:
+ - python: 3.7
+ dist: xenial
+ sudo: true
+
+install:
+ - pip install -r requirements-dev.txt
+ - if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then pip install black; fi
+ - pip install -e .
+
+script:
+ - ./setup.py test --pytest-args="--cov-report= --cov=litecli"
+ - coverage report
+ - if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then ./setup.py lint; fi
+
+after_success:
+ - codecov
+
+notifications:
+ webhooks:
+ urls:
+ - YOUR_WEBHOOK_URL
+ on_success: change # options: [always|never|change] default: always
+ on_failure: always # options: [always|never|change] default: always