summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-11-27 21:24:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-11-27 21:24:53 +0000
commit9042b07cb1884b4a9ab2958ffa425d15069127fb (patch)
tree4c5d5aa16b47bbe0ec150d47a8be8dca40d52c72 /pyproject.toml
parentReleasing debian version 1.12.4-1. (diff)
downloadlitecli-9042b07cb1884b4a9ab2958ffa425d15069127fb.tar.xz
litecli-9042b07cb1884b4a9ab2958ffa425d15069127fb.zip
Merging upstream version 1.13.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 9 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 55dc144..5caeb84 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,10 +4,8 @@ dynamic = ["version"]
description = "CLI for SQLite Databases with auto-completion and syntax highlighting."
readme = "README.md"
requires-python = ">=3.7"
-license = {text = "BSD"}
-authors = [
- {name = "dbcli", email = "litecli-users@googlegroups.com"}
-]
+license = { text = "BSD" }
+authors = [{ name = "dbcli", email = "litecli-users@googlegroups.com" }]
urls = { "homepage" = "https://github.com/dbcli/litecli" }
dependencies = [
"cli-helpers[styles]>=2.2.1",
@@ -19,9 +17,15 @@ dependencies = [
]
[build-system]
-requires = ["setuptools >= 61.0"]
+requires = [
+ "setuptools>=64.0",
+ "setuptools-scm>=8;python_version>='3.8'",
+ "setuptools-scm<8;python_version<'3.8'",
+]
build-backend = "setuptools.build_meta"
+[tool.setuptools_scm]
+
[project.scripts]
litecli = "litecli.main:cli"
@@ -42,8 +46,5 @@ exclude = ["screenshots", "tests*"]
[tool.setuptools.package-data]
litecli = ["liteclirc", "AUTHORS"]
-[tool.setuptools.dynamic]
-version = {attr = "litecli.__version__"}
-
[tool.ruff]
line-length = 140