summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-23 05:17:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-23 05:17:11 +0000
commit7e445aeab02f28b8020e60ec3695183b738b4f58 (patch)
tree614aa1cdea21ea177f354a638f5a6584bce0d294 /Makefile.in
parentReleasing debian version 1.3-2. (diff)
downloadlzd-7e445aeab02f28b8020e60ec3695183b738b4f58.tar.xz
lzd-7e445aeab02f28b8020e60ec3695183b738b4f58.zip
Merging upstream version 1.4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index ced714d..120a41b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -24,15 +24,18 @@ $(progname) : $(objs)
%.o : %.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -DPROGVERSION=\"$(pkgversion)\" -c -o $@ $<
-$(objs) : Makefile
+# prevent 'make' from trying to remake source files
+$(VPATH)/configure $(VPATH)/Makefile.in $(VPATH)/doc/$(pkgname).texi : ;
+%.h %.cc : ;
+$(objs) : Makefile
doc :
info : $(VPATH)/doc/$(pkgname).info
$(VPATH)/doc/$(pkgname).info : $(VPATH)/doc/$(pkgname).texi
- cd $(VPATH)/doc && makeinfo $(pkgname).texi
+ cd $(VPATH)/doc && $(MAKEINFO) $(pkgname).texi
man : $(VPATH)/doc/$(progname).1