summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-29 02:17:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-29 02:24:31 +0000
commitbfcb5b8c5c1860c328e93dc7f3c5b45b4e603aef (patch)
tree0e85819feb593f483ad60a06d46525509e67292e /debian
parentReleasing debian version 1.2-2. (diff)
downloadlzd-bfcb5b8c5c1860c328e93dc7f3c5b45b4e603aef.tar.xz
lzd-bfcb5b8c5c1860c328e93dc7f3c5b45b4e603aef.zip
Removing lzd from lzip alternatives as it doesn't provide the '--test' parameter to verify compressed file integrity (which now is the base-line requirement for all lzip variants providing alternatives).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/lzd.postinst32
-rwxr-xr-xdebian/lzd.prerm29
-rwxr-xr-xdebian/rules5
4 files changed, 0 insertions, 70 deletions
diff --git a/debian/control b/debian/control
index 59f6f1b..04da071 100644
--- a/debian/control
+++ b/debian/control
@@ -16,10 +16,6 @@ Architecture: any
Depends:
${misc:Depends},
${shlibs:Depends},
-Provides:
- lzip-alternative,
- lzip-compressor,
- lzip-decompressor,
Description: Educational, lossless data compressor based on the LZMA algorithm
Lzip is a lossless data compressor based on the LZMA algorithm, with very safe
integrity checking and a user interface similar to the one of gzip or bzip2.
diff --git a/debian/lzd.postinst b/debian/lzd.postinst
deleted file mode 100755
index 877e3c1..0000000
--- a/debian/lzd.postinst
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-
-set -e
-
-case "${1}" in
- configure)
- # lzip-alternative
- update-alternatives --quiet \
- --install /usr/bin/lzip lzip /usr/bin/lzip.lzd -2000
-
- # lzip-compressor
- update-alternatives --quiet \
- --install /usr/bin/lzip-compressor lzip-compressor /usr/bin/lzip.lzd -2000
-
- # lzip-decompressor
- update-alternatives --quiet \
- --install /usr/bin/lzip-decompressor lzip-decompressor /usr/bin/lzip.lzd -2000
- ;;
-
- abort-upgrade|abort-remove|abort-deconfigure)
-
- ;;
-
- *)
- echo "postinst called with unknown argument \`${1}'" >&2
- exit 1
- ;;
-esac
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/lzd.prerm b/debian/lzd.prerm
deleted file mode 100755
index 3ad403d..0000000
--- a/debian/lzd.prerm
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-set -e
-
-case "${1}" in
- remove|upgrade|deconfigure)
- # lzip-alternative
- update-alternatives --quiet --remove lzip /usr/bin/lzip.lzd
-
- # lzip-compressor
- update-alternatives --quiet --remove lzip-compressor /usr/bin/lzip.lzd
-
- # lzip-decompressor
- update-alternatives --quiet --remove lzip-decompressor /usr/bin/lzip.lzd
- ;;
-
- failed-upgrade)
-
- ;;
-
- *)
- echo "prerm called with unknown argument \`${1}'" >&2
- exit 1
- ;;
-esac
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/rules b/debian/rules
index 1315012..336cf54 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,8 +10,3 @@ override_dh_auto_configure:
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/lzd
-
-execute_after_dh_auto_install:
- # update-alternatives
- mv debian/lzd/usr/bin/lzd debian/lzd/usr/bin/lzip.lzd
- ln -s /usr/bin/lzip.lzd debian/lzd/usr/bin/lzd