summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 07:49:43 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 07:49:43 +0000
commit083c902a1bf6cd876dd4f683b7936a8246ec0cd9 (patch)
treea92dad44f2bad587e83d4080a70414d089367286 /Makefile.in
parentAdding debian version 1.10-1. (diff)
downloadlzip-083c902a1bf6cd876dd4f683b7936a8246ec0cd9.tar.xz
lzip-083c902a1bf6cd876dd4f683b7936a8246ec0cd9.zip
Merging upstream version 1.11.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in36
1 files changed, 22 insertions, 14 deletions
diff --git a/Makefile.in b/Makefile.in
index e88a1b6..c366eb3 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -6,7 +6,8 @@ INSTALL_DATA = $(INSTALL) -p -m 644
INSTALL_DIR = $(INSTALL) -d -m 755
SHELL = /bin/sh
-objs = arg_parser.o decoder.o encoder.o main.o
+objs = arg_parser.o decoder.o encoder.o fast_encoder.o main.o
+recobjs = arg_parser.o decoder.o lziprecover.o
.PHONY : all install install-info install-man install-strip \
@@ -21,8 +22,11 @@ $(progname) : $(objs)
$(progname)_profiled : $(objs)
$(CXX) $(LDFLAGS) -pg -o $(progname)_profiled $(objs)
-lziprecover : arg_parser.o lziprecover.o
- $(CXX) $(LDFLAGS) -o lziprecover arg_parser.o lziprecover.o
+lziprecover : $(recobjs)
+ $(CXX) $(LDFLAGS) -o lziprecover $(recobjs)
+
+unzcrash : testsuite/unzcrash.cc
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $<
main.o : main.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -DPROGVERSION=\"$(pkgversion)\" -c -o $@ $<
@@ -33,12 +37,14 @@ lziprecover.o : lziprecover.cc
%.o : %.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c -o $@ $<
-$(objs) : Makefile
-arg_parser.o : arg_parser.h
-decoder.o : lzip.h decoder.h
-encoder.o : lzip.h encoder.h
-main.o : arg_parser.h lzip.h decoder.h encoder.h
-lziprecover.o : arg_parser.h lzip.h Makefile
+$(objs) : Makefile
+arg_parser.o : arg_parser.h
+decoder.o : lzip.h decoder.h
+encoder.o : lzip.h encoder.h
+fast_encoder.o : lzip.h encoder.h fast_encoder.h
+main.o : arg_parser.h lzip.h decoder.h encoder.h fast_encoder.h
+lziprecover.o : arg_parser.h lzip.h decoder.h Makefile
+
doc : info man
@@ -50,18 +56,18 @@ $(VPATH)/doc/$(pkgname).info : $(VPATH)/doc/$(pkgname).texinfo
man : $(VPATH)/doc/$(progname).1 $(VPATH)/doc/lziprecover.1
$(VPATH)/doc/$(progname).1 : $(progname)
- help2man -n 'data compressor based on the LZMA algorithm' \
+ help2man -n 'reduces the size of files' \
-o $(VPATH)/doc/$(progname).1 ./$(progname)
$(VPATH)/doc/lziprecover.1 : lziprecover
- help2man -n 'recover undamaged members from lzip files' \
+ help2man -n 'recovers data from damaged lzip files' \
-o $(VPATH)/doc/lziprecover.1 --no-info ./lziprecover
Makefile : $(VPATH)/configure $(VPATH)/Makefile.in
./config.status
check : all
- @$(VPATH)/testsuite/check.sh $(VPATH)/testsuite
+ @$(VPATH)/testsuite/check.sh $(VPATH)/testsuite $(pkgversion)
install : all install-info install-man
if [ ! -d "$(DESTDIR)$(bindir)" ] ; then $(INSTALL_DIR) "$(DESTDIR)$(bindir)" ; fi
@@ -109,8 +115,10 @@ dist : doc
$(DISTNAME)/doc/$(pkgname).texinfo \
$(DISTNAME)/doc/lziprecover.1 \
$(DISTNAME)/testsuite/check.sh \
- $(DISTNAME)/testsuite/test1 \
- $(DISTNAME)/testsuite/test1.lz \
+ $(DISTNAME)/testsuite/test.txt \
+ $(DISTNAME)/testsuite/test_bad[1-5].lz \
+ $(DISTNAME)/testsuite/test_sync.lz \
+ $(DISTNAME)/testsuite/test_v[01].lz \
$(DISTNAME)/testsuite/unzcrash.cc \
$(DISTNAME)/*.h \
$(DISTNAME)/*.cc