summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-23 05:27:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-23 05:27:08 +0000
commita9dff770f27dfbcef3bf768146324b03c810bfb8 (patch)
treec4040dfa674320afbe30c1f673c5c49f6a066e7f /Makefile.in
parentReleasing debian version 1.23-6. (diff)
downloadlzip-a9dff770f27dfbcef3bf768146324b03c810bfb8.tar.xz
lzip-a9dff770f27dfbcef3bf768146324b03c810bfb8.zip
Merging upstream version 1.24~rc2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index d07ad5a..adf90e0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -28,6 +28,10 @@ main.o : main.cc
%.o : %.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c -o $@ $<
+# prevent 'make' from trying to remake source files
+$(VPATH)/configure $(VPATH)/Makefile.in $(VPATH)/doc/$(pkgname).texi : ;
+%.h %.cc : ;
+
$(objs) : Makefile
arg_parser.o : arg_parser.h
decoder.o : lzip.h decoder.h
@@ -38,13 +42,12 @@ list.o : lzip.h lzip_index.h
lzip_index.o : lzip.h lzip_index.h
main.o : arg_parser.h lzip.h decoder.h encoder_base.h encoder.h fast_encoder.h
-
doc : info man
info : $(VPATH)/doc/$(pkgname).info
$(VPATH)/doc/$(pkgname).info : $(VPATH)/doc/$(pkgname).texi
- cd $(VPATH)/doc && makeinfo $(pkgname).texi
+ cd $(VPATH)/doc && $(MAKEINFO) $(pkgname).texi
man : $(VPATH)/doc/$(progname).1
@@ -122,6 +125,8 @@ dist : doc
$(DISTNAME)/testsuite/test.txt \
$(DISTNAME)/testsuite/fox.lz \
$(DISTNAME)/testsuite/fox_*.lz \
+ $(DISTNAME)/testsuite/fox6.lz \
+ $(DISTNAME)/testsuite/fox6_mark.lz \
$(DISTNAME)/testsuite/test.txt.lz \
$(DISTNAME)/testsuite/test_em.txt.lz
rm -f $(DISTNAME)