summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2016-05-20 06:54:39 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2016-05-20 06:55:18 +0000
commit07c2a71a11edd637f0ec9b42b5c5621980c96562 (patch)
treeffe015da89db655e2f4edbabd6924e41b3971f02 /Makefile.in
parentAdding debian version 1.18~pre2-1. (diff)
downloadlziprecover-07c2a71a11edd637f0ec9b42b5c5621980c96562.tar.xz
lziprecover-07c2a71a11edd637f0ec9b42b5c5621980c96562.zip
Merging upstream version 1.18.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in45
1 files changed, 26 insertions, 19 deletions
diff --git a/Makefile.in b/Makefile.in
index 81b34a6..258ecc1 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -5,9 +5,10 @@ INSTALL_PROGRAM = $(INSTALL) -m 755
INSTALL_DATA = $(INSTALL) -m 644
INSTALL_DIR = $(INSTALL) -d -m 755
SHELL = /bin/sh
+CAN_RUN_INSTALLINFO = $(SHELL) -c "install-info --version" > /dev/null 2>&1
-objs = arg_parser.o block.o file_index.o merge.o mtester.o range_dec.o \
- repair.o split.o decoder.o main.o
+objs = arg_parser.o alone_to_lz.o block.o file_index.o merge.o mtester.o \
+ range_dec.o repair.o split.o decoder.o main.o
unzobjs = arg_parser.o unzcrash.o
@@ -34,18 +35,19 @@ unzcrash.o : unzcrash.cc
%.o : %.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c -o $@ $<
-$(objs) : Makefile
-arg_parser.o : arg_parser.h
-block.o : block.h
-decoder.o : lzip.h decoder.h
-file_index.o : lzip.h block.h file_index.h
-main.o : arg_parser.h lzip.h decoder.h block.h
-merge.o : lzip.h decoder.h block.h file_index.h
-mtester.o : lzip.h mtester.h
-range_dec.o : lzip.h decoder.h block.h file_index.h
-repair.o : lzip.h mtester.h block.h file_index.h
-split.o : lzip.h block.h file_index.h
-unzcrash.o : arg_parser.h Makefile
+$(objs) : Makefile
+alone_to_lz.o : lzip.h mtester.h
+arg_parser.o : arg_parser.h
+block.o : block.h
+decoder.o : lzip.h decoder.h
+file_index.o : lzip.h block.h file_index.h
+main.o : arg_parser.h lzip.h decoder.h block.h
+merge.o : lzip.h decoder.h block.h file_index.h
+mtester.o : lzip.h mtester.h
+range_dec.o : lzip.h decoder.h block.h file_index.h
+repair.o : lzip.h mtester.h block.h file_index.h
+split.o : lzip.h block.h file_index.h
+unzcrash.o : arg_parser.h Makefile
doc : info man
@@ -82,7 +84,9 @@ install-info :
if [ ! -d "$(DESTDIR)$(infodir)" ] ; then $(INSTALL_DIR) "$(DESTDIR)$(infodir)" ; fi
-rm -f "$(DESTDIR)$(infodir)/$(pkgname).info"*
$(INSTALL_DATA) $(VPATH)/doc/$(pkgname).info "$(DESTDIR)$(infodir)/$(pkgname).info"
- -install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$(pkgname).info"
+ -if $(CAN_RUN_INSTALLINFO) ; then \
+ install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$(pkgname).info" ; \
+ fi
install-info-compress : install-info
lzip -v -9 "$(DESTDIR)$(infodir)/$(pkgname).info"
@@ -105,7 +109,9 @@ uninstall-bin :
-rm -f "$(DESTDIR)$(bindir)/$(progname)"
uninstall-info :
- -install-info --info-dir="$(DESTDIR)$(infodir)" --remove "$(DESTDIR)$(infodir)/$(pkgname).info"
+ -if $(CAN_RUN_INSTALLINFO) ; then \
+ install-info --info-dir="$(DESTDIR)$(infodir)" --remove "$(DESTDIR)$(infodir)/$(pkgname).info" ; \
+ fi
-rm -f "$(DESTDIR)$(infodir)/$(pkgname).info"*
uninstall-man :
@@ -126,11 +132,12 @@ dist : doc
$(DISTNAME)/doc/$(pkgname).info \
$(DISTNAME)/doc/$(pkgname).texi \
$(DISTNAME)/testsuite/check.sh \
- $(DISTNAME)/testsuite/fox5.lz \
- $(DISTNAME)/testsuite/fox5_bad[1-5].lz \
- $(DISTNAME)/testsuite/fox5_bad1.txt \
+ $(DISTNAME)/testsuite/fox6.lz \
+ $(DISTNAME)/testsuite/fox6_bad[1-5].lz \
+ $(DISTNAME)/testsuite/fox6_bad1.txt \
$(DISTNAME)/testsuite/test.txt \
$(DISTNAME)/testsuite/test.txt.lz \
+ $(DISTNAME)/testsuite/test.txt.lzma \
$(DISTNAME)/testsuite/test21723.txt \
$(DISTNAME)/testsuite/test_bad[1-5].lz \
$(DISTNAME)/*.h \