summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in41
1 files changed, 22 insertions, 19 deletions
diff --git a/Makefile.in b/Makefile.in
index 76c06cc..48c8448 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -7,8 +7,8 @@ INSTALL_DIR = $(INSTALL) -d -m 755
SHELL = /bin/sh
CAN_RUN_INSTALLINFO = $(SHELL) -c "install-info --version" > /dev/null 2>&1
-objs = arg_parser.o alone_to_lz.o block.o file_index.o list.o merge.o \
- mtester.o range_dec.o repair.o split.o trailing_data.o decoder.o main.o
+objs = arg_parser.o alone_to_lz.o lzip_index.o list.o dump_remove.o \
+ merge.o mtester.o range_dec.o repair.o split.o decoder.o main.o
unzobjs = arg_parser.o unzcrash.o
@@ -36,21 +36,20 @@ unzcrash.o : unzcrash.cc
%.o : %.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c -o $@ $<
-$(objs) : Makefile
-alone_to_lz.o : lzip.h mtester.h
-arg_parser.o : arg_parser.h
-block.o : block.h
-decoder.o : lzip.h decoder.h
-file_index.o : lzip.h block.h file_index.h
-list.o : lzip.h block.h file_index.h
-main.o : arg_parser.h lzip.h decoder.h block.h main_common.cc
-merge.o : lzip.h decoder.h block.h file_index.h
-mtester.o : lzip.h mtester.h
-range_dec.o : lzip.h decoder.h block.h file_index.h
-repair.o : lzip.h mtester.h block.h file_index.h
-split.o : lzip.h block.h file_index.h
-trailing_data.o : lzip.h block.h file_index.h
-unzcrash.o : Makefile arg_parser.h main_common.cc
+$(objs) : Makefile
+alone_to_lz.o : lzip.h mtester.h
+arg_parser.o : arg_parser.h
+decoder.o : lzip.h decoder.h
+dump_remove.o : lzip.h lzip_index.h
+list.o : lzip.h lzip_index.h
+lzip_index.o : lzip.h lzip_index.h
+main.o : arg_parser.h lzip.h decoder.h main_common.cc
+merge.o : lzip.h decoder.h lzip_index.h
+mtester.o : lzip.h mtester.h
+range_dec.o : lzip.h decoder.h lzip_index.h
+repair.o : lzip.h mtester.h lzip_index.h
+split.o : lzip.h lzip_index.h
+unzcrash.o : Makefile arg_parser.h main_common.cc
doc : info man
@@ -137,11 +136,15 @@ dist : doc
$(DISTNAME)/*.h \
$(DISTNAME)/*.cc \
$(DISTNAME)/testsuite/check.sh \
- $(DISTNAME)/testsuite/fox6.lz \
- $(DISTNAME)/testsuite/fox6_bad[1-5].lz \
$(DISTNAME)/testsuite/fox6_bad1.txt \
$(DISTNAME)/testsuite/test.txt \
$(DISTNAME)/testsuite/test21723.txt \
+ $(DISTNAME)/testsuite/fox.lz \
+ $(DISTNAME)/testsuite/fox6.lz \
+ $(DISTNAME)/testsuite/fox6_sc[1-6].lz \
+ $(DISTNAME)/testsuite/fox6_bad[1-6].lz \
+ $(DISTNAME)/testsuite/numbers.lz \
+ $(DISTNAME)/testsuite/numbersbt.lz \
$(DISTNAME)/testsuite/test.txt.lz \
$(DISTNAME)/testsuite/test.txt.lzma \
$(DISTNAME)/testsuite/test_bad[1-5].lz