summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-28 18:40:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-28 19:45:00 +0000
commita86b6e1d44a143b82ca689024d81ddf220656216 (patch)
treee764874c1c7f47f0b1bd26ff8d706458e2135a7f
parentMerging upstream version 4.2+20230227. (diff)
downloadmdadm-a86b6e1d44a143b82ca689024d81ddf220656216.tar.xz
mdadm-a86b6e1d44a143b82ca689024d81ddf220656216.zip
Removing sysvinit scripts in favour of systemd units.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/mdadm-waitidle60
-rw-r--r--debian/mdadm.init100
-rw-r--r--debian/mdadm.links2
-rw-r--r--debian/mdadm.maintscript2
-rwxr-xr-xdebian/rules7
5 files changed, 2 insertions, 169 deletions
diff --git a/debian/mdadm-waitidle b/debian/mdadm-waitidle
deleted file mode 100644
index b986f1e..0000000
--- a/debian/mdadm-waitidle
+++ /dev/null
@@ -1,60 +0,0 @@
-#!/bin/sh
-# This script is not used when systemd is running
-### BEGIN INIT INFO
-# Provides: mdadm-waitidle
-# Required-Start:
-# Required-Stop:
-# Should-Stop: halt reboot kexec
-# X-Stop-After: umountroot
-# Default-Start:
-# Default-Stop: 0 6
-# Short-Description: Wait for MD arrays to become idle
-# Description: Waits until all MD arrays are in idle and synced state
-# before halt/reboot.
-### END INIT INFO
-#
-set -eu
-
-MDADM=/sbin/mdadm
-test -x "$MDADM" || exit 0
-test -f /proc/mdstat || exit 0
-
-. /lib/lsb/init-functions
-
-case "${1:-}" in
-
- start|restart|force-reload)
- # nothing, the only reason the script is here is to stop arrays
- ;;
-
- stop)
- sync
- wait=
- for md in /sys/block/md*/md ; do
- [ -d "$md" ] || continue
- [ "$wait" ] || log_action_begin_msg "Waiting for MD arrays to become idle"
- wait=y
- [ -w $md/sync_action ] && echo idle > $md/sync_action
- done
- if [ "$wait" ]; then
- # mdadm --wait-clean has a short internal timeout
- if $MDADM --wait-clean --scan; then
- log_action_end_msg 0
- else
- log_action_end_msg 1
- sleep 1
- fi
- fi
- ;;
-
- status)
- status_of_proc /usr/bin/$NAME $NAME
- ;;
-
- *)
- echo "Usage: ${0:-} stop" >&2
- exit 1;;
-
-esac
-
-exit 0
diff --git a/debian/mdadm.init b/debian/mdadm.init
deleted file mode 100644
index 0a9004f..0000000
--- a/debian/mdadm.init
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/bin/sh
-#
-# Start the MD monitor daemon for all active MD arrays if desired.
-# This script is not used under systemd.
-#
-# Copyright © 2001-2005 Mario Jou/3en <joussen@debian.org>
-# Copyright © 2005-2009 Martin F. Krafft <madduck@debian.org>
-# Distributable under the terms of the GNU GPL version 2.
-#
-### BEGIN INIT INFO
-# Provides: mdadm
-# Required-Start: $local_fs $syslog
-# Required-Stop: $local_fs $syslog sendsigs
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: MD monitoring daemon
-# Description: mdadm provides a monitor mode, in which it will scan for
-# problems with the MD devices. If a problem is found, the
-# administrator is alerted via email, or a custom script is
-# run.
-### END INIT INFO
-#
-set -eu
-
-MDADM=/sbin/mdadm
-MDMON=/sbin/mdmon
-RUNDIR=/run/mdadm
-PIDFILE=$RUNDIR/monitor.pid
-DEBIANCONFIG=/etc/default/mdadm
-
-test -x "$MDADM" || exit 0
-
-test -f /proc/mdstat || exit 0
-
-START_DAEMON=true
-test -f $DEBIANCONFIG && . $DEBIANCONFIG
-
-. /lib/lsb/init-functions
-
-is_true()
-{
- case "${1:-}" in
- [Yy]es|[Yy]|1|[Tt]|[Tt]rue) return 0;;
- *) return 1;
- esac
-}
-
-case "${1:-}" in
- start)
- if [ -x /usr/bin/systemd-detect-virt ] && /usr/bin/systemd-detect-virt --quiet --container; then
- log_daemon_msg "Not starting MD monitoring service in container"
- log_end_msg 0
- exit 0
- fi
-
- if is_true $START_DAEMON; then
- log_daemon_msg "Starting MD monitoring service" "mdadm --monitor"
- mkdir -p $RUNDIR
- set +e
- start-stop-daemon -S -p $PIDFILE -x $MDADM -- \
- --monitor --pid-file $PIDFILE --daemonise --scan ${DAEMON_OPTIONS:-}
- log_end_msg $?
- set -e
- fi
- if [ "$(echo $RUNDIR/md[0-9]*.pid)" != "$RUNDIR/md[0-9]*.pid" ]; then
- log_daemon_msg "Restarting MD external metadata monitor" "mdmon --takeover --all"
- set +e
- $MDMON --takeover --all
- log_end_msg $?
- set -e
- fi
- ;;
- stop)
- if [ -f $PIDFILE ] ; then
- log_daemon_msg "Stopping MD monitoring service" "mdadm --monitor"
- set +e
- start-stop-daemon -K -p $PIDFILE -x $MDADM
- rm -f $PIDFILE
- log_end_msg $?
- set -e
- fi
- for file in $RUNDIR/md[0-9]*.pid ; do
- [ ! -f "$file" ] && continue
- ln -sf $file /run/sendsigs.omit.d/mdmon-${file##*/}
- done
- ;;
- status)
- status_of_proc -p $PIDFILE "$MDADM" "mdadm" && exit 0 || exit $?
- ;;
- restart|reload|force-reload)
- ${0:-} stop
- ${0:-} start
- ;;
- *)
- echo "Usage: ${0:-} {start|stop|status|restart|reload|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/debian/mdadm.links b/debian/mdadm.links
deleted file mode 100644
index 4acdaf5..0000000
--- a/debian/mdadm.links
+++ /dev/null
@@ -1,2 +0,0 @@
-/dev/null lib/systemd/system/mdadm-waitidle.service
-/dev/null lib/systemd/system/mdadm.service
diff --git a/debian/mdadm.maintscript b/debian/mdadm.maintscript
new file mode 100644
index 0000000..1298978
--- /dev/null
+++ b/debian/mdadm.maintscript
@@ -0,0 +1,2 @@
+rm_conffile /etc/init.d/mdadm 4.2+20230227-1~
+rm_conffile /etc/init.d/mdadm-waitidle 4.2+20230227-1~
diff --git a/debian/rules b/debian/rules
index 52a71b8..fd82966 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,10 +31,3 @@ override_dh_install:
mkdir -p $(CURDIR)/debian/mdadm/etc/mdadm
chmod +x $(CURDIR)/debian/mdadm/usr/share/mdadm/mdcheck
-
-override_dh_installsystemd:
- dh_installsystemd --name mdadm-shutdown
-
-override_dh_installinit:
- dh_installinit --init-script=mdadm-waitidle --no-start -- stop 98 0 6 .
- dh_installinit -- defaults 25