summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/0007-no-Werror.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-25 17:53:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-25 17:53:24 +0000
commita80fd9d5075a448b17b9dde111ce958738ddcf81 (patch)
tree1e34b241d7cf213290c2ae73256f3c479c84fdfe /debian/patches/debian/0007-no-Werror.patch
parentRefreshing readlink-path.patch. (diff)
downloadmdadm-a80fd9d5075a448b17b9dde111ce958738ddcf81.tar.xz
mdadm-a80fd9d5075a448b17b9dde111ce958738ddcf81.zip
Refreshing no-Werror.patch.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/debian/0007-no-Werror.patch')
-rw-r--r--debian/patches/debian/0007-no-Werror.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/patches/debian/0007-no-Werror.patch b/debian/patches/debian/0007-no-Werror.patch
new file mode 100644
index 0000000..2321e26
--- /dev/null
+++ b/debian/patches/debian/0007-no-Werror.patch
@@ -0,0 +1,18 @@
+Author: Martin F. Krafft <madduck@debian.org>
+Description: Remove -Werror from compiler flags.
+ -Werror seems like a bad idea on released/packaged code because a toolchain
+ update (introducing new warnings) could break the build. We'll let upstream
+ use it to beautify the code, but remove it for out builds.
+
+diff -Naurp mdadm.orig/Makefile mdadm/Makefile
+--- mdadm.orig/Makefile
++++ mdadm/Makefile
+@@ -50,7 +50,7 @@ ifeq ($(origin CC),default)
+ CC := $(CROSS_COMPILE)gcc
+ endif
+ CXFLAGS ?= -ggdb
+-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
++CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
+ ifdef WARN_UNUSED
+ CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
+ endif