summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-07 09:38:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-09-07 09:39:08 +0000
commitf0ae12072ba1868526f2ae57615538777d9538f4 (patch)
treef639c1078fc22f434d074470d7b50f58f0ac6e4e /setup.py
parentReleasing debian version 1.25.0-1. (diff)
downloadmycli-f0ae12072ba1868526f2ae57615538777d9538f4.tar.xz
mycli-f0ae12072ba1868526f2ae57615538777d9538f4.zip
Merging upstream version 1.26.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index a44289a..2f69672 100755
--- a/setup.py
+++ b/setup.py
@@ -18,12 +18,15 @@ description = 'CLI for MySQL Database. With auto-completion and syntax highlight
install_requirements = [
'click >= 7.0',
- 'cryptography >= 1.0.0',
+ # Temporary to suppress paramiko Blowfish warning which breaks CI.
+ # Pinning cryptography should not be needed after paramiko 2.11.0.
+ 'cryptography == 36.0.2',
# 'Pygments>=1.6,<=2.11.1',
'Pygments>=1.6',
'prompt_toolkit>=3.0.6,<4.0.0',
'PyMySQL >= 0.9.2',
'sqlparse>=0.3.0,<0.5.0',
+ 'sqlglot>=5.1.3',
'configobj >= 5.0.5',
'cli_helpers[styles] >= 2.2.1',
'pyperclip >= 1.8.1',
@@ -101,16 +104,17 @@ setup(
'console_scripts': ['mycli = mycli.main:cli'],
},
cmdclass={'lint': lint, 'test': test},
- python_requires=">=3.6",
+ python_requires=">=3.7",
classifiers=[
'Intended Audience :: Developers',
'License :: OSI Approved :: BSD License',
'Operating System :: Unix',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: SQL',
'Topic :: Database',
'Topic :: Database :: Front-Ends',