summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 08:07:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 08:07:38 +0000
commitf6a576f0ec04a9b2fa2982e2e9188d874bbd156c (patch)
tree2224798b59442d1e4f6124afdbba2aafa6984fc1 /setup.py
parentReleasing debian version 1.26.1-3. (diff)
downloadmycli-f6a576f0ec04a9b2fa2982e2e9188d874bbd156c.tar.xz
mycli-f6a576f0ec04a9b2fa2982e2e9188d874bbd156c.zip
Merging upstream version 1.27.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 2f69672..2c4f9e1 100755
--- a/setup.py
+++ b/setup.py
@@ -18,9 +18,8 @@ description = 'CLI for MySQL Database. With auto-completion and syntax highlight
install_requirements = [
'click >= 7.0',
- # Temporary to suppress paramiko Blowfish warning which breaks CI.
- # Pinning cryptography should not be needed after paramiko 2.11.0.
- 'cryptography == 36.0.2',
+ # Pinning cryptography is not needed after paramiko 2.11.0. Correct it
+ 'cryptography >= 1.0.0',
# 'Pygments>=1.6,<=2.11.1',
'Pygments>=1.6',
'prompt_toolkit>=3.0.6,<4.0.0',
@@ -95,7 +94,7 @@ setup(
author_email='mycli-dev@googlegroups.com',
version=version,
url='http://mycli.net',
- packages=find_packages(),
+ packages=find_packages(exclude=['test*']),
package_data={'mycli': ['myclirc', 'AUTHORS', 'SPONSORS']},
description=description,
long_description=description,