summaryrefslogtreecommitdiffstats
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml33
1 files changed, 0 insertions, 33 deletions
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 0afb5cc..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,33 +0,0 @@
-language: python
-python:
- - "3.6"
- - "3.7"
- - "3.8"
-
-matrix:
- include:
- - python: 3.7
- dist: xenial
- sudo: true
-
-install:
- - pip install -r requirements-dev.txt
- - pip install -e .
- - sudo rm -f /etc/mysql/conf.d/performance-schema.cnf
- - sudo service mysql restart
-
-script:
- - ./setup.py test --pytest-args="--cov-report= --cov=mycli"
- - coverage combine
- - coverage report
- - ./setup.py lint --branch=$TRAVIS_BRANCH
-
-after_success:
- - codecov
-
-notifications:
- webhooks:
- urls:
- - YOUR_WEBHOOK_URL
- on_success: change # options: [always|never|change] default: always
- on_failure: always # options: [always|never|change] default: always