summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 156cd1a..4aa7f91 100755
--- a/setup.py
+++ b/setup.py
@@ -19,12 +19,13 @@ description = 'CLI for MySQL Database. With auto-completion and syntax highlight
install_requirements = [
'click >= 7.0',
'Pygments >= 1.6',
- 'prompt_toolkit>=3.0.0,<4.0.0',
+ 'prompt_toolkit>=3.0.6,<4.0.0',
'PyMySQL >= 0.9.2',
'sqlparse>=0.3.0,<0.4.0',
'configobj >= 5.0.5',
'cryptography >= 1.0.0',
- 'cli_helpers[styles] > 1.1.0',
+ 'cli_helpers[styles] >= 2.0.1',
+ 'pyperclip >= 1.8.1'
]
@@ -65,7 +66,7 @@ class test(TestCommand):
def initialize_options(self):
TestCommand.initialize_options(self)
self.pytest_args = ''
- self.behave_args = ''
+ self.behave_args = '--no-capture'
def run_tests(self):
unit_test_errno = subprocess.call(
@@ -76,6 +77,7 @@ class test(TestCommand):
'behave test/features ' + self.behave_args,
shell=True
)
+ subprocess.run(['git', 'checkout', '--', 'test/myclirc'], check=False)
sys.exit(unit_test_errno or cli_errno)