summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-08-17 06:38:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-08-17 06:38:54 +0000
commit5a81b5757d89e7076e24e2191cb4fdff3d438a88 (patch)
tree74a8f7baa4f17d529cdcdf6ee28f7ad5d4322650
parentReleasing debian version 1.36.0-1. (diff)
downloadnetdata-5a81b5757d89e7076e24e2191cb4fdff3d438a88.tar.xz
netdata-5a81b5757d89e7076e24e2191cb4fdff3d438a88.zip
Merging upstream version 1.36.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--.github/workflows/build.yml4
-rw-r--r--CHANGELOG.md26
-rw-r--r--contrib/debian/netdata.postinst4
-rw-r--r--database/rrdcontext.c14
-rw-r--r--database/sqlite/sqlite_context.c8
-rwxr-xr-xnetdata-installer.sh3
-rw-r--r--netdata.spec.in3
-rwxr-xr-xpackaging/makeself/install-or-update.sh4
-rw-r--r--packaging/version2
9 files changed, 45 insertions, 23 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index 2b31cc26..26849312 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -36,7 +36,7 @@ jobs:
id: fix-tags
if: github.event_name != 'push'
run: |
- git fetch -f origin ${{ github.ref }}:${{ github.ref }}
+ git fetch --tags --force
- name: Mark Stable
id: channel
if: github.event_name == 'workflow_dispatch' && github.event.inputs.type != 'nightly'
@@ -111,7 +111,7 @@ jobs:
id: fix-tags
if: github.event_name != 'push'
run: |
- git fetch -f origin ${{ github.ref }}:${{ github.ref }}
+ git fetch --tags --force
- name: Mark Stable
id: channel
if: github.event_name == 'workflow_dispatch' && github.event.inputs.type != 'nightly'
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 53ab78a0..69f48ec5 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,22 @@
# Changelog
+## [v1.36.1](https://github.com/netdata/netdata/tree/v1.36.1) (2022-08-15)
+
+[Full Changelog](https://github.com/netdata/netdata/compare/v1.36.0...v1.36.1)
+
+**Merged pull requests:**
+
+- fix\(ci\): fix fetching tags in Build workflow [\#13517](https://github.com/netdata/netdata/pull/13517) ([ilyam8](https://github.com/ilyam8))
+- docs\(postfix\): add a note about `authorized_mailq_users` [\#13515](https://github.com/netdata/netdata/pull/13515) ([ilyam8](https://github.com/ilyam8))
+- Remove extra U from log message [\#13514](https://github.com/netdata/netdata/pull/13514) ([uplime](https://github.com/uplime))
+- Print rrdcontexts versions with PRIu64 [\#13511](https://github.com/netdata/netdata/pull/13511) ([MrZammler](https://github.com/MrZammler))
+- Calculate name hash after rrdvar\_fix\_name [\#13509](https://github.com/netdata/netdata/pull/13509) ([MrZammler](https://github.com/MrZammler))
+- fix\(packaging\): add CAP\_NET\_ADMIN for go.d.plugin [\#13507](https://github.com/netdata/netdata/pull/13507) ([ilyam8](https://github.com/ilyam8))
+- netdata.service: Update PIDFile to avoid systemd legacy path warning [\#13504](https://github.com/netdata/netdata/pull/13504) ([candrews](https://github.com/candrews))
+- chore\(python.d\): remove python.d/\* announced in v1.36.0 deprecation notice [\#13503](https://github.com/netdata/netdata/pull/13503) ([ilyam8](https://github.com/ilyam8))
+- reduce memcpy and memory usage on mqtt5 [\#13450](https://github.com/netdata/netdata/pull/13450) ([underhood](https://github.com/underhood))
+- Modify PID monitoring \(ebpf.plugin\) [\#13397](https://github.com/netdata/netdata/pull/13397) ([thiagoftsm](https://github.com/thiagoftsm))
+
## [v1.36.0](https://github.com/netdata/netdata/tree/v1.36.0) (2022-08-10)
[Full Changelog](https://github.com/netdata/netdata/compare/v1.35.1...v1.36.0)
@@ -328,15 +345,6 @@
- feat\(proc/cgroups.plugin\): add PSI stall time charts [\#12869](https://github.com/netdata/netdata/pull/12869) ([ilyam8](https://github.com/ilyam8))
- Update README.md [\#12868](https://github.com/netdata/netdata/pull/12868) ([tkatsoulas](https://github.com/tkatsoulas))
- fix for negative per job busy time [\#12867](https://github.com/netdata/netdata/pull/12867) ([ktsaou](https://github.com/ktsaou))
-- Apply some logic to possible streaming destinations [\#12866](https://github.com/netdata/netdata/pull/12866) ([MrZammler](https://github.com/MrZammler))
-- fix\(cgroups.plugin\): do not disable K8s pod/container cgroups if can't rename them [\#12865](https://github.com/netdata/netdata/pull/12865) ([ilyam8](https://github.com/ilyam8))
-- workers fixes and improvements [\#12863](https://github.com/netdata/netdata/pull/12863) ([ktsaou](https://github.com/ktsaou))
-- bump go.d.plugin version to v0.32.3 [\#12862](https://github.com/netdata/netdata/pull/12862) ([ilyam8](https://github.com/ilyam8))
-- Initialize the metadata database when performing dbengine stress test [\#12861](https://github.com/netdata/netdata/pull/12861) ([stelfrag](https://github.com/stelfrag))
-- Add a SQLite database checkpoint command [\#12859](https://github.com/netdata/netdata/pull/12859) ([stelfrag](https://github.com/stelfrag))
-- feat\(cgroups.plugin\): add k8s cluster name label \(GKE only\) [\#12858](https://github.com/netdata/netdata/pull/12858) ([ilyam8](https://github.com/ilyam8))
-- Autodetect channel for specific version [\#12856](https://github.com/netdata/netdata/pull/12856) ([maneamarius](https://github.com/maneamarius))
-- Pause alert pushes to the cloud [\#12852](https://github.com/netdata/netdata/pull/12852) ([MrZammler](https://github.com/MrZammler))
## [v1.34.1](https://github.com/netdata/netdata/tree/v1.34.1) (2022-04-15)
diff --git a/contrib/debian/netdata.postinst b/contrib/debian/netdata.postinst
index 12b1d97b..cf6a7606 100644
--- a/contrib/debian/netdata.postinst
+++ b/contrib/debian/netdata.postinst
@@ -63,6 +63,10 @@ case "$1" in
setcap cap_sys_admin+ep /usr/libexec/netdata/plugins.d/perf.plugin
fi
+ if [ -f "/usr/libexec/netdata/plugins.d/go.d.plugin" ]; then
+ setcap cap_net_admin+epi /usr/libexec/netdata/plugins.d/go.d.plugin
+ fi
+
chmod 4750 /usr/libexec/netdata/plugins.d/cgroup-network
chmod 4750 /usr/libexec/netdata/plugins.d/nfacct.plugin
diff --git a/database/rrdcontext.c b/database/rrdcontext.c
index b6b9e945..24884dbc 100644
--- a/database/rrdcontext.c
+++ b/database/rrdcontext.c
@@ -1381,7 +1381,7 @@ static void rrdcontext_message_send_unsafe(RRDCONTEXT *rc, bool snapshot __maybe
}
else {
if (ctx_store_context(&rc->rrdhost->host_uuid, &rc->hub) != 0)
- error("RRDCONTEXT: failed to save context '%s' version %lu to SQL.", rc->hub.id, rc->hub.version);
+ error("RRDCONTEXT: failed to save context '%s' version %"PRIu64" to SQL.", rc->hub.id, rc->hub.version);
}
}
@@ -1425,7 +1425,7 @@ static bool check_if_cloud_version_changed_unsafe(RRDCONTEXT *rc, bool sending _
if(unlikely(id_changed || title_changed || units_changed || family_changed || chart_type_changed || priority_changed || first_time_changed || last_time_changed || deleted_changed)) {
- internal_error(true, "RRDCONTEXT: %s NEW VERSION '%s'%s, version %zu, title '%s'%s, units '%s'%s, family '%s'%s, chart type '%s'%s, priority %u%s, first_time_t %ld%s, last_time_t %ld%s, deleted '%s'%s, (queued for %llu ms, expected %llu ms)",
+ internal_error(true, "RRDCONTEXT: %s NEW VERSION '%s'%s, version %"PRIu64", title '%s'%s, units '%s'%s, family '%s'%s, chart type '%s'%s, priority %u%s, first_time_t %ld%s, last_time_t %ld%s, deleted '%s'%s, (queued for %llu ms, expected %llu ms)",
sending?"SENDING":"QUEUE",
string2str(rc->id), id_changed ? " (CHANGED)" : "",
rc->version,
@@ -1458,7 +1458,7 @@ static void rrdcontext_insert_callback(const char *id, void *value, void *data)
// we are loading data from the SQL database
if(rc->version)
- error("RRDCONTEXT: context '%s' is already initialized with version %lu, but it is loaded again from SQL with version %lu", string2str(rc->id), rc->version, rc->hub.version);
+ error("RRDCONTEXT: context '%s' is already initialized with version %"PRIu64", but it is loaded again from SQL with version %"PRIu64"", string2str(rc->id), rc->version, rc->hub.version);
// IMPORTANT
// replace all string pointers in rc->hub with our own versions
@@ -1942,7 +1942,7 @@ void rrdcontext_hub_checkpoint_command(void *ptr) {
uint64_t our_version_hash = rrdcontext_version_hash(host);
if(cmd->version_hash != our_version_hash) {
- error("RRDCONTEXT: received version hash %lu for host '%s', does not match our version hash %lu. Sending snapshot of all contexts.",
+ error("RRDCONTEXT: received version hash %"PRIu64" for host '%s', does not match our version hash %"PRIu64". Sending snapshot of all contexts.",
cmd->version_hash, host->hostname, our_version_hash);
#ifdef ENABLE_ACLK
@@ -2339,8 +2339,8 @@ static inline int rrdcontext_to_json_callback(const char *id, void *value, void
",\n\t\t\t\"last_queued\":%llu"
",\n\t\t\t\"scheduled_dispatch\":%llu"
",\n\t\t\t\"last_dequeued\":%llu"
- ",\n\t\t\t\"hub_version\":%lu"
- ",\n\t\t\t\"version\":%lu"
+ ",\n\t\t\t\"hub_version\":%"PRIu64""
+ ",\n\t\t\t\"version\":%"PRIu64""
, rc->queue.queued_ut / USEC_PER_SEC
, rc->queue.scheduled_dispatch_ut / USEC_PER_SEC
, rc->queue.dequeued_ut / USEC_PER_SEC
@@ -2702,7 +2702,7 @@ void rrdcontext_delete_from_sql_unsafe(RRDCONTEXT *rc) {
// delete it from SQL
if(ctx_delete_context(&rc->rrdhost->host_uuid, &rc->hub) != 0)
- error("RRDCONTEXT: failed to delete context '%s' version %lu from SQL.", rc->hub.id, rc->hub.version);
+ error("RRDCONTEXT: failed to delete context '%s' version %"PRIu64" from SQL.", rc->hub.id, rc->hub.version);
}
static void rrdcontext_garbage_collect(void) {
diff --git a/database/sqlite/sqlite_context.c b/database/sqlite/sqlite_context.c
index 88818579..901ab003 100644
--- a/database/sqlite/sqlite_context.c
+++ b/database/sqlite/sqlite_context.c
@@ -445,13 +445,13 @@ static void dict_ctx_get_context_list_cb(VERSIONED_CONTEXT_DATA *context_data, v
{
(void)data;
info(" Context id = %s "
- "version = %lu "
+ "version = %"PRIu64" "
"title = %s "
"chart_type = %s "
"units = %s "
- "priority = %lu "
- "first time = %lu "
- "last time = %lu "
+ "priority = %"PRIu64" "
+ "first time = %"PRIu64" "
+ "last time = %"PRIu64" "
"deleted = %d "
"family = %s",
context_data->id,
diff --git a/netdata-installer.sh b/netdata-installer.sh
index f6f4fd52..941cf13f 100755
--- a/netdata-installer.sh
+++ b/netdata-installer.sh
@@ -1443,6 +1443,9 @@ install_go() {
run chown "root:${NETDATA_GROUP}" "${NETDATA_PREFIX}/usr/libexec/netdata/plugins.d/go.d.plugin"
fi
run chmod 0750 "${NETDATA_PREFIX}/usr/libexec/netdata/plugins.d/go.d.plugin"
+ if command -v setcap 1>/dev/null 2>&1; then
+ run setcap cap_net_admin+epi "${NETDATA_PREFIX}/usr/libexec/netdata/plugins.d/go.d.plugin"
+ fi
rm -rf "${tmp}"
[ -n "${GITHUB_ACTIONS}" ] && echo "::endgroup::"
diff --git a/netdata.spec.in b/netdata.spec.in
index 756a9d3d..a75e48dd 100644
--- a/netdata.spec.in
+++ b/netdata.spec.in
@@ -515,6 +515,9 @@ rm -rf "${RPM_BUILD_ROOT}"
# freeipmi files
%attr(4750,root,netdata) %{_libexecdir}/%{name}/plugins.d/freeipmi.plugin
+# go.d.plugin (the capability required for wireguard module)
+%caps(cap_net_admin=epi) %{_libexecdir}/%{name}/plugins.d/go.d.plugin
+
# Enforce 0644 for files and 0755 for directories
# for the netdata web directory
%defattr(0644,root,root,0755)
diff --git a/packaging/makeself/install-or-update.sh b/packaging/makeself/install-or-update.sh
index 15b073fe..aef67a15 100755
--- a/packaging/makeself/install-or-update.sh
+++ b/packaging/makeself/install-or-update.sh
@@ -214,6 +214,10 @@ for x in apps.plugin freeipmi.plugin ioping cgroup-network ebpf.plugin perf.plug
fi
done
+if [ -f "usr/libexec/netdata/plugins.d/go.d.plugin" ] && command -v setcap 1>/dev/null 2>&1; then
+ run setcap cap_net_admin+epi "usr/libexec/netdata/plugins.d/go.d.plugin"
+fi
+
# fix the fping binary
if [ -f bin/fping ]; then
run chown root:${NETDATA_GROUP} bin/fping
diff --git a/packaging/version b/packaging/version
index 1ff1dd5d..b5a0280e 100644
--- a/packaging/version
+++ b/packaging/version
@@ -1 +1 @@
-v1.36.0
+v1.36.1