summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-02-08 07:31:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-02-08 07:31:03 +0000
commit50485bedfd9818165aa1d039d0abe95a559134b7 (patch)
tree79c7b08f67edcfb0c936e7a22931653b91189b9f /Makefile.am
parentReleasing debian version 1.11.1+dfsg-7. (diff)
downloadnetdata-50485bedfd9818165aa1d039d0abe95a559134b7.tar.xz
netdata-50485bedfd9818165aa1d039d0abe95a559134b7.zip
Merging upstream version 1.12.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am79
1 files changed, 40 insertions, 39 deletions
diff --git a/Makefile.am b/Makefile.am
index c90db5ca..376ccf17 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,8 +25,6 @@ EXTRA_DIST = \
.lgtm.yml \
.travis \
.github/CODEOWNERS \
- build/build.sh \
- build/Dockerfile \
build/m4/jemalloc.m4 \
build/m4/ax_c___atomic.m4 \
build/m4/ax_check_enable_debug.m4 \
@@ -49,52 +47,40 @@ EXTRA_DIST = \
SUBDIRS = \
diagrams \
- makeself \
system \
- contrib \
tests \
$(NULL)
dist_noinst_DATA= \
cppcheck.sh \
configs.signatures \
- docker \
+ contrib \
netdata.cppcheck \
netdata.spec \
package.json \
- doc/Add-more-charts-to-netdata.md \
- doc/Demo-Sites.md \
- doc/Donations-netdata-has-received.md \
- doc/Netdata-Security-and-Disclosure-Information.md \
- doc/Performance.md \
- doc/Running-behind-apache.md \
- doc/Running-behind-caddy.md \
- doc/Running-behind-lighttpd.md \
- doc/Running-behind-nginx.md \
- doc/Third-Party-Plugins.md \
- doc/a-github-star-is-important.md \
- doc/high-performance-netdata.md \
- doc/netdata-for-IoT.md \
- doc/netdata-security.md \
- doc/Why-Netdata.md \
- htmldoc/themes/material/partials/footer.html \
- installer/README.md \
- installer/UNINSTALL.md \
- installer/UPDATE.md \
- requirements.txt \
- runtime.txt \
+ docs \
+ packaging/version \
+ packaging/go.d.checksums \
+ packaging/installer/README.md \
+ packaging/installer/UNINSTALL.md \
+ packaging/installer/UPDATE.md \
+ netlify.toml \
$(NULL)
# until integrated within build
# should be proper init.d/openrc/systemd usable
dist_noinst_SCRIPTS= \
coverity-scan.sh \
- kickstart.sh \
- kickstart-static64.sh \
+ packaging/installer/netdata-updater.sh \
+ packaging/installer/kickstart.sh \
+ packaging/installer/kickstart-static64.sh \
+ packaging/installer/functions.sh \
netdata-installer.sh \
- installer/functions.sh \
- htmldoc/buildhtml.sh \
- htmldoc/buildyaml.sh \
+ docs/generator/buildhtml.sh \
+ docs/generator/buildyaml.sh \
+ docs/generator/checklinks.sh \
+ docs/generator/requirements.txt \
+ docs/generator/runtime.txt \
$(NULL)
# -----------------------------------------------------------------------------
@@ -120,13 +106,14 @@ AM_CFLAGS = \
$(OPTIONAL_UUID_CFLAGS) \
$(OPTIONAL_LIBCAP_LIBS) \
$(OPTIONAL_IPMIMONITORING_CFLAGS) \
+ $(OPTIONAL_CUPS_CFLAGS) \
$(NULL)
sbin_PROGRAMS =
-dist_cache_DATA = installer/.keep
-dist_varlib_DATA = installer/.keep
-dist_registry_DATA = installer/.keep
-dist_log_DATA = installer/.keep
+dist_cache_DATA = packaging/installer/.keep
+dist_varlib_DATA = packaging/installer/.keep
+dist_registry_DATA = packaging/installer/.keep
+dist_log_DATA = packaging/installer/.keep
plugins_PROGRAMS =
LIBNETDATA_FILES = \
@@ -227,6 +214,11 @@ FREEIPMI_PLUGIN_FILES = \
$(LIBNETDATA_FILES) \
$(NULL)
+CUPS_PLUGIN_FILES = \
+ collectors/cups.plugin/cups_plugin.c \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+
NFACCT_PLUGIN_FILES = \
collectors/nfacct.plugin/plugin_nfacct.c \
collectors/nfacct.plugin/plugin_nfacct.h \
@@ -237,6 +229,7 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/plugin_proc.c \
collectors/proc.plugin/plugin_proc.h \
collectors/proc.plugin/proc_diskstats.c \
+ collectors/proc.plugin/proc_mdstat.c \
collectors/proc.plugin/proc_interrupts.c \
collectors/proc.plugin/proc_softirqs.c \
collectors/proc.plugin/proc_loadavg.c \
@@ -267,6 +260,7 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/sys_devices_system_edac_mc.c \
collectors/proc.plugin/sys_devices_system_node.c \
collectors/proc.plugin/sys_fs_btrfs.c \
+ collectors/proc.plugin/sys_class_power_supply.c \
$(NULL)
TC_PLUGIN_FILES = \
@@ -351,6 +345,8 @@ API_PLUGIN_FILES = \
web/api/formatters/charts2json.h \
web/api/formatters/rrdset2json.c \
web/api/formatters/rrdset2json.h \
+ web/api/health/health_cmdapi.c \
+ web/api/health/health_cmdapi.h \
web/api/web_api_v1.c \
web/api/web_api_v1.h \
$(NULL)
@@ -388,10 +384,6 @@ WEB_PLUGIN_FILES = \
web/server/web_server.h \
web/server/web_client_cache.c \
web/server/web_client_cache.h \
- web/server/single/single-threaded.c \
- web/server/single/single-threaded.h \
- web/server/multi/multi-threaded.c \
- web/server/multi/multi-threaded.h \
web/server/static/static-threaded.c \
web/server/static/static-threaded.h \
$(NULL)
@@ -503,3 +495,12 @@ if ENABLE_PLUGIN_FREEIPMI
$(OPTIONAL_IPMIMONITORING_LIBS) \
$(NULL)
endif
+
+if ENABLE_PLUGIN_CUPS
+ plugins_PROGRAMS += cups.plugin
+ cups_plugin_SOURCES = $(CUPS_PLUGIN_FILES)
+ cups_plugin_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(OPTIONAL_CUPS_LIBS) \
+ $(NULL)
+endif