summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFederico Ceratto <federico.ceratto@gmail.com>2016-03-30 21:40:42 +0000
committerFederico Ceratto <federico.ceratto@gmail.com>2016-03-30 21:40:42 +0000
commit9ce153ce7167c11adba8ac225edc7a707e97c6eb (patch)
tree9f6e849cce2dcc7e5b4e9e6252c843dc2d0787a2 /Makefile.am
downloadnetdata-9ce153ce7167c11adba8ac225edc7a707e97c6eb.tar.xz
netdata-9ce153ce7167c11adba8ac225edc7a707e97c6eb.zip
Imported Upstream version 1.0.0upstream/1.0.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..72f0502c
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2015 Alon Bar-Lev <alon.barlev@gmail.com>
+#
+AUTOMAKE_OPTIONS=foreign dist-bzip2 dist-xz 1.10
+ACLOCAL_AMFLAGS = -I m4
+
+MAINTAINERCLEANFILES= \
+ config.log config.status \
+ $(srcdir)/Makefile.in \
+ $(srcdir)/config.h.in $(srcdir)/config.h.in~ $(srcdir)/configure \
+ $(srcdir)/install-sh $(srcdir)/ltmain.sh $(srcdir)/missing \
+ $(srcdir)/compile $(srcdir)/depcomp $(srcdir)/aclocal.m4 \
+ $(srcdir)/config.guess $(srcdir)/config.sub \
+ $(srcdir)/m4/ltsugar.m4 $(srcdir)/m4/libtool.m4 \
+ $(srcdir)/m4/ltversion.m4 $(srcdir)/m4/lt~obsolete.m4 \
+ $(srcdir)/m4/ltoptions.m4 \
+ $(srcdir)/pkcs11-helper.spec $(srcdir)/config-w32-vc.h
+
+EXTRA_DIST = \
+ .gitignore \
+ autogen.sh \
+ README.md \
+ LICENSE.md \
+ autogen.sh \
+ netdata-9999.ebuild \
+ tests/stress.sh \
+ system/netdata-openrc \
+ system/netdata-systemd \
+ $(NULL)
+
+SUBDIRS = \
+ charts.d \
+ node.d \
+ conf.d \
+ plugins.d \
+ src \
+ web \
+ $(NULL)
+
+dist_noinst_DATA = netdata.spec
+
+# until integrated within build
+# should be proper init.d/openrc/systemd usable
+dist_noinst_SCRIPTS = netdata-installer.sh