summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-07-20 04:50:01 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-07-20 04:50:01 +0000
commitcd4377fab21e0f500bef7f06543fa848a039c1e0 (patch)
treeba00a55e430c052d6bed0b61c0f8bbe8ebedd313 /Makefile.am
parentReleasing debian version 1.40.1-1. (diff)
downloadnetdata-cd4377fab21e0f500bef7f06543fa848a039c1e0.tar.xz
netdata-cd4377fab21e0f500bef7f06543fa848a039c1e0.zip
Merging upstream version 1.41.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am234
1 files changed, 128 insertions, 106 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fc97825..84bf4c9d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,7 +84,7 @@ dist_noinst_DATA = \
packaging/protobuf.version \
packaging/version \
database/engine/journalfile_v2.ksy.in \
- httpd/h2o \
+ web/server/h2o/libh2o \
$(NULL)
# until integrated within build
@@ -168,8 +168,6 @@ LIBNETDATA_FILES = \
libnetdata/log/log.h \
libnetdata/onewayalloc/onewayalloc.c \
libnetdata/onewayalloc/onewayalloc.h \
- libnetdata/parser/parser.c \
- libnetdata/parser/parser.h \
libnetdata/popen/popen.c \
libnetdata/popen/popen.h \
libnetdata/procfile/procfile.c \
@@ -283,6 +281,11 @@ CGROUP_NETWORK_FILES = \
$(LIBNETDATA_FILES) \
$(NULL)
+LOCAL_LISTENERS_FILES = \
+ collectors/plugins.d/local_listeners.c \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+
DISKSPACE_PLUGIN_FILES = \
collectors/diskspace.plugin/plugin_diskspace.c \
$(NULL)
@@ -362,6 +365,8 @@ EBPF_PLUGIN_FILES = \
collectors/ebpf.plugin/ebpf_cgroup.h \
collectors/ebpf.plugin/ebpf_unittest.c \
collectors/ebpf.plugin/ebpf_unittest.h \
+ collectors/ebpf.plugin/ebpf_functions.c \
+ collectors/ebpf.plugin/ebpf_functions.h \
$(LIBNETDATA_FILES) \
$(NULL)
@@ -396,6 +401,7 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/zfs_common.h \
collectors/proc.plugin/proc_spl_kstat_zfs.c \
collectors/proc.plugin/proc_stat.c \
+ collectors/proc.plugin/proc_sys_fs_file_nr.c \
collectors/proc.plugin/proc_sys_kernel_random_entropy_avail.c \
collectors/proc.plugin/proc_vmstat.c \
collectors/proc.plugin/proc_uptime.c \
@@ -408,6 +414,10 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/sys_class_infiniband.c \
$(NULL)
+PROFILE_PLUGIN_FILES = \
+ collectors/profile.plugin/plugin_profile.cc \
+ $(NULL)
+
TC_PLUGIN_FILES = \
collectors/tc.plugin/plugin_tc.c \
$(NULL)
@@ -425,6 +435,7 @@ PLUGINSD_PLUGIN_FILES = \
collectors/plugins.d/plugins_d.h \
collectors/plugins.d/pluginsd_parser.c \
collectors/plugins.d/pluginsd_parser.h \
+ collectors/plugins.d/gperf-hashtable.h \
$(NULL)
RRD_PLUGIN_FILES = \
@@ -653,8 +664,6 @@ REGISTRY_PLUGIN_FILES = \
registry/registry_machine.h \
registry/registry_person.c \
registry/registry_person.h \
- registry/registry_url.c \
- registry/registry_url.h \
$(NULL)
STATSD_PLUGIN_FILES = \
@@ -936,124 +945,126 @@ DAEMON_FILES = \
daemon/static_threads.c \
daemon/commands.c \
daemon/commands.h \
+ daemon/pipename.c \
+ daemon/pipename.h \
daemon/unit_test.c \
daemon/unit_test.h \
$(NULL)
-HTTPD_FILES = \
- httpd/http_server.c \
- httpd/http_server.h \
- httpd/h2o_utils.c \
- httpd/h2o_utils.h \
+H2O_FILES = \
+ web/server/h2o/http_server.c \
+ web/server/h2o/http_server.h \
+ web/server/h2o/h2o_utils.c \
+ web/server/h2o/h2o_utils.h \
$(NULL)
libh2o_a_SOURCES = \
- httpd/h2o/deps/cloexec/cloexec.c \
- httpd/h2o/deps/libgkc/gkc.c \
- httpd/h2o/deps/libyrmcds/close.c \
- httpd/h2o/deps/libyrmcds/connect.c \
- httpd/h2o/deps/libyrmcds/recv.c \
- httpd/h2o/deps/libyrmcds/send.c \
- httpd/h2o/deps/libyrmcds/send_text.c \
- httpd/h2o/deps/libyrmcds/socket.c \
- httpd/h2o/deps/libyrmcds/strerror.c \
- httpd/h2o/deps/libyrmcds/text_mode.c \
- httpd/h2o/deps/picohttpparser/picohttpparser.c \
- httpd/h2o/lib/common/cache.c \
- httpd/h2o/lib/common/file.c \
- httpd/h2o/lib/common/filecache.c \
- httpd/h2o/lib/common/hostinfo.c \
- httpd/h2o/lib/common/http1client.c \
- httpd/h2o/lib/common/memcached.c \
- httpd/h2o/lib/common/memory.c \
- httpd/h2o/lib/common/multithread.c \
- httpd/h2o/lib/common/serverutil.c \
- httpd/h2o/lib/common/socket.c \
- httpd/h2o/lib/common/socketpool.c \
- httpd/h2o/lib/common/string.c \
- httpd/h2o/lib/common/time.c \
- httpd/h2o/lib/common/timeout.c \
- httpd/h2o/lib/common/url.c \
- httpd/h2o/lib/core/config.c \
- httpd/h2o/lib/core/configurator.c \
- httpd/h2o/lib/core/context.c \
- httpd/h2o/lib/core/headers.c \
- httpd/h2o/lib/core/logconf.c \
- httpd/h2o/lib/core/proxy.c \
- httpd/h2o/lib/core/request.c \
- httpd/h2o/lib/core/token.c \
- httpd/h2o/lib/core/util.c \
- httpd/h2o/lib/handler/access_log.c \
- httpd/h2o/lib/handler/chunked.c \
- httpd/h2o/lib/handler/compress.c \
- httpd/h2o/lib/handler/compress/gzip.c \
- httpd/h2o/lib/handler/errordoc.c \
- httpd/h2o/lib/handler/expires.c \
- httpd/h2o/lib/handler/fastcgi.c \
- httpd/h2o/lib/handler/file.c \
- httpd/h2o/lib/handler/headers.c \
- httpd/h2o/lib/handler/mimemap.c \
- httpd/h2o/lib/handler/proxy.c \
- httpd/h2o/lib/handler/redirect.c \
- httpd/h2o/lib/handler/reproxy.c \
- httpd/h2o/lib/handler/throttle_resp.c \
- httpd/h2o/lib/handler/status.c \
- httpd/h2o/lib/handler/headers_util.c \
- httpd/h2o/lib/handler/status/events.c \
- httpd/h2o/lib/handler/status/requests.c \
- httpd/h2o/lib/handler/http2_debug_state.c \
- httpd/h2o/lib/handler/status/durations.c \
- httpd/h2o/lib/handler/configurator/access_log.c \
- httpd/h2o/lib/handler/configurator/compress.c \
- httpd/h2o/lib/handler/configurator/errordoc.c \
- httpd/h2o/lib/handler/configurator/expires.c \
- httpd/h2o/lib/handler/configurator/fastcgi.c \
- httpd/h2o/lib/handler/configurator/file.c \
- httpd/h2o/lib/handler/configurator/headers.c \
- httpd/h2o/lib/handler/configurator/proxy.c \
- httpd/h2o/lib/handler/configurator/redirect.c \
- httpd/h2o/lib/handler/configurator/reproxy.c \
- httpd/h2o/lib/handler/configurator/throttle_resp.c \
- httpd/h2o/lib/handler/configurator/status.c \
- httpd/h2o/lib/handler/configurator/http2_debug_state.c \
- httpd/h2o/lib/handler/configurator/headers_util.c \
- httpd/h2o/lib/http1.c \
- httpd/h2o/lib/tunnel.c \
- httpd/h2o/lib/http2/cache_digests.c \
- httpd/h2o/lib/http2/casper.c \
- httpd/h2o/lib/http2/connection.c \
- httpd/h2o/lib/http2/frame.c \
- httpd/h2o/lib/http2/hpack.c \
- httpd/h2o/lib/http2/scheduler.c \
- httpd/h2o/lib/http2/stream.c \
- httpd/h2o/lib/http2/http2_debug_state.c \
+ web/server/h2o/libh2o/deps/cloexec/cloexec.c \
+ web/server/h2o/libh2o/deps/libgkc/gkc.c \
+ web/server/h2o/libh2o/deps/libyrmcds/close.c \
+ web/server/h2o/libh2o/deps/libyrmcds/connect.c \
+ web/server/h2o/libh2o/deps/libyrmcds/recv.c \
+ web/server/h2o/libh2o/deps/libyrmcds/send.c \
+ web/server/h2o/libh2o/deps/libyrmcds/send_text.c \
+ web/server/h2o/libh2o/deps/libyrmcds/socket.c \
+ web/server/h2o/libh2o/deps/libyrmcds/strerror.c \
+ web/server/h2o/libh2o/deps/libyrmcds/text_mode.c \
+ web/server/h2o/libh2o/deps/picohttpparser/picohttpparser.c \
+ web/server/h2o/libh2o/lib/common/cache.c \
+ web/server/h2o/libh2o/lib/common/file.c \
+ web/server/h2o/libh2o/lib/common/filecache.c \
+ web/server/h2o/libh2o/lib/common/hostinfo.c \
+ web/server/h2o/libh2o/lib/common/http1client.c \
+ web/server/h2o/libh2o/lib/common/memcached.c \
+ web/server/h2o/libh2o/lib/common/memory.c \
+ web/server/h2o/libh2o/lib/common/multithread.c \
+ web/server/h2o/libh2o/lib/common/serverutil.c \
+ web/server/h2o/libh2o/lib/common/socket.c \
+ web/server/h2o/libh2o/lib/common/socketpool.c \
+ web/server/h2o/libh2o/lib/common/string.c \
+ web/server/h2o/libh2o/lib/common/time.c \
+ web/server/h2o/libh2o/lib/common/timeout.c \
+ web/server/h2o/libh2o/lib/common/url.c \
+ web/server/h2o/libh2o/lib/core/config.c \
+ web/server/h2o/libh2o/lib/core/configurator.c \
+ web/server/h2o/libh2o/lib/core/context.c \
+ web/server/h2o/libh2o/lib/core/headers.c \
+ web/server/h2o/libh2o/lib/core/logconf.c \
+ web/server/h2o/libh2o/lib/core/proxy.c \
+ web/server/h2o/libh2o/lib/core/request.c \
+ web/server/h2o/libh2o/lib/core/token.c \
+ web/server/h2o/libh2o/lib/core/util.c \
+ web/server/h2o/libh2o/lib/handler/access_log.c \
+ web/server/h2o/libh2o/lib/handler/chunked.c \
+ web/server/h2o/libh2o/lib/handler/compress.c \
+ web/server/h2o/libh2o/lib/handler/compress/gzip.c \
+ web/server/h2o/libh2o/lib/handler/errordoc.c \
+ web/server/h2o/libh2o/lib/handler/expires.c \
+ web/server/h2o/libh2o/lib/handler/fastcgi.c \
+ web/server/h2o/libh2o/lib/handler/file.c \
+ web/server/h2o/libh2o/lib/handler/headers.c \
+ web/server/h2o/libh2o/lib/handler/mimemap.c \
+ web/server/h2o/libh2o/lib/handler/proxy.c \
+ web/server/h2o/libh2o/lib/handler/redirect.c \
+ web/server/h2o/libh2o/lib/handler/reproxy.c \
+ web/server/h2o/libh2o/lib/handler/throttle_resp.c \
+ web/server/h2o/libh2o/lib/handler/status.c \
+ web/server/h2o/libh2o/lib/handler/headers_util.c \
+ web/server/h2o/libh2o/lib/handler/status/events.c \
+ web/server/h2o/libh2o/lib/handler/status/requests.c \
+ web/server/h2o/libh2o/lib/handler/http2_debug_state.c \
+ web/server/h2o/libh2o/lib/handler/status/durations.c \
+ web/server/h2o/libh2o/lib/handler/configurator/access_log.c \
+ web/server/h2o/libh2o/lib/handler/configurator/compress.c \
+ web/server/h2o/libh2o/lib/handler/configurator/errordoc.c \
+ web/server/h2o/libh2o/lib/handler/configurator/expires.c \
+ web/server/h2o/libh2o/lib/handler/configurator/fastcgi.c \
+ web/server/h2o/libh2o/lib/handler/configurator/file.c \
+ web/server/h2o/libh2o/lib/handler/configurator/headers.c \
+ web/server/h2o/libh2o/lib/handler/configurator/proxy.c \
+ web/server/h2o/libh2o/lib/handler/configurator/redirect.c \
+ web/server/h2o/libh2o/lib/handler/configurator/reproxy.c \
+ web/server/h2o/libh2o/lib/handler/configurator/throttle_resp.c \
+ web/server/h2o/libh2o/lib/handler/configurator/status.c \
+ web/server/h2o/libh2o/lib/handler/configurator/http2_debug_state.c \
+ web/server/h2o/libh2o/lib/handler/configurator/headers_util.c \
+ web/server/h2o/libh2o/lib/http1.c \
+ web/server/h2o/libh2o/lib/tunnel.c \
+ web/server/h2o/libh2o/lib/http2/cache_digests.c \
+ web/server/h2o/libh2o/lib/http2/casper.c \
+ web/server/h2o/libh2o/lib/http2/connection.c \
+ web/server/h2o/libh2o/lib/http2/frame.c \
+ web/server/h2o/libh2o/lib/http2/hpack.c \
+ web/server/h2o/libh2o/lib/http2/scheduler.c \
+ web/server/h2o/libh2o/lib/http2/stream.c \
+ web/server/h2o/libh2o/lib/http2/http2_debug_state.c \
$(NULL)
libh2o_a_INCLUDES = \
- -I$(srcdir)/httpd/h2o/include \
- -I$(srcdir)/httpd/h2o/deps/cloexec \
- -I$(srcdir)/httpd/h2o/deps/brotli/enc \
- -I$(srcdir)/httpd/h2o/deps/golombset \
- -I$(srcdir)/httpd/h2o/deps/libgkc \
- -I$(srcdir)/httpd/h2o/deps/libyrmcds \
- -I$(srcdir)/httpd/h2o/deps/klib \
- -I$(srcdir)/httpd/h2o/deps/neverbleed \
- -I$(srcdir)/httpd/h2o/deps/picohttpparser \
- -I$(srcdir)/httpd/h2o/deps/picotest \
- -I$(srcdir)/httpd/h2o/deps/yaml/include \
- -I$(srcdir)/httpd/h2o/deps/yoml \
+ -I$(srcdir)/web/server/h2o/libh2o/include \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/cloexec \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/brotli/enc \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/golombset \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/libgkc \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/libyrmcds \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/klib \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/neverbleed \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/picohttpparser \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/picotest \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/yaml/include \
+ -I$(srcdir)/web/server/h2o/libh2o/deps/yoml \
$(NULL)
-if ENABLE_HTTPD
+if ENABLE_H2O
noinst_LIBRARIES += libh2o.a
# until h2o updates support for OpenSSL 3.0 we silence the warnings
-libh2o_a_CFLAGS = $(CFLAGS) -Wno-deprecated-declarations -Wno-unused-parameter -Wno-sign-compare -Wno-missing-field-initializers -DH2O_USE_LIBUV=0 $(libh2o_a_INCLUDES)
+libh2o_a_CFLAGS = $(CFLAGS) -Wno-old-style-declaration -Wno-deprecated-declarations -Wno-unused-parameter -Wno-sign-compare -Wno-missing-field-initializers -DH2O_USE_LIBUV=0 $(libh2o_a_INCLUDES)
if LINUX
libh2o_a_CFLAGS += -D_GNU_SOURCE
endif
-endif #ENABLE_HTTPD
+endif #ENABLE_H2O
NETDATA_FILES = \
collectors/all.h \
@@ -1075,6 +1086,7 @@ NETDATA_FILES = \
$(ACLK_FILES) \
$(SPAWN_PLUGIN_FILES) \
$(TIMEX_PLUGIN_FILES) \
+ $(PROFILE_PLUGIN_FILES) \
$(NULL)
if FREEBSD
@@ -1123,8 +1135,8 @@ if ENABLE_ACLK
NETDATA_COMMON_LIBS += libmqttwebsockets.a
endif
-if ENABLE_HTTPD
- NETDATA_FILES += $(HTTPD_FILES)
+if ENABLE_H2O
+ NETDATA_FILES += $(H2O_FILES)
NETDATA_COMMON_LIBS += libh2o.a
endif
@@ -1138,6 +1150,8 @@ endif
NETDATACLI_FILES = \
daemon/commands.h \
+ daemon/pipename.c \
+ daemon/pipename.h \
libnetdata/buffer/buffer.c \
libnetdata/buffer/buffer.h \
cli/cli.c \
@@ -1197,6 +1211,14 @@ if ENABLE_PLUGIN_CGROUP_NETWORK
$(NULL)
endif
+if ENABLE_PLUGIN_LOCAL_LISTENERS
+ plugins_PROGRAMS += local-listeners
+ local_listeners_SOURCES = $(LOCAL_LISTENERS_FILES)
+ local_listeners_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(NULL)
+endif
+
if ENABLE_PLUGIN_FREEIPMI
plugins_PROGRAMS += freeipmi.plugin
freeipmi_plugin_SOURCES = $(FREEIPMI_PLUGIN_FILES)