summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-03 10:23:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-03 10:23:48 +0000
commitcd7ed12292aef11d9062b64f61215174e8cc1860 (patch)
tree9998ab03d153956743d9319cf3a0279b9593ce36 /Makefile.am
parentReleasing debian version 1.16.1-6. (diff)
downloadnetdata-cd7ed12292aef11d9062b64f61215174e8cc1860.tar.xz
netdata-cd7ed12292aef11d9062b64f61215174e8cc1860.zip
Merging upstream version 1.17.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index de161c84..fa12a757 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,7 @@ dist_noinst_DATA= \
package.json \
docs \
packaging/version \
+ packaging/go.d.version \
packaging/go.d.checksums \
packaging/installer/README.md \
packaging/installer/UNINSTALL.md \
@@ -279,6 +280,7 @@ PROC_PLUGIN_FILES = \
collectors/proc.plugin/proc_vmstat.c \
collectors/proc.plugin/proc_uptime.c \
collectors/proc.plugin/sys_kernel_mm_ksm.c \
+ collectors/proc.plugin/sys_block_zram.c \
collectors/proc.plugin/sys_devices_system_edac_mc.c \
collectors/proc.plugin/sys_devices_system_node.c \
collectors/proc.plugin/sys_fs_btrfs.c \
@@ -456,6 +458,11 @@ PROMETHEUS_REMOTE_WRITE_BACKEND_FILES = \
backends/prometheus/remote_write/remote_write.proto \
$(NULL)
+MONGODB_BACKEND_FILES = \
+ backends/mongodb/mongodb.c \
+ backends/mongodb/mongodb.h \
+ $(NULL)
+
DAEMON_FILES = \
daemon/common.c \
daemon/common.h \
@@ -613,3 +620,8 @@ backends/prometheus/remote_write/remote_write.pb.h: backends/prometheus/remote_w
$(PROTOC) --proto_path=$(srcdir) --cpp_out=$(builddir) $^
endif
+
+if ENABLE_BACKEND_MONGODB
+ netdata_SOURCES += $(MONGODB_BACKEND_FILES)
+ netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
+endif