summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-14 19:20:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-14 19:20:36 +0000
commitdd24e74edfbafc09eaeb2dde0fda7eb3e1e86d0b (patch)
tree1e52f4dac2622ab377c7649f218fb49003b4cbb9 /Makefile.am
parentReleasing debian version 1.39.1-2. (diff)
downloadnetdata-dd24e74edfbafc09eaeb2dde0fda7eb3e1e86d0b.tar.xz
netdata-dd24e74edfbafc09eaeb2dde0fda7eb3e1e86d0b.zip
Merging upstream version 1.40.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am179
1 files changed, 156 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d9abd54..666847dc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,7 +54,6 @@ SUBDIRS = \
dist_noinst_DATA = \
CHANGELOG.md \
cppcheck.sh \
- configs.signatures \
contrib \
docs \
mqtt_websockets \
@@ -77,12 +76,15 @@ dist_noinst_DATA = \
packaging/jsonc.version \
packaging/yaml.checksums \
packaging/yaml.version \
- packaging/libbpf.checksums \
- packaging/libbpf.version \
+ packaging/current_libbpf.checksums \
+ packaging/current_libbpf.version \
+ packaging/libbpf_0_0_9.checksums \
+ packaging/libbpf_0_0_9.version \
packaging/protobuf.checksums \
packaging/protobuf.version \
packaging/version \
database/engine/journalfile_v2.ksy.in \
+ httpd/h2o \
$(NULL)
# until integrated within build
@@ -117,7 +119,7 @@ SUBDIRS += \
AM_CFLAGS = \
$(OPTIONAL_MATH_CFLAGS) \
$(OPTIONAL_NFACCT_CFLAGS) \
- $(OPTIONAL_ZLIB_CFLAGS) \
+ $(ZLIB_CFLAGS) \
$(OPTIONAL_UUID_CFLAGS) \
$(OPTIONAL_MQTT_CFLAGS) \
$(OPTIONAL_LIBCAP_LIBS) \
@@ -152,6 +154,8 @@ LIBNETDATA_FILES = \
libnetdata/dictionary/dictionary.h \
libnetdata/eval/eval.c \
libnetdata/eval/eval.h \
+ libnetdata/gorilla/gorilla.h \
+ libnetdata/gorilla/gorilla.cc \
libnetdata/inlined.h \
libnetdata/july/july.c \
libnetdata/july/july.h \
@@ -197,6 +201,7 @@ LIBNETDATA_FILES = \
libnetdata/string/utf8.h \
libnetdata/worker_utilization/worker_utilization.c \
libnetdata/worker_utilization/worker_utilization.h \
+ libnetdata/http/http_defs.h \
$(NULL)
if ENABLE_PLUGIN_EBPF
@@ -211,6 +216,14 @@ APPS_PLUGIN_FILES = \
$(LIBNETDATA_FILES) \
$(NULL)
+DEBUGFS_PLUGIN_FILES = \
+ collectors/debugfs.plugin/debugfs_plugin.c \
+ collectors/debugfs.plugin/debugfs_plugin.h \
+ collectors/debugfs.plugin/debugfs_extfrag.c \
+ collectors/debugfs.plugin/debugfs_zswap.c \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+
FREEBSD_PLUGIN_FILES = \
collectors/freebsd.plugin/plugin_freebsd.c \
collectors/freebsd.plugin/plugin_freebsd.h \
@@ -347,6 +360,8 @@ EBPF_PLUGIN_FILES = \
collectors/ebpf.plugin/ebpf_apps.h \
collectors/ebpf.plugin/ebpf_cgroup.c \
collectors/ebpf.plugin/ebpf_cgroup.h \
+ collectors/ebpf.plugin/ebpf_unittest.c \
+ collectors/ebpf.plugin/ebpf_unittest.h \
$(LIBNETDATA_FILES) \
$(NULL)
@@ -500,15 +515,10 @@ libjudy_a_SOURCES = libnetdata/libjudy/src/Judy.h \
libnetdata/libjudy/src/JudyL/JudyLNextEmpty.c \
libnetdata/libjudy/src/JudyL/JudyLPrev.c \
libnetdata/libjudy/src/JudyL/JudyLPrevEmpty.c \
+ libnetdata/libjudy/src/JudyL/JudyLTables.c \
libnetdata/libjudy/src/JudyHS/JudyHS.c \
$(NULL)
-nodist_libjudy_a_SOURCES = JudyLTables.c
-
-BUILT_SOURCES += JudyLTables.c
-
-CLEANFILES += JudyLTables.c
-
libjudy_a_CFLAGS = $(LIBJUDY_CFLAGS) -DJUDYL -I$(abs_top_srcdir)/libnetdata/libjudy/src -I$(abs_top_srcdir)/libnetdata/libjudy/src/JudyCommon -Wno-sign-compare -Wno-implicit-fallthrough
libnetdata/libjudy/src/JudyL/libjudy_a-JudyLPrev.$(OBJEXT) : CFLAGS += -DJUDYPREV
@@ -518,16 +528,6 @@ libnetdata/libjudy/src/JudyL/libjudy_a-JudyLNextEmpty.$(OBJEXT) : CFLAGS += -DJU
libnetdata/libjudy/src/JudyL/libjudy_a-JudyLByCount.$(OBJEXT) : CFLAGS += -DNOSMARTJBB -DNOSMARTJBU -DNOSMARTJLB
libnetdata/libjudy/src/JudyL/libjudy_a-j__udyLGet.$(OBJEXT) : CFLAGS += -DJUDYGETINLINE
-noinst_PROGRAMS = judyltablesgen
-
-judyltablesgen_SOURCES = libnetdata/libjudy/src/JudyL/JudyLTablesGen.c
-judyltablesgen_CFLAGS = $(LIBJUDY_CFLAGS) -DJUDYL -I$(abs_top_srcdir)/libnetdata/libjudy/src -I$(abs_top_srcdir)/libnetdata/libjudy/src/JudyCommon -Wno-sign-compare -Wno-implicit-fallthrough
-
-$(builddir)/judyltablesgen$(EXEEXT) : CFLAGS += -Wno-format -Wno-format-security
-
-JudyLTables.c: $(abs_top_srcdir)/libnetdata/libjudy/src/JudyL/JudyLTablesGen.c $(builddir)/judyltablesgen$(EXEEXT)
- $(builddir)/judyltablesgen$(EXEEXT)
-
libjudy_a-JudyLTables.$(OBJEXT) : CFLAGS += -I$(abs_top_srcdir)/libnetdata/libjudy/src/JudyL
if ENABLE_DBENGINE
@@ -749,7 +749,8 @@ libmqttwebsockets_a_SOURCES = \
mqtt_websockets/c-rbuf/src/ringbuffer_internal.h \
mqtt_websockets/c_rhash/src/c_rhash.c \
mqtt_websockets/c_rhash/include/c_rhash.h \
- mqtt_websockets/c_rhash/src/c_rhash_internal.h
+ mqtt_websockets/c_rhash/src/c_rhash_internal.h \
+ $(NULL)
libmqttwebsockets_a_CFLAGS = $(CFLAGS) -DMQTT_WSS_CUSTOM_ALLOC -DRBUF_CUSTOM_MALLOC -DMQTT_WSS_CPUSTATS -I$(srcdir)/aclk/helpers -I$(srcdir)/mqtt_websockets/c_rhash/include
@@ -939,6 +940,123 @@ DAEMON_FILES = \
daemon/unit_test.h \
$(NULL)
+HTTPD_FILES = \
+ httpd/http_server.c \
+ httpd/http_server.h \
+ httpd/h2o_utils.c \
+ httpd/h2o_utils.h \
+ $(NULL)
+
+libh2o_dir = httpd/h2o
+
+libh2o_a_SOURCES = \
+ $(libh2o_dir)/deps/cloexec/cloexec.c \
+ $(libh2o_dir)/deps/libgkc/gkc.c \
+ $(libh2o_dir)/deps/libyrmcds/close.c \
+ $(libh2o_dir)/deps/libyrmcds/connect.c \
+ $(libh2o_dir)/deps/libyrmcds/recv.c \
+ $(libh2o_dir)/deps/libyrmcds/send.c \
+ $(libh2o_dir)/deps/libyrmcds/send_text.c \
+ $(libh2o_dir)/deps/libyrmcds/socket.c \
+ $(libh2o_dir)/deps/libyrmcds/strerror.c \
+ $(libh2o_dir)/deps/libyrmcds/text_mode.c \
+ $(libh2o_dir)/deps/picohttpparser/picohttpparser.c \
+ $(libh2o_dir)/lib/common/cache.c \
+ $(libh2o_dir)/lib/common/file.c \
+ $(libh2o_dir)/lib/common/filecache.c \
+ $(libh2o_dir)/lib/common/hostinfo.c \
+ $(libh2o_dir)/lib/common/http1client.c \
+ $(libh2o_dir)/lib/common/memcached.c \
+ $(libh2o_dir)/lib/common/memory.c \
+ $(libh2o_dir)/lib/common/multithread.c \
+ $(libh2o_dir)/lib/common/serverutil.c \
+ $(libh2o_dir)/lib/common/socket.c \
+ $(libh2o_dir)/lib/common/socketpool.c \
+ $(libh2o_dir)/lib/common/string.c \
+ $(libh2o_dir)/lib/common/time.c \
+ $(libh2o_dir)/lib/common/timeout.c \
+ $(libh2o_dir)/lib/common/url.c \
+ $(libh2o_dir)/lib/core/config.c \
+ $(libh2o_dir)/lib/core/configurator.c \
+ $(libh2o_dir)/lib/core/context.c \
+ $(libh2o_dir)/lib/core/headers.c \
+ $(libh2o_dir)/lib/core/logconf.c \
+ $(libh2o_dir)/lib/core/proxy.c \
+ $(libh2o_dir)/lib/core/request.c \
+ $(libh2o_dir)/lib/core/token.c \
+ $(libh2o_dir)/lib/core/util.c \
+ $(libh2o_dir)/lib/handler/access_log.c \
+ $(libh2o_dir)/lib/handler/chunked.c \
+ $(libh2o_dir)/lib/handler/compress.c \
+ $(libh2o_dir)/lib/handler/compress/gzip.c \
+ $(libh2o_dir)/lib/handler/errordoc.c \
+ $(libh2o_dir)/lib/handler/expires.c \
+ $(libh2o_dir)/lib/handler/fastcgi.c \
+ $(libh2o_dir)/lib/handler/file.c \
+ $(libh2o_dir)/lib/handler/headers.c \
+ $(libh2o_dir)/lib/handler/mimemap.c \
+ $(libh2o_dir)/lib/handler/proxy.c \
+ $(libh2o_dir)/lib/handler/redirect.c \
+ $(libh2o_dir)/lib/handler/reproxy.c \
+ $(libh2o_dir)/lib/handler/throttle_resp.c \
+ $(libh2o_dir)/lib/handler/status.c \
+ $(libh2o_dir)/lib/handler/headers_util.c \
+ $(libh2o_dir)/lib/handler/status/events.c \
+ $(libh2o_dir)/lib/handler/status/requests.c \
+ $(libh2o_dir)/lib/handler/http2_debug_state.c \
+ $(libh2o_dir)/lib/handler/status/durations.c \
+ $(libh2o_dir)/lib/handler/configurator/access_log.c \
+ $(libh2o_dir)/lib/handler/configurator/compress.c \
+ $(libh2o_dir)/lib/handler/configurator/errordoc.c \
+ $(libh2o_dir)/lib/handler/configurator/expires.c \
+ $(libh2o_dir)/lib/handler/configurator/fastcgi.c \
+ $(libh2o_dir)/lib/handler/configurator/file.c \
+ $(libh2o_dir)/lib/handler/configurator/headers.c \
+ $(libh2o_dir)/lib/handler/configurator/proxy.c \
+ $(libh2o_dir)/lib/handler/configurator/redirect.c \
+ $(libh2o_dir)/lib/handler/configurator/reproxy.c \
+ $(libh2o_dir)/lib/handler/configurator/throttle_resp.c \
+ $(libh2o_dir)/lib/handler/configurator/status.c \
+ $(libh2o_dir)/lib/handler/configurator/http2_debug_state.c \
+ $(libh2o_dir)/lib/handler/configurator/headers_util.c \
+ $(libh2o_dir)/lib/http1.c \
+ $(libh2o_dir)/lib/tunnel.c \
+ $(libh2o_dir)/lib/http2/cache_digests.c \
+ $(libh2o_dir)/lib/http2/casper.c \
+ $(libh2o_dir)/lib/http2/connection.c \
+ $(libh2o_dir)/lib/http2/frame.c \
+ $(libh2o_dir)/lib/http2/hpack.c \
+ $(libh2o_dir)/lib/http2/scheduler.c \
+ $(libh2o_dir)/lib/http2/stream.c \
+ $(libh2o_dir)/lib/http2/http2_debug_state.c \
+ $(NULL)
+
+libh2o_a_INCLUDES = \
+ -I$(srcdir)/$(libh2o_dir)/include \
+ -I$(srcdir)/$(libh2o_dir)/deps/cloexec \
+ -I$(srcdir)/$(libh2o_dir)/deps/brotli/enc \
+ -I$(srcdir)/$(libh2o_dir)/deps/golombset \
+ -I$(srcdir)/$(libh2o_dir)/deps/libgkc \
+ -I$(srcdir)/$(libh2o_dir)/deps/libyrmcds \
+ -I$(srcdir)/$(libh2o_dir)/deps/klib \
+ -I$(srcdir)/$(libh2o_dir)/deps/neverbleed \
+ -I$(srcdir)/$(libh2o_dir)/deps/picohttpparser \
+ -I$(srcdir)/$(libh2o_dir)/deps/picotest \
+ -I$(srcdir)/$(libh2o_dir)/deps/yaml/include \
+ -I$(srcdir)/$(libh2o_dir)/deps/yoml \
+ $(NULL)
+
+if ENABLE_HTTPD
+noinst_LIBRARIES += libh2o.a
+
+# until h2o updates support for OpenSSL 3.0 we silence the warnings
+libh2o_a_CFLAGS = $(CFLAGS) -Wno-deprecated-declarations -Wno-unused-parameter -Wno-sign-compare -Wno-missing-field-initializers -DH2O_USE_LIBUV=0 $(libh2o_a_INCLUDES)
+
+if LINUX
+ libh2o_a_CFLAGS += -D_GNU_SOURCE
+endif
+endif #ENABLE_HTTPD
+
NETDATA_FILES = \
collectors/all.h \
$(DAEMON_FILES) \
@@ -988,7 +1106,7 @@ endif
NETDATA_COMMON_LIBS = \
$(OPTIONAL_MATH_LIBS) \
$(OPTIONAL_BPF_LIBS) \
- $(OPTIONAL_ZLIB_LIBS) \
+ $(ZLIB_LIBS) \
$(OPTIONAL_SSL_LIBS) \
$(OPTIONAL_UUID_LIBS) \
$(OPTIONAL_MQTT_LIBS) \
@@ -1007,6 +1125,11 @@ if ENABLE_ACLK
NETDATA_COMMON_LIBS += libmqttwebsockets.a
endif
+if ENABLE_HTTPD
+ NETDATA_FILES += $(HTTPD_FILES)
+ NETDATA_COMMON_LIBS += libh2o.a
+endif
+
if LINK_STATIC_JSONC
NETDATA_COMMON_LIBS += $(abs_top_srcdir)/externaldeps/jsonc/libjson-c.a
endif
@@ -1017,7 +1140,8 @@ endif
NETDATACLI_FILES = \
daemon/commands.h \
- $(LIBNETDATA_FILES) \
+ libnetdata/buffer/buffer.c \
+ libnetdata/buffer/buffer.h \
cli/cli.c \
cli/cli.h \
$(NULL)
@@ -1058,6 +1182,15 @@ if ENABLE_PLUGIN_APPS
$(NULL)
endif
+if ENABLE_PLUGIN_DEBUGFS
+ plugins_PROGRAMS += debugfs.plugin
+ debugfs_plugin_SOURCES = $(DEBUGFS_PLUGIN_FILES)
+ debugfs_plugin_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(OPTIONAL_LIBCAP_LIBS) \
+ $(NULL)
+endif
+
if ENABLE_PLUGIN_CGROUP_NETWORK
plugins_PROGRAMS += cgroup-network
cgroup_network_SOURCES = $(CGROUP_NETWORK_FILES)