summaryrefslogtreecommitdiffstats
path: root/collectors/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:29 +0000
commit17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99 (patch)
tree3e0c96613972e8bb4afdeeb97a034806363ddfa9 /collectors/Makefile.am
parentReleasing debian version 1.18.1-1. (diff)
downloadnetdata-17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99.tar.xz
netdata-17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99.zip
Merging upstream version 1.19.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'collectors/Makefile.am')
-rw-r--r--collectors/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/collectors/Makefile.am b/collectors/Makefile.am
index eaa1a7b8c..743102570 100644
--- a/collectors/Makefile.am
+++ b/collectors/Makefile.am
@@ -25,9 +25,16 @@ SUBDIRS = \
slabinfo.plugin \
statsd.plugin \
tc.plugin \
- $(NULL)
+ $(NULL)
+usercustompluginsconfigdir=$(configdir)/custom-plugins.d
+usergoconfigdir=$(configdir)/go.d
+
+# Explicitly install directories to avoid permission issues due to umask
+install-exec-local:
+ $(INSTALL) -d $(DESTDIR)$(usercustompluginsconfigdir)
+ $(INSTALL) -d $(DESTDIR)$(usergoconfigdir)
dist_noinst_DATA = \
- README.md \
- $(NULL)
+ README.md \
+ $(NULL)