summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:29 +0000
commit17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99 (patch)
tree3e0c96613972e8bb4afdeeb97a034806363ddfa9 /configure.ac
parentReleasing debian version 1.18.1-1. (diff)
downloadnetdata-17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99.tar.xz
netdata-17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99.zip
Merging upstream version 1.19.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ea91a7299..35147b0e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -748,6 +748,22 @@ fi
AC_MSG_RESULT([${enable_plugin_xenstat}])
AM_CONDITIONAL([ENABLE_PLUGIN_XENSTAT], [test "${enable_plugin_xenstat}" = "yes"])
+if test "${enable_plugin_xenstat}" == "yes"; then
+ AC_MSG_CHECKING([for xenstat_vbd_error in -lxenstat])
+ AC_TRY_LINK(
+ [ #include <xenstat.h> ],
+ [
+ xenstat_vbd * vbd;
+ int out = xenstat_vbd_error(vbd);
+ ],
+ [
+ have_xenstat_vbd_error=yes
+ AC_DEFINE([HAVE_XENSTAT_VBD_ERROR], [1], [xenstat_vbd_error usability])
+ ],
+ [ have_xenstat_vbd_error=no ]
+ )
+ AC_MSG_RESULT([${have_xenstat_vbd_error}])
+fi
# -----------------------------------------------------------------------------
# perf.plugin