summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-10-17 09:30:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-10-17 09:30:23 +0000
commit517a443636daa1e8085cb4e5325524a54e8a8fd7 (patch)
tree5352109cc7cd5122274ab0cfc1f887b685f04edf /configure.ac
parentReleasing debian version 1.42.4-1. (diff)
downloadnetdata-517a443636daa1e8085cb4e5325524a54e8a8fd7.tar.xz
netdata-517a443636daa1e8085cb4e5325524a54e8a8fd7.zip
Merging upstream version 1.43.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 26 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ac0d7bff6..5db1b9f21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -650,7 +650,7 @@ AC_C_BIGENDIAN([],
[AC_MSG_ERROR([Could not find out system endiannnes])])
AC_CHECK_SIZEOF(void *)
-if test "$ac_cv_sizeof_void_p" = 8; then
+if test "$ac_cv_sizeof_void_p" = 8; then
AC_MSG_RESULT(Detected 64-bit Build Environment)
LIBJUDY_CFLAGS="$LIBJUDY_CFLAGS -DJU_64BIT"
else
@@ -1141,8 +1141,31 @@ fi
AC_MSG_RESULT([${enable_plugin_systemd_journal}])
AM_CONDITIONAL([ENABLE_PLUGIN_SYSTEMD_JOURNAL], [test "${enable_plugin_systemd_journal}" = "yes"])
+AC_CHECK_LIB([systemd], [sd_journal_open_files_fd], [have_sd_journal_open_files_fd=yes], [have_sd_journal_open_files_fd=no])
+if test "${have_sd_journal_open_files_fd}" = "yes"; then
+ AC_DEFINE([HAVE_SD_JOURNAL_OPEN_FILES_FD], [1], [sd_journal_open_files_fd usability])
+fi
+
+AC_CHECK_LIB([systemd], [sd_journal_restart_fields], [have_sd_journal_restart_fields=yes], [have_sd_journal_restart_fields=no])
+if test "${have_sd_journal_restart_fields}" = "yes"; then
+ AC_DEFINE([HAVE_SD_JOURNAL_RESTART_FIELDS], [1], [sd_journal_restart_fields usability])
+fi
+
AC_MSG_NOTICE([OPTIONAL_SYSTEMD_LIBS is set to: ${OPTIONAL_SYSTEMD_LIBS}])
+if test "${enable_plugin_systemd_journal}" = "yes"; then
+ AC_MSG_CHECKING([for SD_JOURNAL_OS_ROOT in systemd])
+ AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <systemd/sd-journal.h>]],
+ [[int x = SD_JOURNAL_OS_ROOT;]]
+ )],
+ [AC_DEFINE(HAVE_SD_JOURNAL_OS_ROOT, 1, [Define if SD_JOURNAL_OS_ROOT is available])
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)]
+ )
+fi
+
LIBS="${LIBS_BAK}"
# -----------------------------------------------------------------------------
@@ -2010,6 +2033,7 @@ AC_CONFIG_FILES([
libnetdata/ebpf/Makefile
libnetdata/eval/Makefile
libnetdata/facets/Makefile
+ libnetdata/functions_evloop/Makefile
libnetdata/july/Makefile
libnetdata/locks/Makefile
libnetdata/log/Makefile
@@ -2034,6 +2058,7 @@ AC_CONFIG_FILES([
web/Makefile
web/api/Makefile
web/api/badges/Makefile
+ web/api/ilove/Makefile
web/api/exporters/Makefile
web/api/exporters/shell/Makefile
web/api/exporters/prometheus/Makefile