summaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-01 06:15:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-01 06:15:11 +0000
commit483926a283e118590da3f9ecfa75a8a4d62143ce (patch)
treecb77052778df9a128a8cd3ff5bf7645322a13bc5 /contrib
parentReleasing debian version 1.31.0-4. (diff)
downloadnetdata-483926a283e118590da3f9ecfa75a8a4d62143ce.tar.xz
netdata-483926a283e118590da3f9ecfa75a8a4d62143ce.zip
Merging upstream version 1.32.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib')
-rw-r--r--contrib/debian/control3
-rw-r--r--contrib/debian/control.xenial62
-rw-r--r--contrib/debian/netdata.postinst2
-rwxr-xr-xcontrib/debian/rules17
4 files changed, 78 insertions, 6 deletions
diff --git a/contrib/debian/control b/contrib/debian/control
index 2659c389..622e730f 100644
--- a/contrib/debian/control
+++ b/contrib/debian/control
@@ -1,7 +1,6 @@
Source: netdata
-Build-Depends: debhelper (>= 9),
+Build-Depends: debhelper (>= 9.20160709),
dh-autoreconf,
- dh-systemd (>= 1.5),
dpkg-dev (>= 1.13.19),
zlib1g-dev,
uuid-dev,
diff --git a/contrib/debian/control.xenial b/contrib/debian/control.xenial
new file mode 100644
index 00000000..2659c389
--- /dev/null
+++ b/contrib/debian/control.xenial
@@ -0,0 +1,62 @@
+Source: netdata
+Build-Depends: debhelper (>= 9),
+ dh-autoreconf,
+ dh-systemd (>= 1.5),
+ dpkg-dev (>= 1.13.19),
+ zlib1g-dev,
+ uuid-dev,
+ libelf-dev,
+ libuv1-dev,
+ liblz4-dev,
+ libjudy-dev,
+ libssl-dev,
+ libmnl-dev,
+ libjson-c-dev,
+ libcups2-dev,
+ libipmimonitoring-dev,
+ libnetfilter-acct-dev,
+ libsnappy-dev,
+ libprotobuf-dev,
+ libprotoc-dev,
+ cmake,
+ autogen,
+ autoconf,
+ automake,
+ pkg-config,
+ curl,
+ protobuf-compiler
+Section: net
+Priority: optional
+Maintainer: Netdata Builder <bot@netdata.cloud>
+Standards-Version: 3.9.6
+Homepage: https://netdata.cloud
+
+Package: netdata
+Architecture: any
+Depends: adduser,
+ libcap2-bin (>= 1:2.0),
+ lsb-base (>= 3.1-23.2),
+ openssl,
+ ${misc:Depends},
+ ${shlibs:Depends}
+Pre-Depends: dpkg (>= 1.17.14)
+Description: real-time charts for system monitoring
+ Netdata is a daemon that collects data in realtime (per second)
+ and presents a web site to view and analyze them. The presentation
+ is also real-time and full of interactive charts that precisely
+ render all collected values.
+
+Package: netdata-plugin-cups
+Architecture: any
+Depends: cups,
+ netdata (>= ${source:Version})
+Description: The Common Unix Printing System plugin for metrics collection from cupsd
+
+Package: netdata-plugin-freeipmi
+Architecture: any
+Depends: freeipmi,
+ netdata (= ${source:Version})
+Description: FreeIPMI - The Intelligent Platform Management System.
+ The IPMI specification defines a set of interfaces for platform management.
+ It is implemented by a number vendors for system management. The features of IPMI that most users will be interested in
+ are sensor monitoring, system event monitoring, power control, and serial-over-LAN (SOL).
diff --git a/contrib/debian/netdata.postinst b/contrib/debian/netdata.postinst
index 17182c7e..f26c94f9 100644
--- a/contrib/debian/netdata.postinst
+++ b/contrib/debian/netdata.postinst
@@ -55,7 +55,7 @@ case "$1" in
chown -R root:netdata /var/lib/netdata/www
setcap cap_dac_read_search,cap_sys_ptrace+ep /usr/libexec/netdata/plugins.d/apps.plugin
setcap cap_dac_read_search+ep /usr/libexec/netdata/plugins.d/slabinfo.plugin
- setcap cap_perfmon+ep /usr/libexec/netdata/plugins.d/perf.plugin || setcap cap_sys_admin+ep /usr/libexec/netdata/plugins.d/perf.plugin
+ capsh --supports=cap_perfmon 2>/dev/null && setcap cap_perfmon+ep /usr/libexec/netdata/plugins.d/perf.plugin || setcap cap_sys_admin+ep /usr/libexec/netdata/plugins.d/perf.plugin
chmod 4750 /usr/libexec/netdata/plugins.d/cgroup-network
chmod 4750 /usr/libexec/netdata/plugins.d/nfacct.plugin
diff --git a/contrib/debian/rules b/contrib/debian/rules
index eb50fffb..0d54b910 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -15,6 +15,13 @@ else
SYSTEMD_UNIT = system/netdata.service
endif
+ifeq ($(shell test `uname -m` != "x86_64" && echo "1"), 1)
+HAVE_EBPF = 0
+EBPF_CONFIG = --disable-ebpf
+else
+HAVE_EBPF = 1
+endif
+
%:
# For jessie and beyond
#
@@ -36,11 +43,13 @@ override_dh_installinit:
override_dh_auto_configure:
packaging/bundle-mosquitto.sh .
packaging/bundle-lws.sh .
- packaging/bundle-libbpf.sh .
+ if [ $(HAVE_EBPF) -eq 1 ]; then \
+ packaging/bundle-libbpf.sh . ${TOP}/usr/libexec/netdata/plugins.d; \
+ fi
autoreconf -ivf
dh_auto_configure -- --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib \
--libexecdir=/usr/libexec --with-user=netdata --with-math --with-zlib --with-webdir=/var/lib/netdata/www \
- --with-bundled-lws=externaldeps/libwebsockets
+ --with-bundled-lws $(EBPF_CONFIG)
override_dh_install:
cp -v $(BASE_CONFIG) debian/netdata.conf
@@ -77,7 +86,9 @@ override_dh_install:
ln -s "/usr/share/netdata/www/$$D" "$(TOP)/var/lib/netdata/www/$$D"; \
done
- packaging/bundle-ebpf.sh . ${TOP}/usr/libexec/netdata/plugins.d
+ if [ $(HAVE_EBPF) -eq 1 ]; then \
+ packaging/bundle-ebpf.sh . ${TOP}/usr/libexec/netdata/plugins.d; \
+ fi
# Install go
#