summaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-10-13 08:37:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-10-13 08:38:18 +0000
commitca540a730c0b880922e86074f994a95b8d413bea (patch)
tree1364a1b82cfcc68f51aabf9b2545e6a06059d6bb /contrib
parentReleasing debian version 1.17.1-1. (diff)
downloadnetdata-ca540a730c0b880922e86074f994a95b8d413bea.tar.xz
netdata-ca540a730c0b880922e86074f994a95b8d413bea.zip
Merging upstream version 1.18.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib')
-rw-r--r--contrib/README.md14
-rw-r--r--contrib/debian/control7
-rw-r--r--contrib/debian/control.buster7
-rw-r--r--contrib/debian/control.jessie7
-rw-r--r--contrib/debian/control.trusty7
-rw-r--r--contrib/debian/control.wheezy6
-rw-r--r--contrib/debian/control.xenial7
-rw-r--r--contrib/debian/netdata.postrm4
-rwxr-xr-xcontrib/debian/rules42
9 files changed, 86 insertions, 15 deletions
diff --git a/contrib/README.md b/contrib/README.md
index 8f28282a..4f32d9df 100644
--- a/contrib/README.md
+++ b/contrib/README.md
@@ -11,23 +11,23 @@ To build Netdata for a Debian Jessie system, the debian directory
has to be available in the root of the Netdata source. The easiest
way to do this is with a symlink:
-```
-~/netdata$ ln -s contrib/debian
+```sh
+ln -s contrib/debian
```
Then build the debian package:
-```
-~/netdata$ dpkg-buildpackage -us -uc -rfakeroot
+```sh
+dpkg-buildpackage -us -uc -rfakeroot
```
This should give a package that can be installed in the parent
directory, which you can install manually with dpkg.
-```
-~/netdata$ ls ../*.deb
+```sh
+ls ../*.deb
../netdata_1.0.0_amd64.deb
-~/netdata$ sudo dpkg -i ../netdata_1.0.0_amd64.deb
+sudo dpkg -i ../netdata_1.0.0_amd64.deb
```
### Building for a Debian system without systemd
diff --git a/contrib/debian/control b/contrib/debian/control
index ed5bd94b..be9a7786 100644
--- a/contrib/debian/control
+++ b/contrib/debian/control
@@ -43,7 +43,6 @@ Depends: adduser,
openssl,
libmnl0,
libjson-c3,
- cups,
freeipmi,
libnetfilter-acct1,
libprotobuf-c1,
@@ -56,3 +55,9 @@ Description: real-time charts for system monitoring
and presents a web site to view and analyze them. The presentation
is also real-time and full of interactive charts that precisely
render all collected values.
+
+Package: netdata-plugin-cups
+Architecture: any
+Depends: cups,
+ netdata (>= ${source:Version})
+Description: The Common Unix Printing System plugin for metrics collection from cupds
diff --git a/contrib/debian/control.buster b/contrib/debian/control.buster
index 56c59ae8..1166883b 100644
--- a/contrib/debian/control.buster
+++ b/contrib/debian/control.buster
@@ -43,7 +43,6 @@ Depends: adduser,
openssl,
libmnl0,
libjson-c3,
- cups,
freeipmi,
libnetfilter-acct1,
libprotobuf-c1,
@@ -56,3 +55,9 @@ Description: real-time charts for system monitoring
and presents a web site to view and analyze them. The presentation
is also real-time and full of interactive charts that precisely
render all collected values.
+
+Package: netdata-plugin-cups
+Architecture: any
+Depends: cups,
+ netdata (>= ${source:Version})
+Description: The Common Unix Printing System plugin for metrics collection from cupds
diff --git a/contrib/debian/control.jessie b/contrib/debian/control.jessie
index ced85d20..79db7839 100644
--- a/contrib/debian/control.jessie
+++ b/contrib/debian/control.jessie
@@ -41,7 +41,6 @@ Depends: adduser,
openssl,
libmnl0,
libjson-c3,
- cups,
freeipmi,
libnetfilter-acct1,
libprotobuf-c1,
@@ -54,3 +53,9 @@ Description: real-time charts for system monitoring
and presents a web site to view and analyze them. The presentation
is also real-time and full of interactive charts that precisely
render all collected values.
+
+Package: netdata-plugin-cups
+Architecture: any
+Depends: cups,
+ netdata (>= ${source:Version})
+Description: The Common Unix Printing System plugin for metrics collection from cupds
diff --git a/contrib/debian/control.trusty b/contrib/debian/control.trusty
index cb8a52e0..918d2ad3 100644
--- a/contrib/debian/control.trusty
+++ b/contrib/debian/control.trusty
@@ -41,7 +41,6 @@ Depends: adduser,
openssl,
libmnl0,
libjson-c2,
- cups,
freeipmi,
libnetfilter-acct1,
libprotobuf-c0,
@@ -54,3 +53,9 @@ Description: real-time charts for system monitoring
and presents a web site to view and analyze them. The presentation
is also real-time and full of interactive charts that precisely
render all collected values.
+
+Package: netdata-plugin-cups
+Architecture: any
+Depends: cups,
+ netdata (>= ${source:Version})
+Description: The Common Unix Printing System plugin for metrics collection from cupds
diff --git a/contrib/debian/control.wheezy b/contrib/debian/control.wheezy
index cde1d560..dc23b788 100644
--- a/contrib/debian/control.wheezy
+++ b/contrib/debian/control.wheezy
@@ -23,3 +23,9 @@ Description: real-time charts for system monitoring
and presents a web site to view and analyze them. The presentation
is also real-time and full of interactive charts that precisely
render all collected values.
+
+Package: netdata-plugin-cups
+Architecture: any
+Depends: cups,
+ netdata (>= ${source:Version})
+Description: The Common Unix Printing System plugin for metrics collection from cupds
diff --git a/contrib/debian/control.xenial b/contrib/debian/control.xenial
index 08a6df43..412b389e 100644
--- a/contrib/debian/control.xenial
+++ b/contrib/debian/control.xenial
@@ -43,7 +43,6 @@ Depends: adduser,
openssl,
libmnl0,
libjson-c2,
- cups,
freeipmi,
libnetfilter-acct1,
libprotobuf-c1,
@@ -56,3 +55,9 @@ Description: real-time charts for system monitoring
and presents a web site to view and analyze them. The presentation
is also real-time and full of interactive charts that precisely
render all collected values.
+
+Package: netdata-plugin-cups
+Architecture: any
+Depends: cups,
+ netdata (>= ${source:Version})
+Description: The Common Unix Printing System plugin for metrics collection from cupds
diff --git a/contrib/debian/netdata.postrm b/contrib/debian/netdata.postrm
index 4ab4eead..94e82bcd 100644
--- a/contrib/debian/netdata.postrm
+++ b/contrib/debian/netdata.postrm
@@ -15,6 +15,10 @@ case "$1" in
dpkg-statoverride --remove /var/lib/netdata/www
fi
+ if dpkg-statoverride --list | grep -qw /var/lib/netdata/registry; then
+ dpkg-statoverride --remove /var/lib/netdata/registry
+ fi
+
if dpkg-statoverride --list | grep -qw /var/lib/netdata; then
dpkg-statoverride --remove /var/lib/netdata
fi
diff --git a/contrib/debian/rules b/contrib/debian/rules
index 036e0108..0e17e395 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -4,6 +4,7 @@
# the location of plugins in /usr/lib
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
TOP = $(CURDIR)/debian/netdata
+TEMPTOP = $(CURDIR)/debian/tmp
%:
# For jessie and beyond
@@ -31,13 +32,40 @@ override_dh_install: debian/netdata.postinst
#
find "$(TOP)" -name .keep -exec rm '{}' ';'
+ # Set the CUPS plugin install rule
+ #
+ mkdir -p $(TOP)-plugin-cups/usr/libexec/netdata/plugins.d
+ mv -f $(TEMPTOP)/usr/libexec/netdata/plugins.d/cups.plugin \
+ $(TOP)-plugin-cups/usr/libexec/netdata/plugins.d/cups.plugin
+
+ # Set the rest of the software in the main package
+ #
+ cp -rp $(TEMPTOP)/usr $(TOP)/usr
+ cp -rp $(TEMPTOP)/var $(TOP)/var
+ #cp -rp $(TEMPTOP)/etc $(TOP)/etc
+
+ # Copy sample netdata.conf
+ cp -p $(CURDIR)/system/edit-config $(TOP)/etc/netdata/
+
+ # Create placeholder dirs in netdata configuration directory
+ #
+ mkdir -p $(TOP)/etc/netdata/health.d
+ mkdir -p $(TOP)/etc/netdata/python.d
+ mkdir -p $(TOP)/etc/netdata/charts.d
+ mkdir -p $(TOP)/etc/netdata/cystonm-plugins.d
+ mkdir -p $(TOP)/etc/netdata/go.d
+ mkdir -p $(TOP)/etc/netdata/ssl
+ mkdir -p $(TOP)/etc/netdata/node.d
+ mkdir -p $(TOP)/etc/netdata/statsd.d
+
+
# Move files that local user shouldn't be editing to /usr/share/netdata
#
- mkdir -p "$(TOP)/usr/share/netdata"
+ mkdir -p "$(TOP)/usr/share/netdata/www"
for D in $$(find "$(TOP)/var/lib/netdata/www/" -maxdepth 1 -type d -printf '%f '); do \
echo Relocating $$D; \
mv "$(TOP)/var/lib/netdata/www/$$D" "$(TOP)/usr/share/netdata/www/$$D"; \
- ln -s "/usr/share/netdata/$$D" "$(TOP)/var/lib/netdata/www/$$D"; \
+ ln -s "/usr/share/netdata/www/$$D" "$(TOP)/var/lib/netdata/www/$$D"; \
done
# Update postinst to set correct group for www files on installation.
@@ -55,7 +83,7 @@ override_dh_install: debian/netdata.postinst
# Install go
#
- debian/install_go.sh $$(cat ${CURDIR}/packaging/go.d.version) $(TOP)/usr/lib/$(DEB_HOST_MULTIARCH)/netdata/ $(TOP)/usr/libexec/netdata
+ debian/install_go.sh $$(cat ${CURDIR}/packaging/go.d.version) $(TOP)/usr/lib/netdata $(TOP)/usr/libexec/netdata
override_dh_installdocs:
dh_installdocs
@@ -79,8 +107,16 @@ override_dh_fixperms:
chmod 0754 $(TOP)/usr/libexec/netdata/plugins.d/apps.plugin
chmod 0754 $(TOP)/usr/libexec/netdata/plugins.d/freeipmi.plugin
chmod 0754 $(TOP)/usr/libexec/netdata/plugins.d/perf.plugin
+ chmod 0754 $(TOP)/usr/libexec/netdata/plugins.d/slabinfo.plugin
chmod 0750 $(TOP)/usr/libexec/netdata/plugins.d/go.d.plugin
+ # Support script for configuration file management
+ #
+ chmod 0750 $(TOP)/etc/netdata/edit-config
+
+ # CUPS plugin package
+ chmod 0750 $(TOP)-plugin-cups/usr/libexec/netdata/plugins.d/cups.plugin
+
override_dh_installlogrotate:
cp system/netdata.logrotate debian/netdata.logrotate
dh_installlogrotate