summaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-03 10:23:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-03 10:23:48 +0000
commitcd7ed12292aef11d9062b64f61215174e8cc1860 (patch)
tree9998ab03d153956743d9319cf3a0279b9593ce36 /contrib
parentReleasing debian version 1.16.1-6. (diff)
downloadnetdata-cd7ed12292aef11d9062b64f61215174e8cc1860.tar.xz
netdata-cd7ed12292aef11d9062b64f61215174e8cc1860.zip
Merging upstream version 1.17.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib')
-rw-r--r--contrib/README.md49
-rw-r--r--contrib/debian/changelog1
-rw-r--r--contrib/debian/control.trusty56
-rwxr-xr-xcontrib/debian/install_go.sh14
-rwxr-xr-xcontrib/debian/rules6
-rw-r--r--contrib/sles11/README.md15
6 files changed, 103 insertions, 38 deletions
diff --git a/contrib/README.md b/contrib/README.md
index c5ce873a..8f28282a 100644
--- a/contrib/README.md
+++ b/contrib/README.md
@@ -1,4 +1,4 @@
-# netdata contrib
+# Netdata contrib
## Building .deb packages
@@ -7,23 +7,28 @@ Debian package. It has been tested on Debian Jessie and Wheezy,
but should work, possibly with minor changes, if you have other
dpkg-based systems such as Ubuntu or Mint.
-To build netdata for a Debian Jessie system, the debian directory
-has to be available in the root of the netdata source. The easiest
+To build Netdata for a Debian Jessie system, the debian directory
+has to be available in the root of the Netdata source. The easiest
way to do this is with a symlink:
- ~/netdata$ ln -s contrib/debian
+```
+~/netdata$ ln -s contrib/debian
+```
Then build the debian package:
- ~/netdata$ dpkg-buildpackage -us -uc -rfakeroot
+```
+~/netdata$ dpkg-buildpackage -us -uc -rfakeroot
+```
This should give a package that can be installed in the parent
directory, which you can install manually with dpkg.
- ~/netdata$ ls ../*.deb
- ../netdata_1.0.0_amd64.deb
- ~/netdata$ sudo dpkg -i ../netdata_1.0.0_amd64.deb
-
+```
+~/netdata$ ls ../*.deb
+../netdata_1.0.0_amd64.deb
+~/netdata$ sudo dpkg -i ../netdata_1.0.0_amd64.deb
+```
### Building for a Debian system without systemd
@@ -32,29 +37,29 @@ are based on systemd. To build non-systemd packages (for example,
for Debian wheezy), you will need to make a couple of minor
updates first.
-* edit `contrib/debian/rules` and adjust the `dh` rule near the
- top to remove systemd (see comments in that file).
+- edit `contrib/debian/rules` and adjust the `dh` rule near the
+ top to remove systemd (see comments in that file).
-* rename `contrib/debian/control.wheezy` to `contrib/debian/control`.
+- rename `contrib/debian/control.wheezy` to `contrib/debian/control`.
-* change `control.wheezy from contrib/Makefile* to control`.
+- change `control.wheezy from contrib/Makefile* to control`.
-* uncomment `EXTRA_OPTS="-P /var/run/netdata.pid"` in
- `contrib/debian/netdata.default`
+- uncomment `EXTRA_OPTS="-P /var/run/netdata.pid"` in
+ `contrib/debian/netdata.default`
-* edit `contrib/debian/netdata.init` and change `PIDFILE` to
- `/var/run/netdata.pid`
+- edit `contrib/debian/netdata.init` and change `PIDFILE` to
+ `/var/run/netdata.pid`
-* remove `dpkg-statoverride --update --add --force root netdata 0775 /var/lib/netdata/registry` from
- `contrib/debian/netdata.postinst.in`. If you are going to handle the unique id file differently.
+- remove `dpkg-statoverride --update --add --force root netdata 0775 /var/lib/netdata/registry` from
+ `contrib/debian/netdata.postinst.in`. If you are going to handle the unique id file differently.
Then proceed as the main instructions above.
-### Reinstalling netdata
+### Reinstalling Netdata
-The recommended way to upgrade netdata packages built from this
+The recommended way to upgrade Netdata packages built from this
source is to remove the current package from your system, then
install the new package. Upgrading on wheezy is known to not
work cleanly; Jessie may behave as expected.
-[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcontrib%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)]()
+[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcontrib%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)](<>)
diff --git a/contrib/debian/changelog b/contrib/debian/changelog
index d9cf8bdb..ddfffe4e 100644
--- a/contrib/debian/changelog
+++ b/contrib/debian/changelog
@@ -3,3 +3,4 @@ netdata (PREVIOUS_PACKAGE_VERSION) unstable; urgency=medium
* Initial Release
-- Netdata Builder <bot@netdata.cloud> PREVIOUS_PACKAGE_DATE
+
diff --git a/contrib/debian/control.trusty b/contrib/debian/control.trusty
new file mode 100644
index 00000000..cb8a52e0
--- /dev/null
+++ b/contrib/debian/control.trusty
@@ -0,0 +1,56 @@
+Source: netdata
+Build-Depends: debhelper (>= 9),
+ dh-autoreconf,
+ dh-systemd (>= 1.5),
+ dpkg-dev (>= 1.13.19),
+ zlib1g-dev,
+ uuid-dev,
+ liblz4-dev,
+ libjudy-dev,
+ libssl-dev,
+ libmnl-dev,
+ libjson-c-dev,
+ libcups2-dev,
+ libipmimonitoring-dev,
+ libnetfilter-acct-dev,
+ libsnappy-dev,
+ libprotobuf-dev,
+ libprotoc-dev,
+ autogen,
+ autoconf,
+ automake,
+ pkg-config,
+ curl,
+ gcc,
+ g++
+Section: net
+Priority: optional
+Maintainer: Netdata Builder <bot@netdata.cloud>
+Standards-Version: 3.9.6
+Homepage: https://netdata.cloud
+
+Package: netdata
+Architecture: any
+Depends: adduser,
+ libcap2-bin (>= 1:2.0),
+ lsb-base (>= 3.1-23.2),
+ zlib1g,
+ libuuid1,
+ liblz4-1,
+ libjudydebian1,
+ openssl,
+ libmnl0,
+ libjson-c2,
+ cups,
+ freeipmi,
+ libnetfilter-acct1,
+ libprotobuf-c0,
+ libsnappy1,
+ libprotoc8,
+ ${misc:Depends},
+ ${shlibs:Depends}
+Description: real-time charts for system monitoring
+ Netdata is a daemon that collects data in realtime (per second)
+ and presents a web site to view and analyze them. The presentation
+ is also real-time and full of interactive charts that precisely
+ render all collected values.
diff --git a/contrib/debian/install_go.sh b/contrib/debian/install_go.sh
index 17a3b409..22ff691f 100755
--- a/contrib/debian/install_go.sh
+++ b/contrib/debian/install_go.sh
@@ -1,7 +1,8 @@
#!/usr/bin/env bash
-LIB_DIR="$1"
-LIBEXEC_DIR="$2"
+GO_PACKAGE_VERSION="$1"
+LIB_DIR="$2"
+LIBEXEC_DIR="$3"
# ############################################################
# Package Go within netdata (TBD: Package it separately)
@@ -35,8 +36,6 @@ download_go() {
}
install_go() {
- # When updating this value, ensure correct checksums in packaging/go.d.checksums
- GO_PACKAGE_VERSION="v0.7.0"
ARCH_MAP=(
'i386::386'
'i686::386'
@@ -62,7 +61,7 @@ install_go() {
fi
done
tmp=$(mktemp -d /tmp/netdata-go-XXXXXX)
- GO_PACKAGE_BASENAME="go.d.plugin-${GO_PACKAGE_VERSION}.${OS}-${ARCH}"
+ GO_PACKAGE_BASENAME="go.d.plugin-${GO_PACKAGE_VERSION}.${OS}-${ARCH}.tar.gz"
download_go "https://github.com/netdata/go.d.plugin/releases/download/${GO_PACKAGE_VERSION}/${GO_PACKAGE_BASENAME}" "${tmp}/${GO_PACKAGE_BASENAME}"
download_go "https://github.com/netdata/go.d.plugin/releases/download/${GO_PACKAGE_VERSION}/config.tar.gz" "${tmp}/config.tar.gz"
@@ -88,7 +87,10 @@ install_go() {
# Install files
tar -xf "${tmp}/config.tar.gz" -C "${LIB_DIR}/conf.d/"
- mv "${tmp}/$GO_PACKAGE_BASENAME" "${LIBEXEC_DIR}/plugins.d/go.d.plugin"
+ tar xf "${tmp}/${GO_PACKAGE_BASENAME}"
+ mv "${GO_PACKAGE_BASENAME/\.tar\.gz/}" "${LIBEXEC_DIR}/plugins.d/go.d.plugin"
+
+ rm -rf "${tmp}"
fi
return 0
}
diff --git a/contrib/debian/rules b/contrib/debian/rules
index 88a8ab36..036e0108 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -18,8 +18,8 @@ TOP = $(CURDIR)/debian/netdata
override_dh_auto_configure:
autoreconf -ivf
- dh_auto_configure -- --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/libexec --with-user=netdata --with-math --with-webdir=/var/lib/netdata/www
+ dh_auto_configure -- --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib \
+ --libexecdir=/usr/libexec --with-user=netdata --with-math --with-zlib --with-webdir=/var/lib/netdata/www
debian/%.postinst: debian/%.postinst.in
sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
@@ -55,7 +55,7 @@ override_dh_install: debian/netdata.postinst
# Install go
#
- debian/install_go.sh $(TOP)/usr/lib/$(DEB_HOST_MULTIARCH)/netdata/ $(TOP)/usr/libexec/netdata
+ debian/install_go.sh $$(cat ${CURDIR}/packaging/go.d.version) $(TOP)/usr/lib/$(DEB_HOST_MULTIARCH)/netdata/ $(TOP)/usr/libexec/netdata
override_dh_installdocs:
dh_installdocs
diff --git a/contrib/sles11/README.md b/contrib/sles11/README.md
index d052b945..2c938001 100644
--- a/contrib/sles11/README.md
+++ b/contrib/sles11/README.md
@@ -1,11 +1,12 @@
-# spec to build netdata RPM for sles 11
+# Spec to build Netdata RPM for sles 11
Based on [opensuse rpm spec](https://build.opensuse.org/package/show/network/netdata) with some
changes and additions for sles 11 backport, namely:
-- init.d script
-- run-time dependency on python ordereddict backport
-- patch for netdata python.d plugin to work with older python
-- crude hack of notification script to work with bash 3 (email and syslog only, one destination,
- see comments at the top)
-[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcontrib%2Fsles11%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)]()
+- init.d script
+- run-time dependency on python ordereddict backport
+- patch for Netdata python.d plugin to work with older python
+- crude hack of notification script to work with bash 3 (email and syslog only, one destination,
+ see comments at the top)
+
+[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcontrib%2Fsles11%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)](<>)