summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-01-01 17:25:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-01-02 18:08:06 +0000
commit1a0071b3f72e769e70b02acfb45654aad0df5219 (patch)
treeaed1b282d9e3e2dfe54b353a375fbaf3ec3f8151 /debian
parentBuilding with dh_missing --fail-missing. (diff)
downloadnetdata-1a0071b3f72e769e70b02acfb45654aad0df5219.tar.xz
netdata-1a0071b3f72e769e70b02acfb45654aad0df5219.zip
Using passwd instead of adduser to lower depends footprint.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/netdata.postinst.in4
-rw-r--r--debian/netdata.postrm4
3 files changed, 4 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index da8236d7e..71578d05d 100644
--- a/debian/control
+++ b/debian/control
@@ -22,7 +22,6 @@ Architecture: linux-any
Pre-Depends:
${misc:Pre-Depends},
Depends:
- adduser,
libcap2-bin,
lsb-base,
netdata-data (=${source:Version}),
diff --git a/debian/netdata.postinst.in b/debian/netdata.postinst.in
index d4fe0171c..e52dbf625 100644
--- a/debian/netdata.postinst.in
+++ b/debian/netdata.postinst.in
@@ -6,11 +6,11 @@ case "$1" in
configure)
if [ -z "$2" ]; then
if ! getent group netdata >/dev/null; then
- addgroup --quiet --system netdata
+ groupadd --system netdata
fi
if ! getent passwd netdata >/dev/null; then
- adduser --quiet --system --ingroup netdata --home /var/lib/netdata --no-create-home netdata
+ useradd --system --groups netdata --home-dir /var/lib/netdata --no-create-home netdata
mkdir -p /var/lib/netdata
fi
diff --git a/debian/netdata.postrm b/debian/netdata.postrm
index 81a657881..2a57c3cba 100644
--- a/debian/netdata.postrm
+++ b/debian/netdata.postrm
@@ -16,11 +16,11 @@ case "$1" in
rm -rf /var/cache/netdata /var/log/netdata
if getent passwd netdata >/dev/null; then
- deluser --quiet --system netdata || echo "Unable to remove netdata user"
+ userdel netdata || echo "Unable to remove netdata user"
fi
if getent group netdata >/dev/null; then
- delgroup --quiet --system netdata || echo "Unable to remove netdata group"
+ groupdel netdata || echo "Unable to remove netdata group"
fi
;;