summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-26 04:50:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-26 05:08:19 +0000
commitb976f209d0effa790a2d2ce0ac52c5db71f57b66 (patch)
treee5c1b8f3b1a48b828411c224a58b18ddb207c7b3 /debian
parentCreating empty directories to fix FTBFS when building from git. (diff)
downloadnetdata-b976f209d0effa790a2d2ce0ac52c5db71f57b66.tar.xz
netdata-b976f209d0effa790a2d2ce0ac52c5db71f57b66.zip
Removing initscript in favour of systemd unit.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/manpages/netdata.14
l---------debian/netdata-core-no-sse.netdata.init1
-rw-r--r--debian/netdata-core.netdata.init103
-rw-r--r--debian/netdata.TODO2
-rwxr-xr-xdebian/rules5
5 files changed, 3 insertions, 112 deletions
diff --git a/debian/manpages/netdata.1 b/debian/manpages/netdata.1
index bed840e1..0ef572f6 100644
--- a/debian/manpages/netdata.1
+++ b/debian/manpages/netdata.1
@@ -19,8 +19,8 @@ integrated to existing monitoring tool chains (Prometheus, Graphite,
OpenTSDB, Kafka, Grafana, etc).
.SH OPTIONS
-The \fBnetdata\fR daemon is usually started by an initscript or a systemd
-service, the following options are available:
+The \fBnetdata\fR daemon is usually started by the systemd service,
+the following options are available:
.IP "\-c \fIFILENAME\fR" 4
Configuration file to load.
diff --git a/debian/netdata-core-no-sse.netdata.init b/debian/netdata-core-no-sse.netdata.init
deleted file mode 120000
index 127fb0a0..00000000
--- a/debian/netdata-core-no-sse.netdata.init
+++ /dev/null
@@ -1 +0,0 @@
-netdata-core.netdata.init \ No newline at end of file
diff --git a/debian/netdata-core.netdata.init b/debian/netdata-core.netdata.init
deleted file mode 100644
index dc95589c..00000000
--- a/debian/netdata-core.netdata.init
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: netdata
-# Required-Start: $local_fs $remote_fs $network
-# Required-Stop: $local_fs $remote_fs $network
-# Should-Start: $syslog
-# Should-Stop: $syslog
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Real-time charts for system monitoring
-# Description: Start netdata, a real-time monitoring tool
-### END INIT INFO
-
-# Documentation
-# man netdata
-# file:///usr/share/doc/netdata/html/index.html
-# https://github.com/netdata/netdata
-
-# Load the VERBOSE setting and other rcS variables
-. /lib/init/vars.sh
-
-# Define LSB log_* functions.
-. /lib/lsb/init-functions
-
-NAME=netdata
-PIDFILE=/run/netdata.pid
-DAEMON=/usr/sbin/$NAME
-DAEMON_USER=$NAME
-DAEMON_ARGS="-P $PIDFILE"
-
-# Exit if executable is not installed
-[ -x "$DAEMON" ] || exit 0
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-DESC="the netdata daemon"
-CONF_FNAME=/etc/netdata/netdata.conf
-
-STOP_SCHEDULE="${STOP_SCHEDULE:-QUIT/5/TERM/5/KILL/5}"
-
-case "$1" in
- start)
- if [ ! -f "$CONF_FNAME" ]; then
- log_action_msg "Not starting $DESC: $CONF_FNAME is missing."
- exit 0
- fi
-
- log_action_begin_msg "Starting $DESC"
-
- if start-stop-daemon --start --quiet --pidfile $PIDFILE --name $NAME --startas $DAEMON --test; then
- if start-stop-daemon --start --quiet --pidfile $PIDFILE --name $NAME --startas $DAEMON -- $DAEMON_ARGS; then
- log_action_end_msg 0
- else
- log_action_end_msg 1
- exit 1
- fi
- else
- log_action_end_msg 0 "already running"
- fi
- ;;
- stop)
- log_action_begin_msg "Stopping $DESC"
- pid=`cat $PIDFILE 2>/dev/null` || true
- if test ! -f $PIDFILE -o -z "$pid"; then
- log_action_end_msg 0 "not running - there is no $PIDFILE"
- exit 0
- fi
-
- if start-stop-daemon --stop --quiet --pidfile $PIDFILE --name $NAME --retry=$STOP_SCHEDULE; then
- log_action_end_msg 0
- else
- log_action_end_msg 1 "$DAEMON died: process $pid not running; or permission denied"
- exit 1
- fi
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- status)
- if test ! -r $(dirname $PIDFILE); then
- log_failure_msg "cannot read PID file $PIDFILE"
- exit 4
- fi
- pid=`cat $PIDFILE 2>/dev/null` || true
- if test ! -f $PIDFILE -o -z "$pid"; then
- log_failure_msg "$NAME is not running"
- exit 3
- fi
- if ps "$pid" >/dev/null 2>&1; then
- log_success_msg "$NAME is running"
- exit 0
- else
- log_failure_msg "$NAME is not running"
- exit 1
- fi
- ;;
- *)
- log_action_msg "Usage: $0 {start|stop|restart|force-reload|status}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/debian/netdata.TODO b/debian/netdata.TODO
index 165d8c05..460448ac 100644
--- a/debian/netdata.TODO
+++ b/debian/netdata.TODO
@@ -24,7 +24,7 @@
* keep depends minimal and put everything to recommends/suggests
-* check netdata.conf, netdata.init, netdata.service etc. with upstream
+* check netdata.conf, netdata.service etc. with upstream
* check if freeipmi plugin can be run with caps instead setuid
diff --git a/debian/rules b/debian/rules
index 4dabdc38..9febc7fd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -157,11 +157,6 @@ override_dh_install-indep:
# Setting package version (update check)
echo $(VERSION) > $(TOP)-web/usr/share/netdata/web/version.txt
-override_dh_installinit:
- dh_installinit -p netdata-core --name=netdata
- dh_installinit -p netdata-core-no-sse --name=netdata
- dh_installinit --remaining-packages
-
override_dh_installsystemd:
dh_installsystemd -p netdata-core --name=netdata
dh_installsystemd -p netdata-core-no-sse --name=netdata