summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/c-ares-1.19.1/test/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-24 09:54:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-24 09:54:44 +0000
commit836b47cb7e99a977c5a23b059ca1d0b5065d310e (patch)
tree1604da8f482d02effa033c94a84be42bc0c848c3 /fluent-bit/lib/c-ares-1.19.1/test/Makefile.am
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-836b47cb7e99a977c5a23b059ca1d0b5065d310e.tar.xz
netdata-836b47cb7e99a977c5a23b059ca1d0b5065d310e.zip
Merging upstream version 1.46.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/lib/c-ares-1.19.1/test/Makefile.am')
-rw-r--r--fluent-bit/lib/c-ares-1.19.1/test/Makefile.am49
1 files changed, 0 insertions, 49 deletions
diff --git a/fluent-bit/lib/c-ares-1.19.1/test/Makefile.am b/fluent-bit/lib/c-ares-1.19.1/test/Makefile.am
deleted file mode 100644
index 504e65e46..000000000
--- a/fluent-bit/lib/c-ares-1.19.1/test/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-ARES_BLD_DIR = $(top_builddir)/..
-ARES_SRC_DIR = $(top_srcdir)/..
-
-AUTOMAKE_OPTIONS = foreign subdir-objects nostdinc 1.9.6
-ACLOCAL_AMFLAGS = -I ../m4 --install
-
-# Note use of -isystem to force use of local gMock/gTest even if there's an installed version.
-CPPFLAGS += -I$(ARES_BLD_DIR)/include \
- -I$(ARES_BLD_DIR)/src/lib \
- -I$(ARES_SRC_DIR)/include \
- -I$(ARES_SRC_DIR)/src/lib \
- -I$(top_builddir) \
- -isystem $(srcdir)/gmock-1.11.0
-CXXFLAGS += -Wall $(PTHREAD_CFLAGS)
-
-# Makefile.inc provides the various *SOURCES and *HEADERS defines
-include Makefile.inc
-
-TESTS = arestest fuzzcheck.sh
-
-noinst_LTLIBRARIES = libgmock.la
-
-libgmock_la_SOURCES = \
- gmock-1.11.0/gmock-gtest-all.cc \
- gmock-1.11.0/gmock/gmock.h \
- gmock-1.11.0/gtest/gtest.h
-
-libgmock_la_CPPFLAGS = -isystem $(srcdir)/gmock-1.11.0
-
-
-noinst_PROGRAMS = arestest aresfuzz aresfuzzname dnsdump
-EXTRA_DIST = fuzzcheck.sh CMakeLists.txt Makefile.m32 Makefile.msvc README.md buildconf $(srcdir)/fuzzinput/* $(srcdir)/fuzznames/*
-arestest_SOURCES = $(TESTSOURCES) $(TESTHEADERS)
-
-# Not interested in coverage of test code, but linking the test binary needs the coverage option
-arestest_LDADD = libgmock.la $(ARES_BLD_DIR)/src/lib/libcares.la $(PTHREAD_LIBS) $(CODE_COVERAGE_LIBS)
-
-include $(top_srcdir)/aminclude_static.am
-
-aresfuzz_SOURCES = $(FUZZSOURCES)
-aresfuzz_LDADD = $(ARES_BLD_DIR)/src/lib/libcares.la $(CODE_COVERAGE_LIBS)
-
-aresfuzzname_SOURCES = $(FUZZNAMESOURCES)
-aresfuzzname_LDADD = $(ARES_BLD_DIR)/src/lib/libcares.la $(CODE_COVERAGE_LIBS)
-
-dnsdump_SOURCES = $(DUMPSOURCES)
-dnsdump_LDADD = $(ARES_BLD_DIR)/src/lib/libcares.la $(CODE_COVERAGE_LIBS)
-
-test: check