summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-24 09:54:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-24 09:54:44 +0000
commit836b47cb7e99a977c5a23b059ca1d0b5065d310e (patch)
tree1604da8f482d02effa033c94a84be42bc0c848c3 /fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-836b47cb7e99a977c5a23b059ca1d0b5065d310e.tar.xz
netdata-836b47cb7e99a977c5a23b059ca1d0b5065d310e.zip
Merging upstream version 1.46.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app')
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/CMakeLists.txt98
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/assert.h20
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/ctype.h28
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/errno.h20
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/fcntl.h20
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/inttypes.h21
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/limits.h34
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/pthread.h91
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/semaphore.h44
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdarg.h27
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdbool.h19
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdint.h91
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdio.h30
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdlib.h28
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/string.h36
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/strings.h20
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/share/defined-symbols.txt87
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wamr_toolchain.cmake34
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wasi_toolchain.cmake17
19 files changed, 0 insertions, 765 deletions
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/CMakeLists.txt b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/CMakeLists.txt
deleted file mode 100644
index 2e115cf4..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/CMakeLists.txt
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright (C) 2019 Intel Corporation. All rights reserved.
-# SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
-
-cmake_minimum_required(VERSION 2.8)
-project(app-framework)
-
-SET (CMAKE_C_FLAGS "-O3")
-
-if (NOT DEFINED WAMR_BUILD_SDK_PROFILE)
- set (WAMR_BUILD_SDK_PROFILE "default")
-endif ()
-
-if (NOT DEFINED CONFIG_PATH)
- set (CONFIG_PATH ${CMAKE_CURRENT_LIST_DIR}/../wamr_config_default.cmake)
- message(STATUS "CONFIG_PATH set to ${CONFIG_PATH} ")
-endif ()
-
-if (NOT EXISTS "${CONFIG_PATH}")
- message (FATAL_ERROR "${CONFIG_PATH} not exist")
-endif ()
-
-include(${CONFIG_PATH})
-
-if (NOT DEFINED OUT_DIR)
- set (OUT_DIR "${CMAKE_CURRENT_LIST_DIR}/../out/${WAMR_BUILD_SDK_PROFILE}")
-endif ()
-set (APP_SDK_DIR "${OUT_DIR}/app-sdk")
-
-if (DEFINED EXTRA_SDK_INCLUDE_PATH)
- message(STATUS, "EXTRA_SDK_INCLUDE_PATH = ${EXTRA_SDK_INCLUDE_PATH} ")
- include_directories (
- ${EXTRA_SDK_INCLUDE_PATH}
- )
-endif ()
-
-if (WAMR_BUILD_LIBC_BUILTIN EQUAL 1)
- set (SYSROOT_DIR "${APP_SDK_DIR}/libc-builtin-sysroot")
- execute_process(COMMAND ${CMAKE_COMMAND} -E make_directory ${SYSROOT_DIR}/include)
- execute_process(COMMAND ${CMAKE_COMMAND} -E make_directory ${SYSROOT_DIR}/share)
- execute_process(COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_LIST_DIR}/libc-builtin-sysroot/share/defined-symbols.txt ${SYSROOT_DIR}/share)
- execute_process(COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_LIST_DIR}/wamr_toolchain.cmake ${APP_SDK_DIR})
- execute_process(
- COMMAND ${CMAKE_COMMAND}
- -E copy_directory ${CMAKE_CURRENT_LIST_DIR}/libc-builtin-sysroot/include ${SYSROOT_DIR}/include
- )
-else()
- if (WAMR_BUILD_LIBC_WASI EQUAL 1)
- set (SYSROOT_DIR "${APP_SDK_DIR}/wasi-sysroot")
- message("sysroot: ${SYSROOT_DIR}")
- execute_process(COMMAND ln -s ${WASI_SDK_DIR}/share/wasi-sysroot ${SYSROOT_DIR})
- execute_process(COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_LIST_DIR}/wasi_toolchain.cmake ${APP_SDK_DIR}/wamr_toolchain.cmake)
- endif ()
-endif()
-
-if (WAMR_BUILD_APP_FRAMEWORK EQUAL 1)
- message(WAMR_BUILD_APP_FRAMEWORK)
- set (APP_FRAMEWORK_INCLUDE_TYPE "APP")
- set (WAMR_APP_OUT_DIR "${APP_SDK_DIR}/wamr-app-framework")
-
- include(${CMAKE_CURRENT_LIST_DIR}/../../core/app-framework/app_framework.cmake)
-
- add_library(app_framework
- ${WASM_APP_SOURCE_ALL}
- )
-
- add_custom_command(
- TARGET app_framework POST_BUILD
-
- COMMAND ${CMAKE_COMMAND} -E make_directory ${WAMR_APP_OUT_DIR}/lib
- COMMAND ${CMAKE_COMMAND} -E make_directory ${WAMR_APP_OUT_DIR}/include/wa-inc
- COMMAND ${CMAKE_COMMAND} -E make_directory ${WAMR_APP_OUT_DIR}/share
- COMMAND ${CMAKE_COMMAND} -E copy_directory ${WASM_APP_BI_INC_DIR} ${WAMR_APP_OUT_DIR}/include/bi-inc
- COMMAND ${CMAKE_COMMAND} -E copy ${WASM_APP_BASE_DIR}/bh_platform.h ${WAMR_APP_OUT_DIR}/include
- COMMAND ${CMAKE_COMMAND} -E copy ${WASM_APP_BASE_DIR}/wasm_app.h ${WAMR_APP_OUT_DIR}/include
- COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_BINARY_DIR}/*.a ${WAMR_APP_OUT_DIR}/lib
-
- # bi-inc folder should also copy into runtime-sdk
- COMMAND ${CMAKE_COMMAND} -E make_directory ${OUT_DIR}/runtime-sdk/include
- COMMAND ${CMAKE_COMMAND} -E copy_directory ${WASM_APP_BI_INC_DIR} ${OUT_DIR}/runtime-sdk/include/bi-inc
- )
-
- # If app-framework is enabled, add the undefined-symbol list to the toolchain file
- if (WAMR_BUILD_LIBC_WASI EQUAL 1)
- file (APPEND
- ${APP_SDK_DIR}/wamr_toolchain.cmake
- "SET (CMAKE_EXE_LINKER_FLAGS \"\${CMAKE_EXE_LINKER_FLAGS},--allow-undefined-file=\${CMAKE_CURRENT_LIST_DIR}/wamr-app-framework/share/defined-symbols.txt\" CACHE INTERNAL \"\")"
- )
- endif ()
-
- FOREACH (dir IN LISTS WASM_APP_WA_INC_DIR_LIST)
- file (COPY ${dir} DESTINATION ${WAMR_APP_OUT_DIR}/include/)
- ENDFOREACH (dir)
-
- if (DEFINED EXTRA_SDK_INCLUDE_PATH)
- execute_process(COMMAND ${CMAKE_COMMAND} -E copy_directory ${EXTRA_SDK_INCLUDE_PATH} ${WAMR_APP_OUT_DIR}/include)
- endif ()
-
-endif()
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/assert.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/assert.h
deleted file mode 100644
index 534a90de..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/assert.h
+++ /dev/null
@@ -1,20 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_ASSERT_H
-#define _WAMR_LIBC_ASSERT_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-
-
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/ctype.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/ctype.h
deleted file mode 100644
index 1a3cd4e5..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/ctype.h
+++ /dev/null
@@ -1,28 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_CTYPE_H
-#define _WAMR_LIBC_CTYPE_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-int isupper(int c);
-int isalpha(int c);
-int isspace(int c);
-int isgraph(int c);
-int isprint(int c);
-int isdigit(int c);
-int isxdigit(int c);
-int tolower(int c);
-int toupper(int c);
-int isalnum(int c);
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/errno.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/errno.h
deleted file mode 100644
index 9e9cca19..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/errno.h
+++ /dev/null
@@ -1,20 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_ERRNO_H
-#define _WAMR_LIBC_ERRNO_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-
-
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/fcntl.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/fcntl.h
deleted file mode 100644
index a67c24a2..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/fcntl.h
+++ /dev/null
@@ -1,20 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_FCNTL_H
-#define _WAMR_LIBC_FCNTL_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-
-
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/inttypes.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/inttypes.h
deleted file mode 100644
index a04ec7be..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/inttypes.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_INTTYPES_H
-#define _WAMR_LIBC_INTTYPES_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-#include <stdint.h>
-
-
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/limits.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/limits.h
deleted file mode 100644
index d46fb4fc..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/limits.h
+++ /dev/null
@@ -1,34 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_LIMITS_H
-#define _WAMR_LIBC_LIMITS_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-#define CHAR_BIT 8
-#define SCHAR_MIN -128
-#define SCHAR_MAX 127
-#define UCHAR_MAX 255
-#define CHAR_MIN 0
-#define CHAR_MAX 127
-#define MB_LEN_MAX 1
-#define SHRT_MIN -32768
-#define SHRT_MAX +32767
-#define USHRT_MAX 65535
-#define INT_MIN -32768
-#define INT_MAX +32767
-#define UINT_MAX 65535
-#define LONG_MIN -2147483648
-#define LONG_MAX +2147483647
-#define ULONG_MAX 4294967295
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/pthread.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/pthread.h
deleted file mode 100644
index 10b3978e..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/pthread.h
+++ /dev/null
@@ -1,91 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIB_PTHREAD_H
-#define _WAMR_LIB_PTHREAD_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-#include <stdint.h>
-
-/* Data type define of pthread, mutex, cond and key */
-typedef unsigned int pthread_t;
-typedef unsigned int pthread_mutex_t;
-typedef unsigned int pthread_cond_t;
-typedef unsigned int pthread_key_t;
-
-/* Thread APIs */
-int
-pthread_create(pthread_t *thread, const void *attr,
- void *(*start_routine)(void *), void *arg);
-
-int
-pthread_join(pthread_t thread, void **retval);
-
-int
-pthread_detach(pthread_t thread);
-
-int
-pthread_cancel(pthread_t thread);
-
-pthread_t
-pthread_self(void);
-
-void
-pthread_exit(void *retval);
-
-/* Mutex APIs */
-int
-pthread_mutex_init(pthread_mutex_t *mutex, const void *attr);
-
-int
-pthread_mutex_lock(pthread_mutex_t *mutex);
-
-int
-pthread_mutex_unlock(pthread_mutex_t *mutex);
-
-int
-pthread_mutex_destroy(pthread_mutex_t *mutex);
-
-/* Cond APIs */
-int
-pthread_cond_init(pthread_cond_t *cond, const void *attr);
-
-int
-pthread_cond_wait(pthread_cond_t *cond, pthread_mutex_t *mutex);
-
-int
-pthread_cond_timedwait(pthread_cond_t *cond, pthread_mutex_t *mutex,
- uint64_t useconds);
-
-int
-pthread_cond_signal(pthread_cond_t *cond);
-
-int
-pthread_cond_broadcast(pthread_cond_t *cond);
-
-int
-pthread_cond_destroy(pthread_cond_t *cond);
-
-/* Pthread key APIs */
-int
-pthread_key_create(pthread_key_t *key, void (*destructor)(void *));
-
-int
-pthread_setspecific(pthread_key_t key, const void *value);
-
-void *
-pthread_getspecific(pthread_key_t key);
-
-int
-pthread_key_delete(pthread_key_t key);
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif /* end of _WAMR_LIB_PTHREAD_H */
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/semaphore.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/semaphore.h
deleted file mode 100644
index 2e086bdc..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/semaphore.h
+++ /dev/null
@@ -1,44 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIB_SEMAPHORE_H
-#define _WAMR_LIB_SEMAPHORE_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-#include <stdint.h>
-
-typedef unsigned int sem_t;
-
-/* Semaphore APIs */
-
-sem_t *
-sem_open(const char *name, int oflag, int mode, int val);
-
-int
-sem_wait(sem_t *sem);
-
-int
-sem_trywait(sem_t *sem);
-
-int
-sem_post(sem_t *sem);
-
-int
-sem_getvalue(sem_t *restrict sem, int *sval);
-
-int
-sem_unlink(const char *name);
-
-int
-sem_close(sem_t *sem);
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif /* end of _WAMR_LIB_SEMAPHORE_H */
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdarg.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdarg.h
deleted file mode 100644
index 50959573..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdarg.h
+++ /dev/null
@@ -1,27 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_STDARG_H
-#define _WAMR_LIBC_STDARG_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-#ifndef _VA_LIST
-typedef __builtin_va_list va_list;
-#define _VA_LIST
-#endif
-#define va_start(ap, param) __builtin_va_start(ap, param)
-#define va_end(ap) __builtin_va_end(ap)
-#define va_arg(ap, type) __builtin_va_arg(ap, type)
-
-#define __va_copy(d, s) __builtin_va_copy(d, s)
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif /* end of _WAMR_LIBC_STDARG_H */
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdbool.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdbool.h
deleted file mode 100644
index 29e03f9d..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdbool.h
+++ /dev/null
@@ -1,19 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_STDBOOL_H
-#define _WAMR_LIBC_STDBOOL_H
-
-#define __bool_true_false_are_defined 1
-
-#ifndef __cplusplus
-
-#define bool _Bool
-#define false 0
-#define true 1
-
-#endif /* __cplusplus */
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdint.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdint.h
deleted file mode 100644
index 802e9ac5..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdint.h
+++ /dev/null
@@ -1,91 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_STDINT_H
-#define _WAMR_LIBC_STDINT_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-/* clang-format off */
-/* The word size of platform */
-#ifdef __wasm64__
-#define __WORDSIZE 64
-#else
-#define __WORDSIZE 32
-#endif
-
-typedef char int8_t;
-typedef short int int16_t;
-typedef int int32_t;
-typedef long long int int64_t;
-
-/* Unsigned. */
-typedef unsigned char uint8_t;
-typedef unsigned short int uint16_t;
-typedef unsigned int uint32_t;
-typedef unsigned long long int uint64_t;
-
-typedef __INTPTR_TYPE__ intptr_t;
-typedef __UINTPTR_TYPE__ uintptr_t;
-
-/* Signed and unsigned */
-#if __WORDSIZE == 64
-#define INT64_C(c) c ## L
-#define UINT64_C(c) c ## UL
-#define INTMAX_C(c) c ## L
-#define UINTMAX_C(c) c ## UL
-#else
-#define INT64_C(c) c ## LL
-#define UINT64_C(c) c ## ULL
-#define INTMAX_C(c) c ## LL
-#define UINTMAX_C(c) c ## ULL
-#endif
-
-
-/* Minimum of signed integral types. */
-# define INT8_MIN (-128)
-# define INT16_MIN (-32767-1)
-# define INT32_MIN (-2147483647-1)
-# define INT64_MIN (-INT64_C(9223372036854775807)-1)
-
-/* Maximum of signed integral types. */
-# define INT8_MAX (127)
-# define INT16_MAX (32767)
-# define INT32_MAX (2147483647)
-# define INT64_MAX (INT64_C(9223372036854775807))
-
-/* Maximum of unsigned integral types. */
-# define UINT8_MAX (255)
-# define UINT16_MAX (65535)
-# define UINT32_MAX (4294967295U)
-# define UINT64_MAX (UINT64_C(18446744073709551615))
-
-/* Values to test for integral types holding `void *' pointer. */
-#if __WORDSIZE == 64
-#define INTPTR_MIN INT64_MIN
-#define INTPTR_MAX INT64_MAX
-#define UINTPTR_MAX UINT64_MAX
-#else
-#define INTPTR_MIN INT32_MIN
-#define INTPTR_MAX INT32_MAX
-#define UINTPTR_MAX UINT32_MAX
-#endif
-
-/* Limit of `size_t' type. */
-#if __WORDSIZE == 64
-#define SIZE_MAX UINT64_MAX
-#else
-#define SIZE_MAX UINT32_MAX
-#endif
-
-/* clang-format on */
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdio.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdio.h
deleted file mode 100644
index 1d51e6dd..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdio.h
+++ /dev/null
@@ -1,30 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_STDIO_H
-#define _WAMR_LIBC_STDIO_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-#ifndef NULL
-# define NULL ((void*) 0)
-#endif
-
-typedef unsigned long size_t;
-
-int printf(const char *format, ...);
-int putchar(int c);
-int snprintf(char *str, size_t size, const char *format, ...);
-int sprintf(char *str, const char *format, ...);
-int puts(char *string);
-
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdlib.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdlib.h
deleted file mode 100644
index 7eb2cc4b..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/stdlib.h
+++ /dev/null
@@ -1,28 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_STDLIB_H
-#define _WAMR_LIBC_STDLIB_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-typedef unsigned long size_t;
-
-int atoi(const char *s);
-void exit(int status);
-long strtol(const char *nptr, char **endptr, register int base);
-unsigned long strtoul(const char *nptr, char **endptr, register int base);
-void *malloc(size_t size);
-void *calloc(size_t n, size_t size);
-void free(void *ptr);
-
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/string.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/string.h
deleted file mode 100644
index e71a168b..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/string.h
+++ /dev/null
@@ -1,36 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_STRING_H
-#define _WAMR_LIBC_STRING_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-typedef unsigned long size_t;
-
-int memcmp(const void *s1, const void *s2, size_t n);
-void *memcpy(void *dest, const void *src, size_t n);
-void *memmove(void *dest, const void *src, size_t n);
-void *memset(void *s, int c, size_t n);
-void *memchr(const void *s, int c, size_t n);
-int strncasecmp(const char *s1, const char *s2, size_t n);
-size_t strspn(const char *s, const char *accept);
-size_t strcspn(const char *s, const char *reject);
-char *strstr(const char *s, const char *find);
-char *strchr(const char *s, int c);
-int strcmp(const char *s1, const char *s2);
-char *strcpy(char *dest, const char *src);
-size_t strlen(const char *s);
-int strncmp(const char * str1, const char * str2, size_t n);
-char *strncpy(char *dest, const char *src, unsigned long n);
-char * strdup(const char *s);
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/strings.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/strings.h
deleted file mode 100644
index 7f1bec6f..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/include/strings.h
+++ /dev/null
@@ -1,20 +0,0 @@
-/*
- * Copyright (C) 2019 Intel Corporation. All rights reserved.
- * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
- */
-
-#ifndef _WAMR_LIBC_STRINGS_H
-#define _WAMR_LIBC_STRINGS_H
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-
-
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/share/defined-symbols.txt b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/share/defined-symbols.txt
deleted file mode 100644
index fc9c400a..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/libc-builtin-sysroot/share/defined-symbols.txt
+++ /dev/null
@@ -1,87 +0,0 @@
-wasm_open_connection
-wasm_close_connection
-wasm_send_on_connection
-wasm_config_connection
-wasm_sensor_open
-wasm_sensor_config
-wasm_sensor_config_with_attr_container
-wasm_sensor_close
-wasm_btn_native_call
-wasm_obj_native_call
-wasm_label_native_call
-wasm_cont_native_call
-wasm_page_native_call
-wasm_list_native_call
-wasm_ddlist_native_call
-wasm_cb_native_call
-wasm_register_resource
-wasm_response_send
-wasm_post_request
-wasm_sub_event
-wasm_create_timer
-wasm_timer_destroy
-wasm_timer_cancel
-wasm_timer_restart
-wasm_get_sys_tick_ms
-printf
-sprintf
-snprintf
-vprintf
-vsprintf
-vsnprintf
-puts
-putchar
-memcmp
-memcpy
-memmove
-memset
-strchr
-strcmp
-strcpy
-strlen
-strncmp
-strncpy
-malloc
-calloc
-realloc
-strdup
-free
-atoi
-bsearch
-exit
-strtol
-strtoul
-memchr
-strncasecmp
-strspn
-strcspn
-strstr
-isupper
-isalpha
-isspace
-isgraph
-isprint
-isdigit
-isxdigit
-tolower
-toupper
-isalnum
-pthread_create
-pthread_join
-pthread_detach
-pthread_cancel
-pthread_self
-pthread_exit
-pthread_mutex_init
-pthread_mutex_lock
-pthread_mutex_unlock
-pthread_mutex_destroy
-pthread_cond_init
-pthread_cond_wait
-pthread_cond_timedwait
-pthread_cond_signal
-pthread_cond_destroy
-pthread_key_create
-pthread_setspecific
-pthread_getspecific
-pthread_key_delete
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wamr_toolchain.cmake b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wamr_toolchain.cmake
deleted file mode 100644
index 58fc8834..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wamr_toolchain.cmake
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright (C) 2019 Intel Corporation. All rights reserved.
-# SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
-
-SET (CMAKE_SYSTEM_NAME Linux)
-SET (CMAKE_SYSTEM_PROCESSOR wasm32)
-SET (CMAKE_SYSROOT ${CMAKE_CURRENT_LIST_DIR}/libc-builtin-sysroot)
-
-
-IF (NOT (DEFINED WASI_SDK_DIR OR DEFINED CACHE{WASI_SDK_DIR}))
- MESSAGE (FATAL_ERROR "WASI_SDK_DIR is not defined")
-ELSE ()
- MESSAGE (STATUS "WASI_SDK_DIR=${WASI_SDK_DIR}")
- LIST (APPEND CMAKE_TRY_COMPILE_PLATFORM_VARIABLES "WASI_SDK_DIR")
-ENDIF ()
-
-
-SET (CMAKE_C_FLAGS "-nostdlib -z stack-size=4096" CACHE INTERNAL "")
-SET (CMAKE_C_COMPILER_TARGET "wasm32")
-SET (CMAKE_C_COMPILER "${WASI_SDK_DIR}/bin/clang")
-
-SET (CMAKE_CXX_FLAGS "-nostdlib -z stack-size=4096" CACHE INTERNAL "")
-SET (CMAKE_CXX_COMPILER_TARGET "wasm32")
-SET (CMAKE_CXX_COMPILER "${WASI_SDK_DIR}/bin/clang++")
-
-SET (CMAKE_EXE_LINKER_FLAGS
- "-Wl,--initial-memory=65536,--no-entry,--strip-all" CACHE INTERNAL "")
-
-SET (CMAKE_LINKER "${WASI_SDK_DIR}/bin/wasm-ld" CACHE INTERNAL "")
-SET (CMAKE_AR "${WASI_SDK_DIR}/bin/llvm-ar" CACHE INTERNAL "")
-SET (CMAKE_NM "${WASI_SDK_DIR}/bin/llvm-nm" CACHE INTERNAL "")
-SET (CMAKE_OBJDUMP "${WASI_SDK_DIR}/bin/llvm-dwarfdump" CACHE INTERNAL "")
-SET (CMAKE_RANLIB "${WASI_SDK_DIR}/bin/llvm-ranlib" CACHE INTERNAL "")
-SET (CMAKE_EXE_LINKER_FLAGS
- "${CMAKE_EXE_LINKER_FLAGS},--allow-undefined-file=${CMAKE_SYSROOT}/share/defined-symbols.txt" CACHE INTERNAL "") \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wasi_toolchain.cmake b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wasi_toolchain.cmake
deleted file mode 100644
index f80c7377..00000000
--- a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/wamr-sdk/app/wasi_toolchain.cmake
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright (C) 2019 Intel Corporation. All rights reserved.
-# SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
-
-SET(CMAKE_SYSTEM_NAME Linux)
-
-if (NOT DEFINED WASI_SDK_DIR)
- SET (WASI_SDK_DIR "/opt/wasi-sdk")
-endif ()
-
-SET (CMAKE_C_COMPILER "${WASI_SDK_DIR}/bin/clang")
-SET (CMAKE_CXX_COMPILER "${WASI_SDK_DIR}/bin/clang++")
-
-SET (CMAKE_LINKER "${WASI_SDK_DIR}/bin/wasm-ld" CACHE INTERNAL "")
-SET (CMAKE_AR "${WASI_SDK_DIR}/bin/llvm-ar" CACHE INTERNAL "")
-SET (CMAKE_NM "${WASI_SDK_DIR}/bin/llvm-nm" CACHE INTERNAL "")
-SET (CMAKE_OBJDUMP "${WASI_SDK_DIR}/bin/llvm-dwarfdump" CACHE INTERNAL "")
-SET (CMAKE_RANLIB "${WASI_SDK_DIR}/bin/llvm-ranlib" CACHE INTERNAL "")