summaryrefslogtreecommitdiffstats
path: root/ml/dlib/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-24 09:54:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-24 09:54:44 +0000
commit836b47cb7e99a977c5a23b059ca1d0b5065d310e (patch)
tree1604da8f482d02effa033c94a84be42bc0c848c3 /ml/dlib/CMakeLists.txt
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-836b47cb7e99a977c5a23b059ca1d0b5065d310e.tar.xz
netdata-836b47cb7e99a977c5a23b059ca1d0b5065d310e.zip
Merging upstream version 1.46.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ml/dlib/CMakeLists.txt')
-rw-r--r--ml/dlib/CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/ml/dlib/CMakeLists.txt b/ml/dlib/CMakeLists.txt
deleted file mode 100644
index d3cf123f6..000000000
--- a/ml/dlib/CMakeLists.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-cmake_minimum_required(VERSION 2.8.12)
-
-
-
-
-#############################################################################
-# #
-# READ examples/CMakeLists.txt TO SEE HOW TO USE DLIB FROM C++ WITH CMAKE #
-# #
-#############################################################################
-
-
-
-
-
-get_directory_property(has_parent PARENT_DIRECTORY)
-if(NOT has_parent)
- # When you call add_subdirectory(dlib) from a parent CMake project dlib's
- # CMake scripts will assume you want to statically compile dlib into
- # whatever you are building rather than create a standalone copy of dlib.
- # This means CMake will build dlib as a static library, disable dlib's
- # install targets so they don't clutter your project, and adjust a few other
- # minor things that are convenient when statically building dlib as part of
- # your own projects.
- #
- # On the other hand, if there is no parent CMake project or if
- # DLIB_IN_PROJECT_BUILD is set to false, CMake will compile dlib as a normal
- # standalone library (either shared or static, based on the state of CMake's
- # BUILD_SHARED_LIBS flag), and include the usual install targets so you can
- # install dlib on your computer via `make install`. Since the only reason
- # to build this CMakeLists.txt (the one you are reading right now) by itself
- # is if you want to install dlib, we indicate as such by setting
- # DLIB_IN_PROJECT_BUILD to false.
- set(DLIB_IN_PROJECT_BUILD false)
-endif()
-add_subdirectory(dlib)