summaryrefslogtreecommitdiffstats
path: root/ml/dlib/tools/htmlify/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:20:02 +0000
commit58daab21cd043e1dc37024a7f99b396788372918 (patch)
tree96771e43bb69f7c1c2b0b4f7374cb74d7866d0cb /ml/dlib/tools/htmlify/CMakeLists.txt
parentReleasing debian version 1.43.2-1. (diff)
downloadnetdata-58daab21cd043e1dc37024a7f99b396788372918.tar.xz
netdata-58daab21cd043e1dc37024a7f99b396788372918.zip
Merging upstream version 1.44.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ml/dlib/tools/htmlify/CMakeLists.txt')
-rw-r--r--ml/dlib/tools/htmlify/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/ml/dlib/tools/htmlify/CMakeLists.txt b/ml/dlib/tools/htmlify/CMakeLists.txt
new file mode 100644
index 000000000..02cae2172
--- /dev/null
+++ b/ml/dlib/tools/htmlify/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# This is a CMake makefile. You can find the cmake utility and
+# information about it at http://www.cmake.org
+#
+
+cmake_minimum_required(VERSION 2.8.12)
+
+# create a variable called target_name and set it to the string "htmlify"
+set (target_name htmlify)
+
+project(${target_name})
+
+add_subdirectory(../../dlib dlib_build)
+
+# add all the cpp files we want to compile to this list. This tells
+# cmake that they are part of our target (which is the executable named htmlify)
+add_executable(${target_name}
+ htmlify.cpp
+ to_xml.cpp
+ )
+
+# Tell cmake to link our target executable to dlib.
+target_link_libraries(${target_name} dlib::dlib )
+
+
+
+install(TARGETS ${target_name}
+ RUNTIME DESTINATION bin
+ )
+
+