summaryrefslogtreecommitdiffstats
path: root/netdata.spec.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-11-25 17:33:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-11-25 17:34:10 +0000
commit83ba6762cc43d9db581b979bb5e3445669e46cc2 (patch)
tree2e69833b43f791ed253a7a20318b767ebe56cdb8 /netdata.spec.in
parentReleasing debian version 1.47.5-1. (diff)
downloadnetdata-83ba6762cc43d9db581b979bb5e3445669e46cc2.tar.xz
netdata-83ba6762cc43d9db581b979bb5e3445669e46cc2.zip
Merging upstream version 2.0.3+dfsg (Closes: #923993, #1042533, #1045145).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'netdata.spec.in')
-rw-r--r--netdata.spec.in37
1 files changed, 28 insertions, 9 deletions
diff --git a/netdata.spec.in b/netdata.spec.in
index 67d7de4a0..e7cd1c3f5 100644
--- a/netdata.spec.in
+++ b/netdata.spec.in
@@ -196,6 +196,7 @@ Requires(pre): /usr/sbin/useradd
# to support weak dependencies. Explicitly requiring our default plugins
# makes it impossible to properly test the packages prior to upload,
# so we just skip depending on them on CentOS 7.
+Requires: %{name}-dashboard
%if 0%{?_have_ebpf}
Requires: %{name}-plugin-ebpf = %{version}
%endif
@@ -269,9 +270,9 @@ BuildRequires: cups-devel
# distro handling of versioning).
%if %{?_upstream_go_toolchain:0}%{!?_upstream_go_toolchain:1}
%if 0%{?suse_version}
-BuildRequires: go >= 1.22
+BuildRequires: go >= 1.23
%else
-BuildRequires: golang >= 1.22
+BuildRequires: golang >= 1.23
%endif
%endif
# end - go.d.plugin plugin dependencies
@@ -388,14 +389,14 @@ happened, on your systems and applications.
%else
-DENABLE_EXPORTER_MONGODB=Off \
%endif
- -DENABLE_ACLK=On \
- -DENABLE_CLOUD=On \
-DENABLE_DBENGINE=On \
-DENABLE_H2O=On \
-DENABLE_PLUGIN_APPS=On \
-DENABLE_PLUGIN_CGROUP_NETWORK=On \
-DENABLE_PLUGIN_DEBUGFS=On \
-DENABLE_PLUGIN_GO=On \
+ -DENABLE_PLUGIN_PYTHON=On \
+ -DENABLE_PLUGIN_CHARTS=On \
-DENABLE_PLUGIN_LOCAL_LISTENERS=On \
-DENABLE_PLUGIN_PERF=On \
-DENABLE_PLUGIN_SLABINFO=On \
@@ -551,11 +552,6 @@ rm -rf "${RPM_BUILD_ROOT}"
# ndsudo a helper to run privileged commands
%attr(4750,root,netdata) %{_libexecdir}/%{name}/plugins.d/ndsudo
-# Enforce 0644 for files and 0755 for directories
-# for the netdata web directory
-%defattr(0644,root,root,0755)
-%{_datadir}/%{name}/web
-
# Enforce 0660 for files and 0770 for directories
# for the netdata lib, cache and log dirs
%defattr(0660,root,netdata,0770)
@@ -565,6 +561,9 @@ rm -rf "${RPM_BUILD_ROOT}"
%attr(0770,netdata,netdata) %dir %{_localstatedir}/lib/%{name}/registry
%attr(0770,netdata,netdata) %dir %{_localstatedir}/lib/%{name}/cloud.d
+# Dashboard belongs to a different sub-package
+%exclude %{_datadir}/%{name}/web
+
# Free IPMI belongs to a different sub-package
%if %{_have_freeipmi}
%exclude %{_libexecdir}/%{name}/plugins.d/freeipmi.plugin
@@ -987,7 +986,27 @@ fi
# CAP_SYS_ADMIN, CAP_SYS_PTRACE and CAP_DAC_READ_SEARCH needed for data collection.
%caps(cap_sys_admin,cap_sys_ptrace,cap_dac_read_search=ep) %attr(0750,root,netdata) %{_libexecdir}/%{name}/plugins.d/network-viewer.plugin
+%package dashboard
+Summary: The local dashboard for the Netdata Agent
+Group: Applications/System
+Requires: %{name} >= %{version}
+Conflicts: %{name} < %{version}
+
+%description dashboard
+ This allows access to the dashboard on the local node without internet access.
+
+%pre dashboard
+if ! getent group %{name} > /dev/null; then
+ groupadd --system %{name}
+fi
+
+%files dashboard
+%defattr(0644,root,root,0755)
+%{_datadir}/%{name}/web
+
%changelog
+* Thu Aug 29 2024 Austin Hemmelgarn <austin@netdata.cloud>
+- Split dashboard to it’s own package
* Fri Jul 19 2024 Austin Hemmelgarn <austin@netdata.cloud>
- Fix dependency issues with old logs-management plugin
* Tue Jul 16 2024 Austin Hemmelgarn <austin@netdata.cloud>