summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:18 +0000
commit5da14042f70711ea5cf66e034699730335462f66 (patch)
tree0f6354ccac934ed87a2d555f45be4c831cf92f4a /src/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-5da14042f70711ea5cf66e034699730335462f66.tar.xz
netdata-5da14042f70711ea5cf66e034699730335462f66.zip
Merging upstream version 1.45.3+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt')
-rw-r--r--src/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt b/src/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt
new file mode 100644
index 000000000..3321956dd
--- /dev/null
+++ b/src/fluent-bit/lib/c-ares-1.19.1/include/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Write ares_build.h configuration file. This is an installed file.
+CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h)
+
+# Headers installation target
+IF (CARES_INSTALL)
+ SET (CARES_HEADERS ares.h ares_version.h "${PROJECT_BINARY_DIR}/ares_build.h" ares_rules.h ares_dns.h ares_nameser.h)
+ INSTALL (FILES ${CARES_HEADERS} COMPONENT Devel DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+ENDIF ()