summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/lib/jansson-e23f558/doc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:18 +0000
commit5da14042f70711ea5cf66e034699730335462f66 (patch)
tree0f6354ccac934ed87a2d555f45be4c831cf92f4a /src/fluent-bit/lib/jansson-e23f558/doc/Makefile.am
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-5da14042f70711ea5cf66e034699730335462f66.tar.xz
netdata-5da14042f70711ea5cf66e034699730335462f66.zip
Merging upstream version 1.45.3+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/fluent-bit/lib/jansson-e23f558/doc/Makefile.am')
-rw-r--r--src/fluent-bit/lib/jansson-e23f558/doc/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/fluent-bit/lib/jansson-e23f558/doc/Makefile.am b/src/fluent-bit/lib/jansson-e23f558/doc/Makefile.am
new file mode 100644
index 000000000..8186a7db8
--- /dev/null
+++ b/src/fluent-bit/lib/jansson-e23f558/doc/Makefile.am
@@ -0,0 +1,20 @@
+EXTRA_DIST = conf.py apiref.rst changes.rst conformance.rst \
+ gettingstarted.rst github_commits.c index.rst threadsafety.rst \
+ tutorial.rst upgrading.rst ext/refcounting.py
+
+SPHINXBUILD = sphinx-build
+SPHINXOPTS = -d _build/doctrees $(SPHINXOPTS_EXTRA)
+
+html-local:
+ $(SPHINXBUILD) -b html $(SPHINXOPTS) $(srcdir) _build/html
+
+install-html-local: html
+ mkdir -p $(DESTDIR)$(htmldir)
+ cp -r _build/html $(DESTDIR)$(htmldir)
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(htmldir)
+
+clean-local:
+ rm -rf _build
+ rm -f ext/refcounting.pyc