summaryrefslogtreecommitdiffstats
path: root/src/fluent-bit/plugins/in_windows_exporter_metrics/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:18 +0000
commit5da14042f70711ea5cf66e034699730335462f66 (patch)
tree0f6354ccac934ed87a2d555f45be4c831cf92f4a /src/fluent-bit/plugins/in_windows_exporter_metrics/CMakeLists.txt
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-5da14042f70711ea5cf66e034699730335462f66.tar.xz
netdata-5da14042f70711ea5cf66e034699730335462f66.zip
Merging upstream version 1.45.3+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/fluent-bit/plugins/in_windows_exporter_metrics/CMakeLists.txt')
-rw-r--r--src/fluent-bit/plugins/in_windows_exporter_metrics/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/fluent-bit/plugins/in_windows_exporter_metrics/CMakeLists.txt b/src/fluent-bit/plugins/in_windows_exporter_metrics/CMakeLists.txt
new file mode 100644
index 000000000..8cc7fe70a
--- /dev/null
+++ b/src/fluent-bit/plugins/in_windows_exporter_metrics/CMakeLists.txt
@@ -0,0 +1,28 @@
+set(src
+ we_config.c
+ we.c
+ we_cpu.c
+ we_os.c
+ we_net.c
+ we_logical_disk.c
+ we_cs.c
+ we_wmi.c
+ we_util.c
+ we_metric.c
+ we_perflib.c
+ we_wmi_thermalzone.c
+ we_wmi_cpu_info.c
+ we_wmi_logon.c
+ we_wmi_system.c
+ we_wmi_service.c
+ we_wmi_memory.c
+ we_wmi_paging_file.c
+ we_wmi_process.c
+ )
+
+set(libs
+ wbemuuid
+ netapi32
+)
+
+FLB_PLUGIN(in_windows_exporter_metrics "${src}" "${libs}")