summaryrefslogtreecommitdiffstats
path: root/src/ml/dlib/tools/htmlify/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:08:18 +0000
commit5da14042f70711ea5cf66e034699730335462f66 (patch)
tree0f6354ccac934ed87a2d555f45be4c831cf92f4a /src/ml/dlib/tools/htmlify/CMakeLists.txt
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-5da14042f70711ea5cf66e034699730335462f66.tar.xz
netdata-5da14042f70711ea5cf66e034699730335462f66.zip
Merging upstream version 1.45.3+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/ml/dlib/tools/htmlify/CMakeLists.txt')
-rw-r--r--src/ml/dlib/tools/htmlify/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/ml/dlib/tools/htmlify/CMakeLists.txt b/src/ml/dlib/tools/htmlify/CMakeLists.txt
new file mode 100644
index 000000000..02cae2172
--- /dev/null
+++ b/src/ml/dlib/tools/htmlify/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# This is a CMake makefile. You can find the cmake utility and
+# information about it at http://www.cmake.org
+#
+
+cmake_minimum_required(VERSION 2.8.12)
+
+# create a variable called target_name and set it to the string "htmlify"
+set (target_name htmlify)
+
+project(${target_name})
+
+add_subdirectory(../../dlib dlib_build)
+
+# add all the cpp files we want to compile to this list. This tells
+# cmake that they are part of our target (which is the executable named htmlify)
+add_executable(${target_name}
+ htmlify.cpp
+ to_xml.cpp
+ )
+
+# Tell cmake to link our target executable to dlib.
+target_link_libraries(${target_name} dlib::dlib )
+
+
+
+install(TARGETS ${target_name}
+ RUNTIME DESTINATION bin
+ )
+
+