summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-21 17:19:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-21 17:19:04 +0000
commit310edf444908b09ea6d00c03baceb7925f3bb7a2 (patch)
tree7064577c7fa7a851e2e930beb606ea8237b0bbd2 /system
parentReleasing debian version 1.44.3-2. (diff)
downloadnetdata-310edf444908b09ea6d00c03baceb7925f3bb7a2.tar.xz
netdata-310edf444908b09ea6d00c03baceb7925f3bb7a2.zip
Merging upstream version 1.45.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'system')
-rw-r--r--system/Makefile.am136
-rwxr-xr-xsystem/install-service.sh.in2
-rw-r--r--system/netdata-updater.conf26
-rw-r--r--system/netdata.conf11
4 files changed, 25 insertions, 150 deletions
diff --git a/system/Makefile.am b/system/Makefile.am
deleted file mode 100644
index 1e96f6f4..00000000
--- a/system/Makefile.am
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright (C) 2015 Alon Bar-Lev <alon.barlev@gmail.com>
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-CLEANFILES = \
- install-service.sh \
- cron/netdata-updater-daily \
- freebsd/rc.d/netdata \
- initd/init.d/netdata \
- launchd/netdata.plist \
- logrotate/netdata \
- lsb/init.d/netdata \
- openrc/conf.d/netdata \
- openrc/init.d/netdata \
- runit/run \
- systemd/netdata.service \
- systemd/netdata.service.v235 \
- systemd/netdata-updater.service \
- $(NULL)
-
-include $(top_srcdir)/build/subst.inc
-SUFFIXES = .in
-
-dist_config_SCRIPTS = \
- edit-config \
- $(NULL)
-
-dist_config_DATA = \
- .install-type \
- netdata-updater.conf \
- $(NULL)
-
-libconfigvnodesdir=$(libconfigdir)/vnodes
-libsyscrondir=$(libsysdir)/cron
-libsysfreebsddir=$(libsysdir)/freebsd
-libsysfreebsdrcddir=$(libsysfreebsddir)/rc.d
-libsysinitddir=$(libsysdir)/initd
-libsysinitdinitddir=$(libsysinitddir)/init.d
-libsyslaunchddir=$(libsysdir)/launchd
-libsyslogrotatedir=$(libsysdir)/logrotate
-libsyslsbdir=$(libsysdir)/lsb
-libsyslsbinitddir=$(libsyslsbdir)/init.d
-libsysopenrcdir=$(libsysdir)/openrc
-libsysopenrcinitddir=$(libsysopenrcdir)/init.d
-libsysopenrcconfddir=$(libsysopenrcdir)/conf.d
-libsysrunitdir=$(libsysdir)/runit
-libsyssystemddir=$(libsysdir)/systemd
-
-# Explicitly install directories to avoid permission issues due to umask
-install-exec-local:
- $(INSTALL) -d $(DESTDIR)$(configdir)
- $(INSTALL) -d $(DESTDIR)$(libsysdir)
- $(INSTALL) -d $(DESTDIR)$(libsyscrondir)
- $(INSTALL) -d $(DESTDIR)$(libsysfreebsdrcddir)
- $(INSTALL) -d $(DESTDIR)$(libsysinitdinitddir)
- $(INSTALL) -d $(DESTDIR)$(libsyslaunchddir)
- $(INSTALL) -d $(DESTDIR)$(libsyslogrotatedir)
- $(INSTALL) -d $(DESTDIR)$(libsyslsbinitddir)
- $(INSTALL) -d $(DESTDIR)$(libsyssystemddir)
- $(INSTALL) -d $(DESTDIR)$(libsysopenrcinitddir)
- $(INSTALL) -d $(DESTDIR)$(libsysopenrcconfddir)
- $(INSTALL) -d $(DESTDIR)$(libsysrunitdir)
- $(INSTALL) -d $(DESTDIR)$(libconfigvnodesdir)
-
-dist_libconfigvnodes_DATA = \
- vnodes/vnodes.conf
- $(NULL)
-
-libexecnetdatadir=$(libexecdir)/netdata
-nodist_libexecnetdata_SCRIPTS = \
- install-service.sh \
- $(NULL)
-
-nodist_libsyscron_DATA = \
- cron/netdata-updater-daily \
- $(NULL)
-
-nodist_libsysfreebsdrcd_DATA = \
- freebsd/rc.d/netdata \
- $(NULL)
-
-nodist_libsysinitdinitd_DATA = \
- initd/init.d/netdata \
- $(NULL)
-
-nodist_libsyslaunchd_DATA = \
- launchd/netdata.plist \
- $(NULL)
-
-nodist_libsyslogrotate_DATA = \
- logrotate/netdata \
- $(NULL)
-
-nodist_libsyslsbinitd_DATA = \
- lsb/init.d/netdata \
- $(NULL)
-
-nodist_libsysopenrcinitd_DATA = \
- openrc/init.d/netdata \
- $(NULL)
-
-nodist_libsysopenrcconfd_DATA = \
- openrc/conf.d/netdata \
- $(NULL)
-
-nodist_libsysrunit_DATA = \
- runit/run \
- $(NULL)
-
-nodist_libsyssystemd_DATA = \
- systemd/netdata.service \
- systemd/netdata.service.v235 \
- systemd/netdata-updater.service \
- $(NULL)
-
-dist_libsyssystemd_DATA = \
- systemd/netdata-updater.timer \
- systemd/50-netdata.preset
- $(NULL)
-
-dist_noinst_DATA = \
- install-service.sh.in \
- netdata.conf \
- cron/netdata-updater-daily.in \
- freebsd/rc.d/netdata.in \
- initd/init.d/netdata.in \
- launchd/netdata.plist.in \
- logrotate/netdata.in \
- lsb/init.d/netdata.in \
- openrc/conf.d/netdata.in \
- openrc/init.d/netdata.in \
- runit/run.in \
- systemd/netdata.service.in \
- systemd/netdata.service.v235.in \
- systemd/netdata-updater.service.in \
- $(NULL)
diff --git a/system/install-service.sh.in b/system/install-service.sh.in
index cdd1bf52..226dca5d 100755
--- a/system/install-service.sh.in
+++ b/system/install-service.sh.in
@@ -630,6 +630,8 @@ install_darwin_service() {
exit 4
fi
+ launchctl unload /Library/LaunchDaemons/com.github.netdata.plist 2>/dev/null
+
if ! launchctl load /Library/LaunchDaemons/com.github.netdata.plist; then
error "Failed to load plist file."
exit 4
diff --git a/system/netdata-updater.conf b/system/netdata-updater.conf
index 09af046b..ac35131d 100644
--- a/system/netdata-updater.conf
+++ b/system/netdata-updater.conf
@@ -2,10 +2,30 @@
#
# When run non-interactively, the updater script will delay some
# random number of seconds up to NETDATA_UPDATER_JITTER before
-# actually running the update. The default is 3600 (one
-# hour). Most users should not need to change this.
+# actually running the update. The default is 3600 (one hour). Most
+# users should not need to change this.
#NETDATA_UPDATER_JITTER="3600"
+# By default, the updater will update to new major versions without asking
+# for user confirmation once we consider them ready for general usage.
+#
+# You can override this behavior by setting NETDATA_ACCEPT_MAJOR_VERSIONS
+# to a space separated list of major versions you are willing to update
+# to. Attempts to update to newer major versions not listed in this variable
+# will be treated as a fatal error.
+#
+# An empty value is equivalent to the default behavior.
+#
+# This only applies to static builds and local builds. If you are using
+# our native packages, use your package manager’s existing functionality
+# to prevent updates (for example, pinning versions on APT-based systems,
+# or the DNF versionlock plugin on RHEL/Fedora).
+#
+# To lock yourself to a specific major version, set this value to exactly
+# that major version number. For example, to stay on version 1.x even
+# if 2.x has been released, set this to a value of `1`.
+#NETDATA_ACCEPT_MAJOR_VERSIONS=''
+
# On systems using our native packages, the updater will by default
# attempt to install optional plugin packages that would be installed by
# default on clean installs if those packages are supported on the system.
@@ -13,7 +33,7 @@
# This behavior can be disabled on a per-package basis using the below
# variables. Setting the variable to a value other than 0 will disable
# the corresponding package (note that you still need to remove the package
-# yourself if you don0t want it, this just controls whether the updater
+# yourself if you don't want it, this just controls whether the updater
# will try to ensure it’s installed or not).
#
# NETDATA_NO_SYSTEMD_JOURNAL controls the `netdata-plugin-systemd-journal`
diff --git a/system/netdata.conf b/system/netdata.conf
index 94d9ab82..6131ab56 100644
--- a/system/netdata.conf
+++ b/system/netdata.conf
@@ -10,14 +10,3 @@
# or
# curl -o /etc/netdata/netdata.conf http://localhost:19999/netdata.conf
#
-# You can uncomment and change any of the options below.
-# The value shown in the commented settings, is the default value.
-#
-
-[global]
- run as user = netdata
-
- # default storage size - increase for longer data retention
- page cache size = 32
- dbengine multihost disk space = 256
-