summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/mruby/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:20:02 +0000
commit58daab21cd043e1dc37024a7f99b396788372918 (patch)
tree96771e43bb69f7c1c2b0b4f7374cb74d7866d0cb /web/server/h2o/libh2o/deps/mruby/Makefile
parentReleasing debian version 1.43.2-1. (diff)
downloadnetdata-58daab21cd043e1dc37024a7f99b396788372918.tar.xz
netdata-58daab21cd043e1dc37024a7f99b396788372918.zip
Merging upstream version 1.44.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/server/h2o/libh2o/deps/mruby/Makefile')
-rw-r--r--web/server/h2o/libh2o/deps/mruby/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/mruby/Makefile b/web/server/h2o/libh2o/deps/mruby/Makefile
new file mode 100644
index 000000000..4912f17e1
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/mruby/Makefile
@@ -0,0 +1,17 @@
+# mruby is using Rake (http://rake.rubyforge.org) as a build tool.
+# We provide a minimalistic version called minirake inside of our
+# codebase.
+
+RAKE = ruby ./minirake
+
+all :
+ $(RAKE)
+.PHONY : all
+
+test : all
+ $(RAKE) test
+.PHONY : test
+
+clean :
+ $(RAKE) clean
+.PHONY : clean