summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/yaml/include/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:20:02 +0000
commit58daab21cd043e1dc37024a7f99b396788372918 (patch)
tree96771e43bb69f7c1c2b0b4f7374cb74d7866d0cb /web/server/h2o/libh2o/deps/yaml/include/Makefile.am
parentReleasing debian version 1.43.2-1. (diff)
downloadnetdata-58daab21cd043e1dc37024a7f99b396788372918.tar.xz
netdata-58daab21cd043e1dc37024a7f99b396788372918.zip
Merging upstream version 1.44.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/server/h2o/libh2o/deps/yaml/include/Makefile.am')
-rw-r--r--web/server/h2o/libh2o/deps/yaml/include/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/yaml/include/Makefile.am b/web/server/h2o/libh2o/deps/yaml/include/Makefile.am
new file mode 100644
index 000000000..f81863cbb
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/yaml/include/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = yaml.h
+DOXYGEN_CFG = $(top_srcdir)/doc/doxygen.cfg
+
+nobase_include_HEADERS = $(INCLUDES)
+
+if DOXYGEN
+
+html: $(INCLUDES) $(DOXYGEN_CFG)
+ PACKAGE=$(PACKAGE) VERSION=$(VERSION) top_srcdir=$(top_srcdir) top_builddir=$(top_builddir) doxygen $(DOXYGEN_CFG)
+
+endif
+
+maintainer-clean-local:
+ -rm -rf $(top_builddir)/doc/html
+
+dist-hook: html
+ cp -a $(top_builddir)/doc/html $(top_distdir)/doc